• nvidia fan issue with Bumblebee


    Hello.

    I have a Asus R510-dm205d with nvidia gforce 950M. The problem is that when I enable bumblebeed.service and restart the SO, the gpu fan starts to working at max speed. What can I do?. This is what I have done:

    sudo pacman -Rc xf86-video-nouveau
    sudo pacman -S bumblebee mesa xf86-video-intel nvidia lib32-nvidia-utils lib32-virtualgl lib32-mesa-libgl nvidia-settings bbswitch
    sudo gpasswd -a $USER bumblebee
    sudo gpasswd -a $USER video
    sudo systemctl enable bumblebeed.service
    sudo shutdown -r now
    

    Thanks.

  • @felipejr233 Asus hardware lives on its own and is hardly controlled under Linux. Normally I’m avoiding at all costs to work with it.

    Anyway. The post is very clear and pleasant to read. A rare case.

    The commands and their sequence are absolutely correct. Bumblebee should work correctly also.

    Please, boot the computer, wait about 10 seconds, open the terminal, maximize its window, and run two commands in it. Then post back here the commands, as they were typed in, along with their full output. The commands are:

    optirun --status
    systemctl status bumblebeed
    

    The expected output looks like:

    ┌──[just]─[alexarm]:/1st/tmp$
    └─> optirun --status
    Bumblebee status: Ready (3.2.1-2016-05-20-Format:%h$). X inactive. Discrete video card is off.
    
    ┌──[just]─[alexarm]:/1st/tmp$
    └─> systemctl status bumblebeed
    ● bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
       Active: active (running) since Wed 2016-12-07 11:29:43 MSK; 31min ago
     Main PID: 723 (bumblebeed)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/bumblebeed.service
               └─723 /usr/bin/bumblebeed --use-syslog
    
    Dec 07 11:29:43 alexarm.net bumblebeed[723]: /usr/bin/bumblebeed 3.2.1-2016-05-20-Format:%h$ started
    Dec 07 11:29:43 alexarm.net systemd[1]: Started Bumblebee C Daemon.
    ┌──[just]─[alexarm]:/1st/tmp$
    └─>
    

    Edit

    After running two commands above, execute any command with optirun prefix. For example, simply print the currect directory:

    optirun pwd
    

    Does the fan slow down after that?

  • Hello just, thank you for the answer.

    I don’t have the laptop here rigth now. The fan only stops when I run shutdown. It never slow down. This is the output I get:

    optirun --status
      Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    optirun pwd
      /home/just
    optirun --status
      Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    

    Also, I tried:

    optirun glxgears -info
    

    It works properly, I can see the gears.

    Everything seems to work properly except the fan. Also I tried the follow:

    nvclock -f -F 70
    

    But it freezes the laptop. Maybe nvclock are not good for my gpu.

  • @felipejr233 Three notes.

    1. Please, run optirun --status command on your laptop, when you’ll have it with you.

    2. glxgears is not a right tool to test bumblebee. The only reliable, correct tool is glxspheres64. It is suggested by Bumblebee Project guys themselves.

    3. I never used nvclock, so can’t speak about it. bbswitch, from Bumblebee, which automatically runs on optirun’s exit, only powers off the Nvidia GPU. It doesn’t control cooler fans directly. If the laptop is (very) hot, the fans may continue to spin for some time, until the overall temperature decreases. Leave the laptop in idlle for some minutes, don’t run anything. It takes usually from 5 to 15 mins here until the fans slow down after running some program on Nvidia GPU.

  • Hello again just.

    Here is my outputs:

    portatil% sudo systemctl start bumblebeed
    
    [sudo] password for felipe: 
    portatil% optirun --status
    
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    portatil% systemctl status bumblebeed
    ● bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; disabled; vendor 
       Active: active (running) since Wed 2016-12-07 20:38:35 CET; 37s ago
     Main PID: 3431 (bumblebeed)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/bumblebeed.service
               └─3431 /usr/bin/bumblebeed
    
    dic 07 20:38:35 portatil systemd[1]: Started Bumblebee C Daemon.
    dic 07 20:38:35 portatil bumblebeed[3431]: [ 2669.689862] [INFO]/usr/bin/bumbleb
    lines 1-10/10 (END)
    

    When I run glxspheres64 , the figure doesn’t move and the output is:

    portatil% optirun glxspheres64 -info 
    Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
    Visual ID of window: 0x20
    Context is Direct
    OpenGL Renderer: GeForce GTX 950M/PCIe/SSE2
    

    optirun status:

    portatil% optirun --status
    Bumblebee status: Ready (3.2.1). X is PID 3489, 1 applications using bumblebeed.
    

    Thank you.

  • @felipejr233 A little bit too much info… Smth looks good, other looks strange.

    Let’s start from the beginning. Step by step, one thing at a time.

    Most importantly - why do you start bumblebeed by hand?

    sudo systemctl start bumblebeed
    

    It shouldn’t be started by hand, never. It must start automatically on boot. It controls both graphics and power. If it doesn’t run, I do believe that the fans are never turned off.

    So, the main and the only question is, for now - does bumblebeed start automaticaly on boot? Yes or no?

    Edit

    To answer the question, boot and simply run in terminal, as the first and only command:

    systemctl status bumblebeed
    

    There’s no need to start the daemon. After boot, it must be already loaded, enabled, active and running.

  • @just I only use “start” to try. When I run “sudo systemctl enable bumblebeed” and restart, the system behaves the same. That is, as soon as I log in (after restarting), the fan starts to run at maximum speed. I do not know what else I can do :( .

  • @felipejr233 said in nvidia fan issue with Bumblebee:

    @just I only use “start” to try. When I run “sudo systemctl enable bumblebeed” and restart, the system behaves the same. That is, as soon as I log in (after restarting), the fan starts to run at maximum speed. I do not know what else I can do :( .

    Enabling a service is a one-time action. It does nothing more than creating a softlink to a specific file (service). It is done to enable automatic service startup on subsequent boots.

    This action may fail, for various reasons. Apparently enabled service may not start automatically, for other reasons. I can’t see an answer to the question - does bumblebeed start on boot?

    Once the laptop was started up, simply run the command

    systemctl status bumblebeed
    

    and paste the result here.

  • @just Thank you for your answer. Here my output:

    > systemctl status bumblebeed                                        [email protected]
    ● bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor p
       Active: active (running) since Thu 2016-12-08 15:12:49 CET; 59s ago
     Main PID: 377 (bumblebeed)
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/bumblebeed.service
               └─377 /usr/bin/bumblebeed
    
    dic 08 15:12:49 portatil systemd[1]: Started Bumblebee C Daemon.
    dic 08 15:12:54 portatil bumblebeed[377]: [   17.966832] [INFO]/usr/bin/bumblebe
    
  • @felipejr233 Ok, very well. The bumblebeed daemon (service) is autostarted and is in the correct state.

    The next simple step is to verify your groups. Simply paste back here the output of the command

    groups
    
  • This is the output:

    wheel bumblebee video users
    
  • @felipejr233 Ok, you’re the member of two Bumblebee groups - bumblebee and video. This is correct.

    We’ll check bbswitch functionality now. It consists of two steps.

    1. Reboot the laptop

    2. Once rebooted, open the terminal and execute 3 (three) commands in sequence, one after another:

      optirun --status
      optirun pwd
      optirun --status
      

      The last command is the same as the first one. This is correct.

    Again, post back here the full output of all three commands, as you see it in terminal. It occupies less than 10 lines.

  • @just Ok. This is the output:

    optirun --status
      Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    optirun pwd
      /home/just
    optirun --status
      Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    
  • @felipejr233 It doesn’t seem to be an output in your terminal:

    • there’s no bash prompt, with your user name
    • the output is not formatted the same way as it looks when it’s actually executed
    • it’s hard to believe that you use the same user name as mine, which seems meaningless for most people

    Sorry, but it looks like you did a copy-paste from another source. I need to see the real, raw, not modified output, from your real laptop. Please, include the bash prompts in it - everything you see in the terminal, even the whole terminal window content.

    You can even make a screenshot of the terminal window, and paste it here.

  • Ok @just. Here is all the output:

    [oh-my-zsh] Random theme '/home/felipe/.oh-my-zsh/themes/wezm.zsh-theme' loaded...
    % optirun --status                                                            ~
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    % optirun pwd                                                                 ~
    /home/felipe
    % optirun --status                                                            ~
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    %         
    
  • @felipejr233 Ok, that’s fine. It’s the real output now :) . Almost surely bbswitch turns Nvidia GPU off when optirun exits. Which is the desired and expected behaviour.

    Let’s add a low-level check, to verify it even deeper… Again, reboot the computer, open the terminal, and this time run four commands:

    optirun --status
    optirun pwd
    optirun --status
    cat /proc/acpi/bbswitch
    

    First three are the same as before, but the last, fourth is a new one.

    Again, please post the full, raw, unmodified zsh output, including zsh prompts and your commands, as you enter them. Don’t be shy :) , zsh is a very good shell. A half of my Linux installations use zsh.

    Edit

    It’s late here. We’'ll continue tomorrow.

  • Hello @just

    This is the output:

    [oh-my-zsh] Random theme '/home/felipe/.oh-my-zsh/themes/rgm.zsh-theme' loaded...
    
    [email protected] ~
    0 % optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    
    [email protected] ~
    0 % optirun pwd
    /home/felipe
    
    [email protected] ~
    0 % optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    
    [email protected] ~
    0 % cat /proc/acpi/bbswitch
    0000:01:00.0 OFF
    
    

    And I love zsh XD.

  • I solve it adding acpi_osi=! acpi_osi=“Windows 2009” to kernel parameters. Thank you @just .

  • @felipejr233 Sorry for the delay with the answers. I’m not feeling good these days.

    I’m very glad you’ve found the solution. It’s not trivial, and I wasn’t aware of it. All checks, done by you, return good results, so it seemed problematic for me to find a solution. Oh, those Asus :)

    I must study your solution better. It deserves to go to our AnteWiki. For now, it goes directly to my personal desktop WIki - Zim :) .

    Good job!

nvidia99 fan4 bumblebee29 Posts 19Views 866
Log in to reply