• clean installation, keyboard isn't detected, not possible to login


    New clean installation is working but not possible to login because laptop keyboard and usb external keyboard isn’t detected, only mouse works at login screen. Because that, it isn’t possible to login.

    Somebody has a possible fix without reinstalling?

  • laptop keyboard and usb external keyboard isn’t detected

    That’s really, really odd.

    Does your keyboard work outside of X? (ie: can you Ctrl+Shift+F2 to tty2 and login?)

  • @karasu: Yes, very weird, with my previous Antergos installation this two keyboards where working. The differences between my previous and current installation are: now latest Antergos iso and i have chosen directly the Belgian keyboard while installing. Before i switch to Belgian keyboard on first boot. Can that be the reason: English system, but Belgian keyboard selected during installation?
    I will try Ctrl+Shift+F2 to tty2 login and come back.

  • @karasu: At which moment i have push the Ctrl+Shift+F2 keys?
    On boot, computer is almost immediatly at the blue Antergos screen.

    Trackpad and mouse are working, keyboard not, also no blinking cursor in password field.

  • @bartatantergos said

    At which moment i have push the Ctrl+Shift+F2 keys?

    Being in this screen, the login screen) if pressing Ctrl+Alt+F2" can you get into the tty screen?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch: No, because the keyboard isn’t detected, only mouse and track pad. All are usb devices and where working in my previous installed Antergos and still working in MacOs.

    Also strange that the same keyboard was working during installation. So, is it possible that there are files not installed?
    If yes, which files i have to search/replace?

  • I’d try to check whether or not the keyboard works in pure bash shell, without GUI.

    To boot into non-graphical mode with networking enabled, add the following parameter to the boot line:

    systemd.unit=multi-user.target
    
  • @just: Thanks. I have seen that command line at the bottom of the first bootloader menu. But how to get to the kernel command line? When i push E to get in the Edit selection or C to get in the GRUB command line and put that command plus ctrl x it doesn’t boot at all.

    Can you be more specific?
    Not too much experience in bootloader command lines.

  • @bartatantergos said in clean installation, keyboard isn't detected, not possible to login:


    Can you be more specific?

    Sorry, I can’t, as I don’t use the default Antergos Grub2 boot loader. Vaguely remember some basics about it.

    Yes, you should press e to edit the boot entry. It is made of two lines.

    The first one should start with kernel…. You want to edit this one.

    The second one should start with initrd…. Don’t modify it.

    At the bottom of the screen Grub2 displays a helpful info about all keys you may use for editing and booting with the modified boot entry. Read them. They are useful.

    Start to edit the first line. The one which starts with kernel….

    Do not change existing parameters. They are all good. Position the cursor at the end on the line, and add one new parameter. Separate it with one space from preceeding text. Place one more space after it.

    Simply add systemd.unit=multi-user.target at the end of the line.

    Leave the second boot line untouched.

    That’s it. You’ve added a one more parameter for the kernel. There’s no need to modify anything for initrd (the 2nd line).

    Hit ctrl+x (or F10 ?) to boot with the modified boot entry. Or another key, suggested by Grub2 for booting at the bottom of the screen.

  • @just: Already tried to put the command line there, but there are more then two lines, ±30 lines of command line? Most of them are the same but a lit different. Seams like savety rules, if the first doesn’t work try the next, and so on.

    Will try some out and see what happens. Thanks to clear this up!

  • @just: So, keyboard works outside X, and i am logged in as root but still in tty. What’s next, do i boot or boot without lightdm or gdm?

    Meanwhile i have tried to boot in lightdm without startx:

    sudo service lightdm start
    

    But the arch tty doen’t understand service.
    So for Arch:

    sudo lightdm start
    

    But of coarse, i come on the same login screen and keyboard not detected. :)

    What do i next?

  • @bartatantergos said in clean installation, keyboard isn't detected, not possible to login:

    @just: So, keyboard works outside X, and i am logged in as root…

    Never - again, never - log in as root. Unless you’re very familiar with Linux and know well what you’re doing.

    Log in in bash shell with your own, standard user name.

    So the keyabord works outside X, but not within it. It could be a little problem with X configuration.

    Please, answer two questions.

    1. What is your physical keyboard layout? Does it have one layout only, like English (US), or it has two layouts, English (US) + National One?

    2. Post back here the output of the command

      localectl
      

      You can run it bash shell, without any GUI.

    The syntax in your attempts to start systemd services is wrong. That’s why they don’t start. It would be better to clarify the keyboard issue first. Starting X (GUI) later is not a problem.

  • @just: No time till now, now back on track:

    keyboard layout:
    belgian latin

    command output:

    System Locale: LANG=nl_BE.UTF-8
    VC Keymap: be-latin1
    X11 Layout: be
    

    Weird, during installation i have choosen English as system language? Now it seams to be nl_BE?

    System language i choose always English but keyboard Belgian, because i am used to that and i don’t want a Dutch system.
    Can this be the problem, i have already had problems with the same language settings in the past.

    I have to do it by root, because new clean install and only admin user for now. I am quite used to MacOs terminal, but have to learn the Linux ones.

    Thanks to follow up.

  • @bartatantergos said in clean installation, keyboard isn't detected, not possible to login:

    @just: No time till now, now back on track:

    No problem at all.


    System language i choose always English but keyboard Belgian, because i am used to that and i don’t want a Dutch system.
    Can this be the problem, i have already had problems with the same language settings in the past.

    I think it may cause the problem. The situation with your keyboards layouts still doesn’t very clear for me. I don’t have a ready-to-use solution for you.

    As a rule of thumb it is better to use only English (US) for passwords. Any national language may be added later, to the installed system.

    Let’s start from the beginning. Continue to boot into bash shell, without GUI.

    Run the command

    sudo nano /etc/locale.gen
    

    Uncomment the en_US.UTF-8 UTF-8 locale. It corresponds to English (US).

    Uncomment any other locale(s) you wish to use.

    Save the file and exit from nano.

    Once at bash prompt. run the command

    sudo locale-gen
    

    It will (re)generate system locales, including the changes you’ve just made. To see all enabled locales, simply run

    locale -a
    

    The list will include locales, enabled by you, and also C and POSIX locales - this is correct.

    Next, check the keyboard layout used in terminal window and VTs. Run the command

    sudo nano /etc/vconsole.conf
    

    You should see smth like:

    KEYMAP=uk
    

    I’m on the computer with English (UK) keyboard now. So vconsole.conf is set to use the English (UK) keyboard.

    The value, used in KEYMAP= field, must correspond to the main, physical keybord layout.

    Now, I’m a bit in difficulty, as all my computers have either English (US) or English (UK) main keyboard layouts, plus various national layouts (Italian, Finnish, Russin). All these computers have either KEYMAP=us or KEYMAP=uk in vconsole.conf.

    Probably, you should have KEYMAP=be there, if you have only one, Belgium physical keyboard layout.

    Start playing with these settings. We’ll decide later how to proceed.

  • @just: Thanks, but that didn’t work. I was able to login by putting the admin user to the autologin group: https://wiki.archlinux.org/index.php/LightDM#Enabling_autologin

    Then when logged in i have put all language settings to English US, tested and after that i have put all autologin settings again off.

    And big surprise, i wasn’t able to login because no blinking cursor in the password field. So, i got pist off and while clicking wild around i grab accidently with the mouse an icon from the login interface and put it in the password field.
    This activated the blinking cursor in the password field and in that way i am able to login.

    Now on every boot i have to grab a login interface icon, drag it to the password field, delete the content in that field and enter my password. Seams a problem with webkit2 ?!

    Idea to fix this in lightdm or better to get rid of lightdm and go for gdm?
    Is gdm already installed in Antergos or do i have to install it?
    Or a faster simpler one-click login screen?

  • @bartatantergos please, update your system (I’m guessing, but I’m 90% sure you’re facing an old bug):

    sudo pacman -Syu

  • @karasu: Old bug in iso from october, ant-16.10?
    But, ok tomorrow i try that update.

  • @karasu: Ok, many hours lost to find out that this is a known bug?
    But ok, again i have learned a lot about linux. ;-)
    @just: Thanks and sorry for your time!
    Will put this post as solved when i have done and tested the update.

  • @karasu: Done update and problem is solved!
    Is there a way that such important bugs that gives problems already at the beginning of a clean install and/or at login screen are mailed/posted to all forum members?

    So, that every Antergos user knows that this exists?
    Could be handy for in the future. :)

    Ok, i know next time i do always first an update!

    Thanks to all to get me thru this.

detected7 installation192 clean2 keyboard34 Posts 22Views 1361
Log in to reply