• Like 0

    Grub missing in EFI after succesfull installation


    Re: Grub missing after successful install

    During my research why Cnchi isn’t installing GRUB in the EFI partition and in /boot/efi whitout giving an error, i found out a few things. This happens on PC and on Mac computers.
    In my situation i have find out that it is, like i mentioned before, because that my computer (Mac) has two hard drives with each an EFI partition. After deleting (free space!) the unneeded EFI partition, the installation works smooth.
    In the topic that i am referring to it seams that the EFI partition isn’t the first partition but the second.

    I start to think that despite choosing the right EFI partition and /boot/efi in Cnchi the installer does install the system properly but doesn’t install the GRUB in EFI partition because it isn’t the first partition or there are more then one EFI partitions.

    Done tests and on my computer that’s what happening, after deleting (free space!) the second EFI partition, the installation went smooth and all worked fine, exept now my laptop keyboard doesn’t work with Antergos but that’s another story.

    Could this be the problem for a lot of proper installations but no grub installed in the EFI partition, while Cnchi doesn’t give an error at all?

    __
    Plus other small problem since latest live iso: when booting from live usb key on a Mac the screen stays black, nothing to see.
    So, it seams that the live usb isn’t booting but when you push the display light button on the keyboard then you notice that all worked nice. Confuse a cat! :-)
    So, in one way or another the new live iso puts the display light off while booting on a Mac. I don’t have a PC to test.

  • Like 0

    Get rescatux [http://www.supergrubdisk.org/rescatux/](link url) and watch a youtube video, you should be fine then.

    It helped me when I resized partitions or clonzilla copied disks and destroyed my boot loader. It always fixed it without much hazzle.

  • Like 0

    @dirkme: Ok, will check that out. But it would be better that we understand why Grub isn’t installed in EFI and why the installer doesn’t give an error at all. Then maybe there can be a fix, when this can be fixed of coarse.

cnchi95 cnchi 0.14.1982 efi5 installation168 Posts 3Views 238
Log in to reply