• Touchpad works but control panel says not detected


    I’m running on a Dell Latitude E5470, brand new one with a full install of plasma.

    My touchpad works, but the control panel says its not detected. Result is that none of the settings work. I want to reverse the scrolling but the only way to do that is by changing mouse settings, and then the scrollwheel of my mouse is reversed which is not what I want :).

    xinput list shows the following:

    $ xinput list
    ⎡ Virtual core pointer                          id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ ImPS/2 BYD TouchPad                       id=11   [slave  pointer  (2)]
    ⎜   ↳ DELL Laser Mouse                          id=14   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
        ↳ Power Button                              id=6    [slave  keyboard (3)]
        ↳ Video Bus                                 id=7    [slave  keyboard (3)]
        ↳ Power Button                              id=8    [slave  keyboard (3)]
        ↳ Sleep Button                              id=9    [slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
        ↳ Dell WMI hotkeys                          id=12   [slave  keyboard (3)]
        ↳ DELL Wireless hotkeys                     id=13   [slave  keyboard (3)]
        ↳ Dell Dell Multimedia Pro Keyboard         id=15   [slave  keyboard (3)]
        ↳ Dell Dell Multimedia Pro Keyboard         id=16   [slave  keyboard (3)]
    
    

    As you can see its detected as “ImPS/2 BYD TouchPad”. I searched but can’t really find how to make this work.

    If anyone has any ideas please share :).

    Thanks for the help!

  • Try:
    sudo pacman -S xf86-input-libinput && sudo pacman -R xf86-input-synaptics && sudo mv /etc/X11/xorg.conf.d/50-synaptics.conf ~/

    If this doesn’t work, you can rollback your changes with this:
    sudo pacman -R xf86-input-libinput && sudo pacman -S xf86-input-synaptics && sudo mv ~/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf

  • @denlud said in Touchpad works but control panel says not detected:

    Try:
    sudo pacman -S xf86-input-libinput && sudo pacman -R xf86-input-synaptics && sudo mv /etc/X11/xorg.conf.d/50-synaptics.conf ~/

    If this doesn’t work, you can rollback your changes with this:
    sudo pacman -R xf86-input-libinput && sudo pacman -S xf86-input-synaptics && sudo mv ~/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf

    Hey thanks for the reply.

    I tried it, rebooted but it is still the same. Touchpad is not detected and I can’t reverse scrolling.

    :(

control9 detected7 touchpad30 panel17 Posts 3Views 343
Log in to reply