• repo problem


    well,i am a noob,as u can see by writing in here,i wanna try to do some experiment in working and bringing android 7.1 to a device i own,but when i try to initialize repo,i get an error mesage,that is not working with python 3 and to rolle back to python 2.6-2.7,is there any way to make it work without rolling back to an older python version,if is possible,what are the steps i have to fallow ?

  • python2 PROGRAMNAME.py
    

    You can choose the Version like this no need to fallback…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad ty but i am not talkin about the repo of linux,i am talking about the repo for android,i don’t have a comand line including python,i think that the repo file use the commands from the python or somethin like that,and every time i use the comand : repo init , i get the error i mentionated

  • But why then you are asking your question on a Linux Forum???
    Also your Question is likely unclear on what you are doing and what your problem is…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad ok,thing is this,i wanna compile an android kernel and all the rest of a rom,thing is that using the app called repo to get all the necesary files for compiling need the python,python 2.6-2.7 and i have the last version of python 3.ish,which is giving me an error in the moment i try to start the repo,well,i doubt that windows know how to do all that (as a fact,all the how to i search in internet are talkin about linux and not windows) and as far as i know python is part of linux,now the question i asked,i will ask it again : how to make that repo work with python 3.ish that i have without to rolle back the python to an older version ? is there a way ?

repo15 Posts 6Views 562
Log in to reply