• octopi wont commit foreign packages


    Hey everyone, i seem to be having a problem with octopi, it wont commit any foreign packages for whatever reason, non-foreign packages do not have this issue.

  • Yes, I confirm the same problem. Octopi does not install packages from AUR.
    It does update but no fresh install.

    Never to old to learn.

  • Hi, according to their site https://github.com/aarnt/octopi you need to install yaourt or pacaur to work. Did you check if it’s missing some package or library?
    Cheers

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • i have yaourt installed, and it dosnt seem to be missing any package.

  • Yaourt is not the problem. Usually I use yaourt in konsole or use Pamac. I wanted to give Octopi a try because it is Qt5 based, and integrates better in Plasma.

    My impression is that it somehow can not connect to, or open a terminal. There are no logs and opening Octopi in konsole does not give any information.
    When initiating an install it will show the following message:
    Running command in terminal… Command finished OK!
    Then nothing happens.

    It most likely is a bug in Octopi.

    Never to old to learn.

  • @axioma well, i don’t use octopi (pamac and terminal do what i need) , but here is a link comparing pamac vs octopi
    https://www.youtube.com/watch?v=Qv_xORkHE8M

    Cheers.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto Yes, I am aware of the differences, and as I said, I mainly use Pamac or terminal to install packages.

    The problem is that currently Octopi does not seem to be able to install AUR packages. That is a bug that should not be there. I have used Octopi often enough in other distributions like Manjaro and Arch, and never had a problem with it in the past.

    Never to old to learn.

  • @axioma i understand.
    We have to wait for the bug get fixed.
    Cheers.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I, too, don t use Octopi, so I can t really tell if it s a bug or not. But thinking of pamac not searching the AUR by default, maybe is this the case, too?
    Check this vid out (2.50 min. and forward). Is this the case?
    https://www.youtube.com/watch?v=6W2IqkWCW9U&t=204s

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch The problem is with the installing. Octopi now gives you an icon to click on when you want to install through Yaourt. It also lists all available packages. They just don’t install. I got the impression that somehow Octopi is not able to open a terminal window to complete the process.

    While I write this I am installing a vanilla Arch system in Vbox to test Octopi there too. Just to make sure it is an Octopi problem. I will get back to it later after some more testing.

    Never to old to learn.

  • I tried Octopi in Arch and Kaos, and in both cases it worked without problem.
    Somehow Octopi is prevented to open a terminal window when installing or updating Aur/yaourt packages in Antergos.

    @Spore If you want to use Octopi, the git version does work well. using terminal:
    yaourt octopi-git
    Select ‘yes’ when asked if you want to replace Octopi with Octopi-git.

    Note: I have not tested Octopi in a different DE then Plasma, but presume it would give the same error.

    Never to old to learn.

commit4 foreign1 octopi7 Posts 11Views 579
Log in to reply