• \[SOLVED\] Failed to start Remount Root & Kernel File Systems


    Hi. I am new to Antergos and so far, I like it. But there is something bugging me right now during boot; it’s the error “Failed to start Remount Root and Kernel File Systems.”

    Here’s the result of [b:eq6sq5yc]systemctl -l status systemd-remount-fs[/b:eq6sq5yc]:

      
    systemd-remount-fs.service - Remount Root and Kernel File Systems  
    Loaded: loaded (/usr/lib/systemd/system/systemd-remount-fs.service; static)  
    Active: failed (Result: exit-code) since Mon 2014-03-17 08:42:29 PHT; 1h 5min ago  
    Docs: man:systemd-remount-fs.service(8)  
    http://www.freedesktop.org/wiki/Software/systemd/APIFileSystems  
    Process: 149 ExecStart=/usr/lib/systemd/systemd-remount-fs (code=exited, status=1/FAILURE)  
    Main PID: 149 (code=exited, status=1/FAILURE)  
      
    Mar 17 08:42:29 a10-5800k systemd[1]: systemd-remount-fs.service: main process exited, code=exited, status=1/FAILURE  
    Mar 17 08:42:29 a10-5800k systemd[1]: Failed to start Remount Root and Kernel File Systems.  
    Mar 17 08:42:29 a10-5800k systemd[1]: Unit systemd-remount-fs.service entered failed state.  
    Mar 17 08:42:29 a10-5800k systemd-remount-fs[149]: mount: / not mounted or bad option  
    Mar 17 08:42:29 a10-5800k systemd-remount-fs[149]: In some cases useful info is found in syslog - try  
    Mar 17 08:42:29 a10-5800k systemd-remount-fs[149]: dmesg | tail or so.  
    Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.  
    
    

    Here’s my [b:eq6sq5yc]/etc/fstab[/b:eq6sq5yc]:

      
    \# /etc/fstab: static file system information.  
    \#  
    \# Use 'blkid' to print the universally unique identifier for a  
    \# device; this may be used with UUID= as a more robust way to name devices  
    \# that works even if disks are added and removed. See fstab(5).  
    \#  
    \# <file system\> <mount point\> <type\> <options\> <dump\> <pass\>  
    \#  
    UUID=06e43846-... swap swap defaults 0 0  
    UUID=24c0e112-... /home btrfs defaults 0 0  
    UUID=12be9a60-... / btrfs rw,relatime,data=ordered 0 0  
      
    UUID=ef8340b2-... /vol/backup xfs defaults 0 0  
    UUID=76867994-... /vol/wd-500G xfs defaults 0 0  
    
    

    Initially, the entry for [b:eq6sq5yc]root[/b:eq6sq5yc] was with [i:eq6sq5yc]pass=1[/i:eq6sq5yc] and I read in the Arch wiki that if using [b:eq6sq5yc]btrfs[/b:eq6sq5yc] then it should be 0. I’ve since set it to 0 but I still get the error during boot.

    Here’s the [b:eq6sq5yc]uname -a[/b:eq6sq5yc] result:

      
    Linux a10-5800k 3.13.6-1-ARCH \#1 SMP PREEMPT Fri Mar 7 22:47:48 CET 2014 x86\_64 GNU/Linux  
    
    

    My computer does start fine and I am able to do my activities with no issues but I am wondering why the error is being generated and I want to get rid of it. Hoping anyone from the forums can help.

  • Hi. I am new to Antergos and so far, I like it. But there is something bugging me right now during boot; it’s the error “Failed to start Remount Root and Kernel File Systems.”

    Here’s the result of [b:eq6sq5yc]systemctl -l status systemd-remount-fs[/b:eq6sq5yc]:

      
    systemd-remount-fs.service - Remount Root and Kernel File Systems  
    Loaded: loaded (/usr/lib/systemd/system/systemd-remount-fs.service; static)  
    Active: failed (Result: exit-code) since Mon 2014-03-17 08:42:29 PHT; 1h 5min ago  
    Docs: man:systemd-remount-fs.service(8)  
    http://www.freedesktop.org/wiki/Software/systemd/APIFileSystems  
    Process: 149 ExecStart=/usr/lib/systemd/systemd-remount-fs (code=exited, status=1/FAILURE)  
    Main PID: 149 (code=exited, status=1/FAILURE)  
      
    Mar 17 08:42:29 a10-5800k systemd[1]: systemd-remount-fs.service: main process exited, code=exited, status=1/FAILURE  
    Mar 17 08:42:29 a10-5800k systemd[1]: Failed to start Remount Root and Kernel File Systems.  
    Mar 17 08:42:29 a10-5800k systemd[1]: Unit systemd-remount-fs.service entered failed state.  
    Mar 17 08:42:29 a10-5800k systemd-remount-fs[149]: mount: / not mounted or bad option  
    Mar 17 08:42:29 a10-5800k systemd-remount-fs[149]: In some cases useful info is found in syslog - try  
    Mar 17 08:42:29 a10-5800k systemd-remount-fs[149]: dmesg | tail or so.  
    Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.  
    
    

    Here’s my [b:eq6sq5yc]/etc/fstab[/b:eq6sq5yc]:

      
    \# /etc/fstab: static file system information.  
    \#  
    \# Use 'blkid' to print the universally unique identifier for a  
    \# device; this may be used with UUID= as a more robust way to name devices  
    \# that works even if disks are added and removed. See fstab(5).  
    \#  
    \# <file system\> <mount point\> <type\> <options\> <dump\> <pass\>  
    \#  
    UUID=06e43846-... swap swap defaults 0 0  
    UUID=24c0e112-... /home btrfs defaults 0 0  
    UUID=12be9a60-... / btrfs rw,relatime,data=ordered 0 0  
      
    UUID=ef8340b2-... /vol/backup xfs defaults 0 0  
    UUID=76867994-... /vol/wd-500G xfs defaults 0 0  
    
    

    Initially, the entry for [b:eq6sq5yc]root[/b:eq6sq5yc] was with [i:eq6sq5yc]pass=1[/i:eq6sq5yc] and I read in the Arch wiki that if using [b:eq6sq5yc]btrfs[/b:eq6sq5yc] then it should be 0. I’ve since set it to 0 but I still get the error during boot.

    Here’s the [b:eq6sq5yc]uname -a[/b:eq6sq5yc] result:

      
    Linux a10-5800k 3.13.6-1-ARCH \#1 SMP PREEMPT Fri Mar 7 22:47:48 CET 2014 x86\_64 GNU/Linux  
    
    

    My computer does start fine and I am able to do my activities with no issues but I am wondering why the error is being generated and I want to get rid of it. Hoping anyone from the forums can help.

  • My best guess as to what is happening is that the mount is failing b/c “data=ordered” is not a valid option for btrfs. Did you add that or was it from installation? Change the line to this:

    UUID=12be9a60-... / btrfs rw,relatime,space\_cache,autodefrag,inode\_cache 0 0
    

    Actually its no longer required that the root even be listed in fstab because systemd will mount it anyway (which is why your boot still completes successfully after the failed mount). But, I recommend keeping it in fstab so it will mount with the options in my example. Let me know if that helps!

    Best Regards,
    Dustin

  • @“lots.0.logs”:1n4kily0 said:

    UUID=12be9a60-... / btrfs rw,relatime,space\_cache,autodefrag,inode\_cache 0 0
    

    This did it! Thanks.

    @“lots.0.logs”:1n4kily0 said:

    Did you add that or was it from installation?[/quote:1n4kily0]
    That option in fstab was from the installation, FYI.

  • @“baktin”:psx2b85g said:

    That option in fstab was from the installation, FYI.[/quote:psx2b85g] Thanks for reporting this!!

    Cheers!

Posts 5Views 7252
Log in to reply