• Viber not working.


    Hi people.

    I tried Antergos for a while and I like it a lot so I wanted to make it my main distro. I installed most of the apps that I need but I’m not having any luck running viber.

    I installed it from AUR, through pamac but when I try to run it I get

    /usr/lib/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./Viber)
    

    I tried installed lib32-libcurl-compat-nostatic which was said to solve a similar problem in Arch (in another forum - I don’t know if I’m allowed to paste links to other forums here) but it still doesn’t work. The same error.

    Any ideas on how I could solve this? I’m relatively new to linux and completely new to Antergos (Arch).

    Thank you.

  • Hi.
    Ok, so I take it that you resolved all the dependancies that Viber needs as listed here: AUR-Viber

    Also, the AUR posts indicate that there is/ may be a fix:

    hawara commented on 2016-09-14 22:10
    @Forum_Liker I think it is fixed in latest Cinnamon version, see: https://github.com/linuxmint/Cinnamon/pull/5181/commits/18debb315045a1619f4eb4f1e81ab671c2c2a895
    There's always the manual fix - you have to type 'Viber', not 'Skype' obviously - 
    https://pragtob.wordpress.com/2012/09/25/fix-incoming-skype-messages-stealing-focus-on-linux-mint-cinnamon/
    https://www.reddit.com/r/linuxmint/comments/4n5xfx/viber_for_desktop_linux_mint_64bit_new_messages/
    

    I don’t think it’s all that relevant in the above links in the AUR discussion, but you can have a quick look if your interested.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • so I take it that you resolved all the dependancies that Viber needs as listed here: AUR-Viber

    An easier way through pamac @DarkSocksRaily ::

    1. Open its software manager and type viber
    2. Double click on the name of the app
    3. A new screen will open with more info. Ckick on Dependencies
    4. Click on each dependency in turns and see which one isn t shown as installed.
    5. Install the missing one and you re done.
      Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hi,

    I have Viber installed and running without any problems. I even uninstalled and installed it again. No problems except for that it is useless on my HiDpi laptop. The one applications that won’t scale correctly.

    //Christian

  • Hi.
    Thank you all for the replies. :)

    @Modisc Yes, I made sure that those dependencies are installed. They were installed automatically so I didn’t have to do anything. When I tried to run it (viber) the first time it said that it needs qt5 to run so I installed that to (qt5-base). And then the error mentioned above appeared.

    @anarch I also did what you suggested but everything seemed fine with the dependencies.

    I managed to get it running somehow but I didn’t have a chance to try out if it works because no contacts whatsoever are shown. This might not be a problem though because the same thing happened when I first installed it on my other (former) main OS but I can’t say it works for sure before I test it.

    After double-checking the dependencies once more with no results I tried to reinstall it (again through pamac) and then an error showed up while installing, after the package was built, saying something on the lines of: “there were errors... the files are at /tmp/[something]_viber”. So I copied the contents of the /tmp/[something]_viber directory to another directory (in home) and tried to run viber from there. It ran. There are still some complains about sslv3… but at least it runs now.

    Thank you for the help. My experience here was nothing like what I’ve heard about arch forums (I know Antergos is not exactly arch but still I was prepared for a bit of hostility).

    Probably I’m gonna have to ask some questions again int he future when I break something. :neutral_face:

working6 viber2 Posts 5Views 374
Log in to reply