• \[SOLVED\] dependency cycle detected while updating


    Hi,
    I have not updated my system for quite some time. Today I tried to update, I get dependency cycle detected error.

    sudo pacman -Syyu 
    

    I get following output

    [i:nqdgztd3]:: Synchronizing package databases…
    core 107.5 KiB 106K/s 00:01 [############################################################] 100%
    extra 1465.4 KiB 163K/s 00:09 [############################################################] 100%
    community 2.1 MiB 120K/s 00:18 [############################################################] 100%
    antergos 162.4 KiB 118K/s 00:01 [############################################################] 100%
    multilib 114.6 KiB 91.2K/s 00:01 [############################################################] 100%
    :: Starting full system upgrade…
    :: Replace lib32-dbus with multilib/lib32-libdbus? [Y/n] y
    :: Replace libusbx with core/libusb? [Y/n] y
    resolving dependencies…
    warning: dependency cycle detected:
    warning: util-linux will be installed before its pam dependency
    warning: dependency cycle detected:
    warning: freetype2 will be installed before its harfbuzz dependency
    warning: dependency cycle detected:
    warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
    looking for inter-conflicts…
    error: failed to prepare transaction (could not satisfy dependencies)
    :: chmsee: requires xulrunner<28.0
    [/i:nqdgztd3]

  • Hi,
    I have not updated my system for quite some time. Today I tried to update, I get dependency cycle detected error.

    sudo pacman -Syyu 
    

    I get following output

    [i:nqdgztd3]:: Synchronizing package databases…
    core 107.5 KiB 106K/s 00:01 [############################################################] 100%
    extra 1465.4 KiB 163K/s 00:09 [############################################################] 100%
    community 2.1 MiB 120K/s 00:18 [############################################################] 100%
    antergos 162.4 KiB 118K/s 00:01 [############################################################] 100%
    multilib 114.6 KiB 91.2K/s 00:01 [############################################################] 100%
    :: Starting full system upgrade…
    :: Replace lib32-dbus with multilib/lib32-libdbus? [Y/n] y
    :: Replace libusbx with core/libusb? [Y/n] y
    resolving dependencies…
    warning: dependency cycle detected:
    warning: util-linux will be installed before its pam dependency
    warning: dependency cycle detected:
    warning: freetype2 will be installed before its harfbuzz dependency
    warning: dependency cycle detected:
    warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
    looking for inter-conflicts…
    error: failed to prepare transaction (could not satisfy dependencies)
    :: chmsee: requires xulrunner<28.0
    [/i:nqdgztd3]

  • I have uninstalled chmsee. Now it started update. But I need chmsee as well.

  • chmsee is no longer maintained and it does not run with xulrunner version 28. So I can not use chmsee with xulrunner version 28

  • Hi,

    Glad to see you solved it. I highly recommend you install system updates AT LEAST once per week if not more often. Remember we are using a rolling release model so there are updates almost daily.

    Best Regards,
    Dustin

  • I am very much happy with Antergos and it’s my main distro. I use it for almost 99% of work. From today I started clicking distrowatch page.

Posts 6Views 3377
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.