• GTK3+ dashed lines bug


    Hi there fellow Archers,

    I have a problem with my GTK3+ theme. I am using the Arc-Dark theme on Linux Antergos with the Gnome desktop environment. I am seeing dashed lines on the edges of GTK3+ applications, and I cannot get rid of them.

    I have tried the following:

    • Edit ~/.config/gtk-3.0/gtk.css to:
    .undershoot.top, .undershoot.right, .undershoot.bottom, .undershoot.left { background-image: none; }
    
    • Edit /usr/share/themes/Arc-Dark/gtk-3.0/gtk.css:
    outline-style: dashed; - changed to outline-style: none;
    

    This is weird, because I’ve been using this theme for 2 days without this problem. The problem occurred after I tried to install the following gnome shell extension:
    https://extensions.gnome.org/extension/162/todo-list/

    The extension failed to install, probably because it isn’t compatible with the latest version of gnome shell (3.22.2).

    Some packages were also updated, but I don’t know exactly which packages were updated.
    After I started noticing this problem, I tried reverting to the default Adwaita theme, which did not have the dashed lines. Now I’m seeing the dashed lines on the default theme too, and since no solutions I found work, I guess I would classify this as a bug.
    Any ideas ?

    P.S: If you want me to provide any logs of some sorts, can you please include the command for it ? I am a new Arch user (3 days and counting), and there are quite a few differences from the distro I’m used with (Kali Linux).
    Thanks !

    [EDIT]
    I guess it’s worth noting I looked for any .css file with the outline-style: dashed; string in it. Here’s the output:

    [[email protected] /usr/share/themes]$ sudo grep -lr --include='*.css' 'outline-style: dashed' /
    /usr/share/themes/Arc/gtk-3.0/gtk-dark.css
    /usr/share/themes/Arc/gtk-3.0/gtk.css
    /usr/share/themes/Arc-Darker/gtk-3.0/gtk-dark.css
    /usr/share/themes/Arc-Darker/gtk-3.0/gtk.css
    

    As you can see, the only other .css files that have this setting are the other 2 Arc themes, which I am not using, so there is no config file that could override my settings.

  • I solved the problem on my own. It seems I was using an old/incompatible syntax for the ~/.config/gtk-3.0/gtk.css file.

    Solution:

    Edit/create file ~/.config/gtk-3.0/gtk.css:

    undershoot.top, undershoot.right, undershoot.bottom, undershoot.left { background-image: none; }
    
themes15 gnome 3.22.210 gtk39 bugs7 Posts 2Views 630
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.