• Touchpad problem

    Hey guys. I own a Dell E6410 laptop and i am having issues with the touchpad. Sometimes it works just fine but most of the times it dosent. Is there a way to check if its something wrong with the software/driver etc or is it my hardware is failling ?? Havent tried to test the touchpad in windows to check if there it works cause the moment i had it my hands i simple erased windows and went on with installing Antergos. Thanks for your time in advance.

  • Try to install the xf86-input-libinput package:

    sudo pacman -S xf86-input-libinput

    It solves many issues with input devices of all kinds.

  • I just installed it and it seems to go just nice so far. I will test it a little bit more and then mark this as solved. Thank you.

  • I was too quick to judge. My problem persists. Is there anything else i could try ??

  • From Arch Linux Wiki:

    Touchpad detected as “PS/2 Generic Mouse” or "Logitech PS/2 mouse"

    There is a link to PKG for a driver for ALPS - Touch :

    But first try to validate what hardwre it is:


    may offer info…

    better a

    lspci -vv


  • I’m prety new to linux and i didnt quite understand what you told back ther. :( I did execute the command you suggest and i dont really know what i’m reading etc. If you could explain it more i would apreciate it a lot m8. Thank you for your time :)

  • lspci shows information about your pci-hardware devices.
    the -vv shows double verbose info…

    you can do this in terminal:

    lspci -vv > lspci.txt

    to create a textfile with the info the command finds.

    to read:

    gedit lspci.txt

    copy text and paste it for example here:


    you can share the link to the text here then…

    << i am off for freetime caus working toooooo much before so i share my time here ;)

  • Here is the results : http://pastebin.com/2kwXzms7 , i have tried a lot of distros but this is actually the first time i find such a friendly community and i’m loving it so far. No more afraid to be mocked cause my question is way to stupid etc.

  • can you do the same for:

    sudo lsusb -v > lsusb.txt
  • you can also install lshw:

    yaourt -S lshw

    this is a grafik toool for showing hardware info…

    also helpfull:

    cat /proc/bus/input/devices > inputdevices.txt
  • sudo libinput-list-devices

    give info about connectet devices and enabled/disabled option aviable

    there is also a grafic tool to optimize and configure:

    yaourt -S gpointing-device-settings

    Bild Text

  • @Vagelis said in Touchpad problem:

    No more afraid to be mocked cause my question is way to stupid etc.

    … there is a german talking:

    As one calls it into the forest, the echo comes out of it again ;)

  • This is for lsusb : http://pastebin.com/hKNNgc2f , and this is for the libinput : http://pastebin.com/KxxZqJu8

  • sudo lsusb -v > lsusb.txt

    write textfile called lsbusb.txt … the terminal gives only some errors…
    you can copy the output also directly from terminal… then

    sudo lsusb -v
  • Device: AlpsPS/2 ALPS DualPoint Stick

    Device: AlpsPS/2 ALPS DualPoint TouchPad

    There it is:


    also the output of:

    lsmod | grep i2c_hid

    would be helpfull, caus may this module is your problem…

    from here:


  • The result from sudo lsusb -v : http://pastebin.com/Qz0XP2vc , the lsmod | grep i2c_hid didnt do anything for me.

  • lsmod: list all loaded kernel-modules the >>| grep “term”<< shows only the line wich include the term…

    So caus it show you nothing the module “i2c_hid” is not loaded…and can not caus your problem…

    For now we now your hardware… i will need some researching…

    I do not think that your touchpad has a HARDWARE failure… caus there are a number of people have trouble with the
    AlpsPS/2 ALPS DualPoint TouchPad

    Could you try to install

    yaourt -S gpointing-device-settings

    and see if your touchpad is configurable with this?

    dmesg command is also a good start to find failed stuff…

  • The results for dmesg : http://pastebin.com/1m6ukXKE , i did install gpointing-device-settings but i cant find anywhere after i install it etc. I so reliefed that you think it wont be a hardware faillure and i cant thank you enought for all your trouble and efford. :)

  • you can run


    inside terminal to start it… programm is named pointing device settings

    Your touchpad seems to correctly detect by sstem and as you say is working kind of… but not as expected.
    they are al lot of options to configure touchdevices but the way is difficult as you can see here:


    there is also a gnome-shell-extension maybe helpfull:


    You can install out of the browser… but as far as i know not with chromium…

  • I’m using KDE plasma atm so i cant really use that gnome shell extension you suggested. I’m a fool for eye candy looking DE :P I’m also trying to search it a bit but most of the things i find its like greek to me (inside joke cause im greek :P).

touchpad55 Posts 23Views 5015
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.