• Default browser problem in Plasma5


    I have a strange problem with my Plasma5. I have 3 browsers installed, , Qupzilla, PaleMoon and Chromium.
    I have set Qupzilla as default browser. Now, when i cick on a link in applications like Hexchat or Thunderbird, these links are opened in Chromium, which is not the expected behaviour.
    When I remove Chromium, the links are opened in PaleMoon, which is also not the expected behaviour whith Qupzilla set as default browser.
    Any Ideas how to prevent the system from using a “non-default” browser?
    J.

  • @Jeannie____ Hi, well i use Mate, but you need to find something like configurations>preferencial apps>internet then you set Qupozilla as preferencial.

    Good luck

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • As I wrote in my initial post, qupzilla is set as preferred browser my plasma5 settings. Plasma5 just dosn’t seem to care about that.
    .J.

  • try to move this file:

    mv ~/.local/share/applications/mimeapps.list  ~/.local/share/applications/mimeapps.list.backup
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • I don’t have a mimeapps.list file on my system.
    J.

  • @Jeannie____ yea i do not have kde on my system yet ;)

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @Jeannie____ then i don’t know how to help you, sorry :(

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • is it possible to right click on files inside the filebrowser and change the “open with” programm?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Yes, for files this is possible in Dolphin.
    J.

  • i know this problem from before when i try to use thunderbird… it does not follow the system defaults…

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Even in thunderbird, qupzilla is set as application to to open links. If I click on a link in thunderbird, chromium opens up. If I remove chromium, thunderbird opens links in palemoon. If I reinstall chromium, thunderbird opens links in chromium again. Trying to open links in other applications shows exactly the same behaviour.
    J.

  • and if you try to reinstall Qupzilla?

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto It is not a Quipzilla bug. I too have this problem with certain programs. Although FF is my default, some programs open links in Chromium.
    I have not yet been able to figure out why this is.

    Never to old to learn.

  • @axioma ok, weird but interesting also :)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto
    Removing and reinstalling Qupzilla does not change this behaviour.
    J.

  • Have you tried to install another browser e.g. firefox aside the other two and then successively choose them from configurations>preferencial apps>internet
    leaving Qupzilla last?

  • @Jeannie____ Hi, if problem not solved, i guess, the best solution for you is to specify what browser Thunderbird can use with the network.protocol-handler.app.http and network.protocol-handler.app.https or *.ftp settings. Try use in Thunderbird: Edit > Preferences > Advanced > General > Config Editor. In config editor: right click on its listing, select New, select String, enter network.protocol-handler.app.http and then the complete path to whatever browser you want to use. If the setting already exists just double click on the setting to change the path. Do the same thing for network.protocol-handler.app.https to support secure connections. For qupzilla, example path /usr/share/applications qupzilla.desktop.

  • I already did that. Thunderbird still opens links in chromium.
    J.

  • May it helps that inside Gnome shell i can change the network.protocol-handler.app.http inside thunderbird to whatever i want it takes the system default browser…

    Do you have any other WM beside KDE installed?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Only Plasma5 here.
    J.

browser28 plasma511 Posts 43Views 2908
Log in to reply