Hey there

I’m using a swiss keyboard layout on my desktop.
I I then switch to basic shell (CTRL+ALT+F1) I can use all keys as they are printed on my keyboard.

If I switch back, or boot normaly to my gnome desktop a few keys are exchanged like the ² and @ key.
I tried to set the keyboard to German (Switzerland) in the settings app, but it is never the same as on plain shell mode.

Can you help me to set every key exactly like it is in non-GUI mode?
Did i forget to change something?