I’ve just installed Antergos on my Asus EEE PC 1225c and I can’t get my wi-fi working. When I check my connections with rfkill list all command, it returns me the following output:

0: asus-wlan: Wireless LAN
  Soft blocked: no
  Hard blocked: no
1: asus-wimax: WiMAX
  Soft blocked: no
  Hard blocked: no
2: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: yes

rfkill unblock all command didn’t work, as it affects only soft block of wi-fi modules. Pressing key combination Fn + F2 didn’t work either – it only toggles soft block in asus-wlan and phy0, but doesn’t affect hard block in phy0, a LED indicating that wi-fi module is turned on doesn’t enable also. I tried several variants, amongst them adding to /etc/modprobe.d/i915.conf or creating a new file /etc/modprobe.d/asus.conf with the following line

options asus-nb-wmi wapf=4
# I also tried the same command with wapf=0 or wapf=1
# or options asus-wmi wapf=0 or wapf=1 or wapf=4
# But neither did work.

Also I tried to add to /etc/modprobe.d/blacklist.conf the following line

blacklist wmi
# or
blacklist asus-wmi
# or
blacklist asus-nb-wmi

But unfortunately this didn’t work as well. All these variants were taken from internet and they seemed to help the other people but in my case none was successful. Addressing to official Asus technical support gave nothing, they just told that they stopped supporting Linux on their devices since 2008. Are there any possible variants to get wi-fi adapter working on Linux? (I also tried several Ubuntu distros, Manjaro and Arch, and all of them faced the same problem.)
P.S. The adapter is Qualcomm Atheros AR9285 Wireless Network Adapter, the default driver is ath9k.