• Can't login to Gnome Classic desktop on SONY with NVIDIA graphics


    Sony Vaio VGN-AW11Z/B (8 years old)
    Processor: Intel Core2 Duo Processor T9400
    Graphic Card: NVIDIA GeForce 9600M GT GPU
    Memory Type: 4GB DDR2 SDRAM 800MHz

    During the initial install process I didn’t enable the Proprietary Graphics Driver option in list provided by installer, then when install finished, I rebooted but there was just a blank screen and no login.

    So I repeated the install process, but this time I enabled the Proprietary Graphics Driver option. Installation completed and reboot was successful and could login to desktop OK, but I noticed a couple of problems…

    1. Although I can login to Gnome desktop successfully, I can’t login to Gnome Classic desktop which is my preferred choice. The screen reverts back to username and password window again.

    2. Also my Brightness Control Fn keys are not working, this may not be related to the brightness problem, so I have created a separate topic for this, see… https://forum.antergos.com/topic/5545/brightness-control-not-working-on-gnome-on-sony-with-nvidia-graphics

    Here is details of my graphics…

    $ lspci -vvnn
    
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G96M [GeForce 9600M GT] [10de:0649] (rev a1) (prog-if 00 [VGA controller])
    	Subsystem: Sony Corporation Device [104d:9040]
    	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    	Latency: 0
    	Interrupt: pin A routed to IRQ 35
    	Region 0: Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
    	Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
    	Region 3: Memory at d0000000 (64-bit, non-prefetchable) [size=32M]
    	Region 5: I/O ports at d000 [size=128]
    	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    	Capabilities: <access denied>
    	Kernel driver in use: nvidia
    	Kernel modules: nouveau, nvidia
    

    EDIT: I have just installed Antergos Gnome on my new DELL Inspiron 5559 laptop (with UEFI) …

    • Processor: Intel Core i7-6500U CPU @ 2.50GHz, 2592 Mhz, 1 Core(s), 2 Logical Processor(s)
      Integrated Graphics Processor: Intel® HD Graphics 520
      Discrete Graphics Processor: AMD Radeon R5 M335w

    The system is running very snappy so happy with the result, but I still can’t select and login to “Gnome Classic” desktop on this laptop either, only standard Gnome desktop is working. Has anyone seen this before?
    EDIT2: I can see Gnome Classic in /usr/share/xsessions …

    [hugh@DELL-INSP-ANTERGOS ~]$ cd /usr/share/xsessions
    [hugh@DELL-INSP-ANTERGOS xsessions]$
    
    [hugh@DELL-INSP-ANTERGOS xsessions]$ ls
    gnome-classic.desktop  gnome.desktop  gnome-xorg.desktop
    [hugh@DELL-INSP-ANTERGOS xsessions]$ 
    
    
    [hugh@DELL-INSP-ANTERGOS xsessions]$ cat gnome-classic.desktop
    [Desktop Entry]
    Name=GNOME Classic
    Comment=This session logs you into GNOME Classic
    Exec=env GNOME_SHELL_SESSION_MODE=classic gnome-session --session gnome-classic
    TryExec=gnome-session
    Type=Application
    DesktopNames=GNOME-Classic;GNOME;
    [hugh@DELL-INSP-ANTERGOS xsessions]$
    

    If anyone can give me some advice I would be grateful.

  • @hughparker1 Okay, So I too had this issue.
    I’m no linux wizard, so Don’t expect genius here.
    Turns out that for whatever reason the name of Gnome Classic got changed, and is now called gnome flashback.
    Details here: https://wiki.archlinux.org/index.php/GNOME/Flashback
    Installing the required packages for that and then picking gnome flashback at login gets me in.

    If that works for you great, it didn’t quite work for me. Logging in got me the layout I was looking for. For two seconds, and then booted me to the log in screen again. It’s not the SAME error, because my xsession errors log is now clean, but it hasn’t gotten me what I need. Got me further than before though…

  • @sifrnihilum said in Can't login to Gnome Classic desktop on SONY with NVIDIA graphics:

    @hughparker1 Okay, So I too had this issue.
    I’m no linux wizard, so Don’t expect genius here.
    Turns out that for whatever reason the name of Gnome Classic got changed, and is now called gnome flashback.
    Details here: https://wiki.archlinux.org/index.php/GNOME/Flashback
    Installing the required packages for that and then picking gnome flashback at login gets me in.

    If that works for you great, it didn’t quite work for me. Logging in got me the layout I was looking for. For two seconds, and then booted me to the log in screen again. It’s not the SAME error, because my xsession errors log is now clean, but it hasn’t gotten me what I need. Got me further than before though…

    Thanks for feedback. I’m very new to Antergos so I opened “Add/Remove Software” and installed “gnome-flashback” then rebooted and was able to select a new option on the login window called “GNOME Flashback (Metacity)” and was able to get to what looks like the “GNOME Classic” desktop.

    Thanks again for your suggestion it was spot on. I wish I could fix the problem with not being able to adjust the brightness, see link https://forum.antergos.com/topic/5545/brightness-control-not-working-on-gnome-on-sony-with-nvidia-graphics for details.

    Any suggestion? would reinstalling gnome-desktop using “Add/Remove Software” be a possible solution? This laptop has an 18" screen and it’s on full brightness so needing to wear sunglasses till i get it fixed :sunglasses:

  • This post is deleted!
classic1 gnome201 login63 sony4 Posts 4Views 468
Log in to reply