• Gnome not running with Wayland? / Sessions confusion


    Just installed fresh latest Antergos with Gnome.

    When I log in I can choose 4 sessions: 2 x “Gnome” , Gnome Classic , Gnome with Xorg.

    What are the differences of the two “Gnome” sessions?

    When I look it up in /usr/share/xsessions I just have:
    gnome-classic.desktop gnome.desktop gnome-xorg.desktop

    Now I am selecting one of the two “Gnome” sessions I get horrible screen tearing and really jittery windows. I really dont think Wayland is enabled here. How can I check it? How can I enable it?

  • This “What are the differences of the two “Gnome” sessions?” is something i realy want to know too ;)
    @chronixsc said :

    When I look it up in /usr/share/xsessions I just have: …

    True me too the double gnome session entry is from lightdm itself i think…

    /usr/share/xsessions/gnome.desktop:

    Exec=gnome-session
    TryExec=gnome-session
    Icon=
    Type=Application
    DesktopNames=GNOME
    X-GDM-Session-Type=wayland
    

    As Wayland is enabled by default you do not need to…

    But depending on your hardware Gnome starts without Wayland if it can not be startet…

    Put this in a terminal:

    [email protected] ~ % echo $XDG_SESSION_TYPE
    wayland
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Yea it says:

    echo $XDG_SESSION_TYPE
    x11
    

    With every lightdm session entry.

    But depending on your hardware Gnome starts without Wayland if it can not be startet…
    “Normal” dedicated desktop card, Nvidia 660 TI. That should be no problem?

  • what says a:

    cat /usr/share/xsessions/gnome.desktop
    

    at the last 6 lines?

    You can put this in the end:

    X-GDM-Session-Type=wayland
    

    second line:

    Name=GNOME-WAYLAND
    

    and change the name to gnome-wayland.desktop

    then you will get a GNOME-WAYLAND entry you can choose inside lightdm…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • So what I did:
    cd /usr/share/xsessions/
    cp gnome.desktop gnome-wayland.desktop
    Edit line:
    Name=GNOME-WAYLAND
    Added line:
    X-GDM-Session-Type=wayland
    As expected I now have another session option available “Gnome-Wayland”.
    When I login with that option I still get:

    echo $XDG_SESSION_TYPE
    x11
    

    Which error log could be useful?

    Remember this is a totally fresh installation of antergos with a “normal” dedicated Nvidia Card. This might be a problem for a lot of users …

  • Which graphics driver are you using for your Nvidia card? The free one or the proprietary nvidia driver?
    J.

  • @chronixsc said in Gnome not running with Wayland? / Sessions confusion:

    Remember this is a totally fresh installation of antergos with a “normal” dedicated Nvidia Card. This might be a problem for a lot of users …

    So as there is no option to install properitary nvidia driver cnchi installs nouveau by default…?

    @chronixsc: check:

    lsmod | grep nouveau
    

    and:

    cat /etc/mkinitcpio.conf | grep nouveau
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • I did not enable proprietary driver during installation.

    
    lsmod | grep nouveau
    nouveau              1523712  4
    mxm_wmi                16384  1 nouveau
    wmi                    16384  2 mxm_wmi,nouveau
    ttm                    86016  1 nouveau
    drm_kms_helper        126976  1 nouveau
    drm                   294912  7 nouveau,ttm,drm_kms_helper
    i2c_algo_bit           16384  1 nouveau
    video                  36864  1 nouveau
    button                 16384  1 nouveau
    

    “cat /etc/mkinitcpio.conf | grep nouveau” is empty.

  • Than you can do the following to enable “Enable early KMS loading”: (as root / with sudo for shure…)

    As discribed here: Nouveau (ArchWiki)

    add nouveau to the MODULES array in /etc/mkinitcpio.conf:

    MODULES="nouveau"
    

    Re-generate the initial ramdisk image:

    mkinitcpio -p linux
    

    reboot

    But i am not shure this will solve your problem… but may it helps

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • and i just find the double entry for gnome here:

    /usr/share/wayland-sessions % ls
    gnome.desktop
    
    
    

    GDM seems to ignore this entries but lightdm reading it…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @chronixsc said in Gnome not running with Wayland? / Sessions confusion:

    This might be a problem for a lot of users …

    Wayland is a newly comming up inside the system so there is for shure some work to do…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Adding it to the module array didnt help.

    What can I do from here on? There should be a log somewhere that says somethinng like “Starting up gnome wayland - Fail; Falling back to normal X”.

  • lightdm logs:

    /var/log/lightdm/ 
    
    lightdm.log      seat0-greeter.log      x-0.log      x-1.log
    lightdm.log.old  seat0-greeter.log.old  x-0.log.old  x-1.log.old
    

    May also /home/USER/.xsession-errors

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • i am starting with wayland, also when i choose gnome-xorg …

    trying in virtualbox with new installation i am stick to xorg session…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

running8 gnome219 sessions3 wayland38 Posts 14Views 3226
Log in to reply