• Brightness Control not working on Gnome on SONY with NVIDIA graphics


    Sony Vaio VGN-AW11Z/B (8 years old)
    Processor: Intel Core2 Duo Processor T9400
    Graphic Card: NVIDIA GeForce 9600M GT GPU
    Memory Type: 4GB DDR2 SDRAM 800MHz

    During the install process I didn’t enable the Proprietary Graphics Driver option in list provided by installer, then when install finished, I rebooted but there was just a blank screen and no login.

    So I repeated the install process, but this time I enabled the Proprietary Graphics Driver option. Installation completed and reboot was successful, but I noticed a couple of problems…

    Brightness Control Fn keys are not working and also there is no brightness slider control shown in drop down when power icon is clicked (but there is a sound volume slider control) so I can’t manually adjust the brightness.

    Also, although I can login to Gnome desktop successfully, I can’t login to Gnome Classic desktop which is my preferred choice. The screen reverts back to username and password login again. This may not be related to brightness problem so I created a separate topic … https://forum.antergos.com/topic/5552/can-t-login-to-gnome-classic-desktop-on-sony-with-nvidia-graphics

    Here is details of my graphics…

    $ lspci -vvnn
    
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G96M [GeForce 9600M GT] [10de:0649] (rev a1) (prog-if 00 [VGA controller])
    	Subsystem: Sony Corporation Device [104d:9040]
    	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    	Latency: 0
    	Interrupt: pin A routed to IRQ 35
    	Region 0: Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
    	Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
    	Region 3: Memory at d0000000 (64-bit, non-prefetchable) [size=32M]
    	Region 5: I/O ports at d000 [size=128]
    	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    	Capabilities: <access denied>
    	Kernel driver in use: nvidia
    	Kernel modules: nouveau, nvidia
    

    EDIT: I dual boot this laptop with other Linux operating systems, e.g. Debian with Gnome desktop (using Kernel driver nouveau), Solus with Budgie desktop and Linux Mint 18 Mate desktop. The brightness control does work OK on all to these. so not sure what the problem is.

    EDIT2 i found out how to check the version of my nvidia driver…

    [[email protected] ~]$ nvidia-smi
    Sat Nov 26 14:08:33 2016       
    +------------------------------------------------------+                       
    | NVIDIA-SMI 340.98     Driver Version: 340.98         |                       
    |-------------------------------+----------------------+----------------------+
    | GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
    | Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
    |===============================+======================+======================|
    |   0  GeForce 9600M GT    Off  | 0000:01:00.0     N/A |                  N/A |
    | N/A   50C    P8    N/A /  N/A |    151MiB /   511MiB |     N/A      Default |
    +-------------------------------+----------------------+----------------------+
                                                                                   
    +-----------------------------------------------------------------------------+
    | Compute processes:                                               GPU Memory |
    |  GPU       PID  Process name                                     Usage      |
    |=============================================================================|
    |    0            Not Supported                                               |
    +-----------------------------------------------------------------------------+
    [[email protected] ~]$
    

    I checked http://www.nvidia.co.uk/download/driverResults.aspx/107959/en-uk and looks like I have the latest nvidia driver installed, but wondered if the information in the command output above indicated if anything was wrong.

    I had a look in this directory…

    [[email protected] ~]$ cd /sys/class/backlight/
    [[email protected] backlight]$ ls
    [[email protected] backlight]$
    

    but no files are here, I wondered if there should be some files/folders here.

    I also read online that you can modify file…

    /etc/default/grub
    

    and add …

    video.use_native_backlight=0
    

    to end of line (keep inside quotes)…

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    Would this be a good solution? I don’t know enough to about Linux to determine if there is an underlying problem that needs resolved rather than trying a quick fix. I’m fairly new to Linux but I can use terminal. If anyone can give me some advice I would be grateful.

  • @hughparker1 said

    Not sure if these issues are connected, should I create a post for each one?

    Yes, please do.

    @hughparker1 said

    other Linux OSs, e.g. Debian, Solus and Linux Mint. The brightness control does work on these OK.

    Was any of them running Gnome? Just a shot in the darkness. I came along the same issue with brightness. It was rather stupid, but there was a light sensor on my laptop s screen which was set to AUTO. All I had to do was change the settingt from the asigned keybords.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Brightness Control not working on Gnome on SONY with NVIDIA graphics:

    @hughparker1 said
    other Linux OSs, e.g. Debian, Solus and Linux Mint. The brightness control does work on these OK.

    Was any of them running Gnome? Just a shot in the darkness. I came along the same issue with brightness. It was rather stupid, but there was a light sensor on my laptop s screen which was set to AUTO. All I had to do was change the settingt from the asigned keybords.

    Thanks for feedback. Here are more details of the other operating systems on this laptop…

    Debian has Gnome desktop (using Kernel driver nouveau), Solus has Budgie desktop and Linux Mint 18 has Mate desktop. I have updated my post with these details.

    I don’t have a light sensor on my laptop screen, and Debian Gnome is working OK although it is not using any proprietary drivers for graphics. Don’t know if that is relevant. During my first install I didn’t select any proprietary drivers but then I couldn’t login to desktop after reboot so I had to select proprietary drivers during second install to be able to boot into desktop.

  • I have just installed Antergos Gnome on my new DELL Inspiron 5559 laptop (with UEFI) …

    • Processor: Intel Core i7-6500U CPU @ 2.50GHz, 2592 Mhz, 1 Core(s), 2 Logical Processor(s)
      Integrated Graphics Processor: Intel® HD Graphics 520
      Discrete Graphics Processor: AMD Radeon R5 M335w

    And the brightness control is working OK. The system is running very snappy so happy with the result. So the problem must be with my old Sony Vaio laptop. It’s 8 years old but it’s running very well on Antergos. Does anyone know if I can fix it to be able to use the “Gnome Classic” desktop?

  • I tried modifying file “/etc/default/grub”

    and add… “video.use_native_backlight=0”

    to end of line (keep inside quotes)…

    GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”

    then ran upudate grub…

    $ sudo grub-mkconfig -o /boot/grub/grub.cfg

    but after reboot, still can’t adjust brightness. This laptop has an 18" screen and it’s on full brightness so needing to wear sunglasses till i get it fixed :sunglasses: any help would be appreciated. Would reinstalling gnome-desktop using “Add/Remove Software” be a possible solution?

  • @hughparker1 , the closest "solution I was able to find by searching, was this:

    "Hugh Parker September 16, 2014 at 11:12 pm
    I managed to fix the brightness problem on my Sony Vaio laptop by modifying the directory path from described above.
    cat /sys/class/backlight/acpi_video0/max_brightness # directory “acpi_video0″ doesn’t exist on Sony Vaio laptop so I changed this to….
    cat /sys/class/backlight/nv_backlight/max_brightness # value is 100 for Sony Vaio
    then I tried to edit the brightness file….
    gedit /etc/rc.local # to edit the file
    echo 30 > /sys/class/backlight/nv_backlight/brightness # used 30%
    and it works for my Sony Vaio.
    Thanks for your very good solution
    Hugh"
    taken from here
    http://ubuntuhandbook.org/index.php/2014/04/save-screen-brightness-settings-in-ubuntu-14-04/

    EDIT:
    You might find this one interesting. Seems to have worked for a number of brands, including VAIO and someone mentioned in Arch.
    https://itsfoss.com/fix-brightness-ubuntu-1310/

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Brightness Control not working on Gnome on SONY with NVIDIA graphics:

    @hughparker1 , the closest "solution I was able to find by searching, was this:

    "Hugh Parker September 16, 2014 at 11:12 pm
    I managed to fix the brightness problem on my Sony Vaio laptop by modifying the directory path from described above.
    cat /sys/class/backlight/acpi_video0/max_brightness # directory “acpi_video0″ doesn’t exist on Sony Vaio laptop so I changed this to….
    cat /sys/class/backlight/nv_backlight/max_brightness # value is 100 for Sony Vaio
    then I tried to edit the brightness file….
    gedit /etc/rc.local # to edit the file
    echo 30 > /sys/class/backlight/nv_backlight/brightness # used 30%
    and it works for my Sony Vaio.
    Thanks for your very good solution
    Hugh"
    taken from here
    http://ubuntuhandbook.org/index.php/2014/04/save-screen-brightness-settings-in-ubuntu-14-04/

    thanks for reply, I had already tried this solution but failed on the first task of creating directory…

    /sys/class/backlight/nv_backlight
    

    I got the following error…

    [[email protected] ~]$ sudo mkdir /sys/class/backlight/nv_backlight
    [sudo] password for hugh: 
    mkdir: cannot create directory ‘/sys/class/backlight/nv_backlight’: Operation not permitted
    [[email protected] ~]$
    

    so I tried again using root…

    [[email protected] ~]$ sudo -i
    [[email protected] ~]# mkdir /sys/class/backlight/nv_backlight
    mkdir: cannot create directory ‘/sys/class/backlight/nv_backlight’: Operation not permitted
    [[email protected] ~]#
    

    I get same message “Operation not permitted”

    I’m still learning Linux so not sure how to proceed, any advice would be appreciated.

  • I tried to re-install Gnome again without the proprietary drivers enabled in the list generated during the install, and after reboot I was able to login to desktop, and brightness control worked OK, but after another reboot I was left with only black screen and the mouse pointer displayed, nothing else. I couldn’t get to the desktop after several attempts.

    So there must be something about my old Sony laptop that the Gnome installer doesn’t like. (I was able to install Gnome on my new UEFI DELL Inspiron 5559 laptop OK. Brightness control working and system running very well, nice and snappy.

    So I decided to install Xfce desktop on my old Sony laptop with proprietary drivers enabled and after reboot I was able to boot into desktop with brightness control working. Again the system is very snappy so very happy that i have successfully installed Antergos on both laptops.

    Thanks for a great operating system. It’s very fast and also boots up and shuts down very quickly.

gnome187 sony4 brightness9 control5 Posts 8Views 919
Log in to reply