• No network connection with minimal ISO live

    Downloaded the ISO and made a boottable usb.
    Boots up. Wired connection is UP in ip a…but the applet says no netwrok connection hence install cannot proceed further. If unplugging/plugging back the ethernet cable, dmesg shows the link going down and up again as expected…
    Every 30 seconds orr soo the applet shows a pop up that says “the network connection has been disconnected”
    I just don’t know where to look ! I have used Linux on and off for years, including archbang and many flavours of ubuntu/debian but have never had any trouble with a wired connection!
    It is a thinkpad 220 with Intel 82579LM chip. Module e1000e loaded.
    Btw i have double checked …the connection is fine when booting from HD…

  • I had this same issue yesterday. I fixed it by right clicking on the internet connection icon in the toolbar and selecting Add Hiddent Network. I typed in the name of my wi-fi hotspot and the password and clicked Okay. It found it right away and allowed me to continue installation. Hope this works for you too!

  • @jridgers Thanks but it does not help.
    Antergos sees the wifii networks but can’t connect to them. I have servral on 2.4 and 5Ghz, and one guest ssid without password…none of them connect.

    I have also try using nmtui following some forum posts…

  • Dhcp is deifnitively the issue.
    I tried the "full"ISO to see if it was different…no change
    I managed to connect by setting up the wired connection to manual instead of dhcp.
    Now install validates all 4requirements on this screen, but then the installer window disappears???
    Honestly so far it is quite disappointing. I was expecting a lot from this distro based on its reviews…archbang had been my daily commute for years, on several machines, and I have never seen this kind if issue with it!

  • @peterlongfield I’ve run a few installs of this distro and I feel your pain. Cnchi is definitely flawed, but once you get it installed, it’s worth it and for most of us here, smooth sailing after install.

  • The crash was because the DNS was not properly set…
    Then i had other errors …which were due to choosing to install flash…
    Then eventually it worked.
    I configured my partitions manually, trying to install it alongside Mint.
    I aske to set-up grub too…
    Well…problem is now none boot.
    Mint goes to the login screen but cannot write to the authorization file???
    And the bootloader does not see the Antergos install??

  • The crash was because the DNS was not properly set…

    No one has ever reported this (I suppose everybody has DNS setup when installing… I will check into it so installer does not crash).

    Then i had other errors …which were due to choosing to install flash…

    Yes, a package name change (see other thread).

    I aske to set-up grub too…

    Why? You already had Mint’s grub. The only think you needed to do is run Mint and update it… it would have found the new Antergos installation.

    Well…problem is now none boot.

    Don’t know about Mint (Did you have any special setup in Grub?) I don’t see how Cnchi can break that.

    You have to choose which distro will handle grub, Mint or Antergos, and then fix it from that distro. If you want to fix it using Antergos, boot from livecd, chroot to your antergos installation and reinstall your grub (there are plenty of articles explaining how to do this, but tell us if you need help on this).


  • Thanks

    Indeed my understanding of Grub was not quite there. I thought that when asking the installer to install grub it would overwrite the existing MBR settings…
    I manage a boot-repair from a liveUSB and everything is good now install wise…

    The DNS issue is also an error of mine - but was a direct consequence of the DHCP bug that forced me to setup my ethernet connection with a fixedIP. Also, the installer just “disappeared” from the screen with no error message . Maybe it should verify DNS resolution before displaying a green tick next to the “internet connection”…

    Thanks for all advices anyway. I’ll try to set this thread as solved (haven’ found yet how to do it :/) - and go back to fixing all the rest (Still no wifi that I can use. My mouse click is behaving very strangely - I changed the multiclick value wiht no change - and the screen blacks out after 15 or so minutes of inactivity and does not wake up - I have to hard reset the laptop :()

connection34 ethernet17 network15 Posts 8Views 2867
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.