• Un par de problema


    Buenas Tardes, compañeros.

    Bueno me presento, soy un chaval de 26 años, estudiante de Ingeniería de computadores.
    He vuelto al mundo de Unix, he elegido Antergos con entorno KDE lo he instalado en un portatil toshiba satellite L655, hasta ahora mi experiencia a sido muy buena, pero tengo dos problemillas o errores que aunque no son demasiado importante me traen de cabeza.
    En primer lugar el entrar en suspensión al cerrar la tapa, me explico de primeras con la instalación limpia no funcionaba por mucho que cambiara la configuración del gestor de energía mediante preferencias del sistema, después de mucho investigar y probar conseguí que funcionara (modificando el /etc/systemd/logind.conf usando aspid y powerdevil) pero para que lo haga tengo que suspender el equipo mediante el menú cada vez que enciendo el PC, Es como si el gestor de energía no funcionara hasta que no suspendo el equipo. Cuando enciendo el equipo no me aparece el icono de la batería en la bandeja del sistema y si enchufo o desenchufo el cargador el equipo es como si no se entera, una vez que suspende y lo reanudo ya funciona todo bien. Como veis no es importante pero si molesto, y no se si es por algo que me falta configurar o un bug de algo.
    En segundo lugar, tengo una multifuncion epson stylus SX235W (Wifi), conseguí instalar y configurarla bien y funciona mediante wifi. El problema viene cuando intento configurar el escáner por wifi, instalé sane, iscan iscan-data e iscan-plugin-network, y seguí la Wiki de Archlinux, he conseguido que funcione alguna vez puntual pero desactivando el cortafuegos ufw, he intentado crear reglas para dejar que el cortafuegos permita que use el escáner pero no ha funcionado y sin tocar la configuración del escáner al trastear con el cortafuegos el escáner deja de funcionar aun teniendo deshabilitado el cortafuegos, (cuando deja de funcionar al ejecutar iscan o el comando scanimage -L tarda muchísimo, iscan me da error “que no se puede enviar el comando compruebe el estado del escaner” y scanimage no detecta el escáner). Sinceramente no se muy bien como tengo que reglas tengo que crear en el cortafuegos que puertos tengo que abrir etc… mediante avahi veo el escáner pero lo que me extraña es que cuando desactivo el cortafuego porque veo que las reglas no surgen efecto el escáner vuelve a no funcionar.

    Saludos y espero aprender y ayudar en lo que este en mi mano.

  • @Kiolko
    Si quieres usar el ahorro de energía de Gnome, lo mejor es quitar el light-locker y el lightdm e instalar el gdm:

    sudo systemctl disable lightdm
    sudo pacman -Rns light-locker lightdm
    sudo pacman -S gdm
    sudo systemctl enable gdm
    

    A ver si con esto mejora el tema de la suspensión, cerrar la tapa, … etc.

    Respecto a la impresora, lo primero es saber los puertos tcp/udp que tienes que abrir (yo ni idea). Quizás en la documentación de la impresora?

    La solución fácil podría ser abrir todos los puertos sólo para la IP en concreto de la impresora.

    Para “limpiar” las reglas del firewall:
    sudo iptables -F
    Para ver las reglas:
    sudo iptables -L

    Saludos!

  • @karasu said in Un par de problema:

    @Kiolko
    Si quieres usar el ahorro de energía de Gnome, lo mejor es quitar el light-locker y el lightdm e instalar el gdm:

    sudo systemctl disable lightdm
    sudo pacman -Rns light-locker lightdm
    sudo pacman -S gdm
    sudo systemctl enable gdm
    

    A ver si con esto mejora el tema de la suspensión, cerrar la tapa, … etc.

    Respecto a la impresora, lo primero es saber los puertos tcp/udp que tienes que abrir (yo ni idea). Quizás en la documentación de la impresora?

    La solución fácil podría ser abrir todos los puertos sólo para la IP en concreto de la impresora.

    Para “limpiar” las reglas del firewall:
    sudo iptables -F
    Para ver las reglas:
    sudo iptables -L

    Saludos!

    Muchas gracias por tu ayuda, respecto al ahorro de energía, lo había pensado pero me gustaría solucionar el problema sin tener que cambiar al ahorro de energía de gnome, puesto que buscando información he leído en varios sitios que este problema u otros parecidos también se dan, y en lo que concierne al tema del escáner sigo sin solucionarlo he intentado como sugieres abrir todos los puertos para la ip de la multifuncion etc… pero nada, de hecho sigue pasando igual. Cuando me pongo a trastear con el Firewall deja de funcionar incluso al desactivar este, solo funciona cuando dejo el Firewall desactivado reinicio y no toco nada, en cuanto activo y desactivo el Firewall o creo alguna regla ya no vuelve a funcionar ni reiniciando ni nada. Saludos

  • Has probado con la interfície gráfica del ufw (gufw) ?

    en cuanto activo y desactivo el Firewall o creo alguna regla ya no vuelve a funcionar ni reiniciando ni nada

    Con ufw status verbose te muestra las políticas por defecto de incoming, outgoing y routed.

    Si pones allow por defecto debería dejar conectar con la impresora:
    ufw default allow

    A partir de aquí, vuelve a poner deny por defecto:
    ufw default deny

    Y aquí viene cuando debes saber qué puerto de entrada debes abrir. Si miras en /etc/services ves que existe el servicio sane-port (puertos 6566 tcp y udp):
    Prueba:
    sudo ufw allow sane-port

    Si lo quieres hacer por IP (imaginamos que la impresora es la 192.168.1.123):
    sudo ufw allow from 192.168.1.123

    A ver si ahora…

problema12 par1 Posts 4Views 540
Log in to reply