• Steam won't open after recent updates


    Hi there. I am having problems running steam after recent updates. All I get in terminal is:

    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(1476379980)

    I use nvidia proprietary driver

  • I had that kinda problem before and I used the following for a while before finding that uninstalling and reinstalling helped for a while:

    LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' steam
    

    Try it and see if it works. I don’t remember how to solve the whole problem and make Steam run from its shortcut, in fact I’ve been using this same command for a while since the same stuff you have has happened to me. It may help, even if temporarily.

    oh boy, here we go again

  • I don’t run steam or have an Nvidia card but on Reddit
    in the Arch subforum there is something about steam and updates. Might want to check it out.

    https://www.reddit.com/r/archlinux/

  • try this on terminal:
    STEAM_RUNTIME=0 steam

    or
    STEAM_RUNTIME=1 steam

    I guess one of them will work and force an update.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Has anyone started getting “fatal error: failed to load steamui.so” anytime they try to open Steam?

    I was trying to do some research on my other Steam based problem and I’ve had that pop up no matter which way I try steam (from menu, from terminal, etc)

steam55 updates32 Posts 5Views 578
Log in to reply