• Nvidia 940mx / Intel 520


    I cannot manage to use my nvidia card in anyway, the system run using
    I have tried to install nvidia nvidia-libgl but after reboot X gives me black screen

    Xorg.log point out an error with glamour

    What I am missing here ?
    any known problem with nvidia 940mx ?
    Should I use any particular driver ? I also tried the nvidia-beta in AUR but same issue

    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
    	Subsystem: Device 1d72:1602
    	Kernel driver in use: i915
    --
    01:00.0 3D controller: NVIDIA Corporation Device 134b (rev a2)
    	Subsystem: Device 1d72:1602
    	Kernel driver in use: nouveau
    
  • @postadelmaga said in Nvidia 940mx / Intel 520:

    …I have tried to install nvidia nvidia-libgl but after reboot X gives me black screen…

    Antergos Wiki: Bumblebee for NVIDIA Optimus.

  • Perfect thx.

    I was using Arch documentation and it was not so clear like this one.

  • @postadelmaga said in Nvidia 940mx / Intel 520:

    Perfect thx.

    I was using Arch documentation and it was not so clear like this one.

    It was written for that :) .

    Rem tene, verba sequentur.

    Marking the topic as [Solved].

    Cheers

  • @just
    I have again problem with this, I think it is related to last upgrade with nvidia driver.

    $ optirun glxspheres32 
    [ 5625.939739] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card
    
    [ 5625.939782] [ERROR]Aborting because fallback start is disabled.
    
    $ sudo modprobe nvidia
    modprobe: ERROR: could not insert 'nvidia': No such device
    

    dmesg shows the following issues

    [ 5558.300804] bbswitch: enabling discrete graphics
    [ 5558.316096] pci 0000:01:00.0: Refused to change power state, currently in D3
    [ 5572.882285] nvidia: module license 'NVIDIA' taints kernel.
    [ 5572.882287] Disabling lock debugging due to kernel taint
    [ 5572.891449] NVRM: This is a 64-bit BAR mapped above 4GB by the system
                   NVRM: BIOS or the Linux kernel, but the PCI bridge
                   NVRM: immediately upstream of this GPU does not define
                   NVRM: a matching prefetchable memory window.
    [ 5572.891450] NVRM: This may be due to a known Linux kernel bug.  Please
                   NVRM: see the README section on 64-bit BARs for additional
                   NVRM: information.
    [ 5572.891453] nvidia: probe of 0000:01:00.0 failed with error -1
    [ 5572.891467] nvidia-nvlink: Nvlink Core is being initialized, major device number 242
    [ 5572.891479] NVRM: The NVIDIA probe routine failed for 1 device(s).
    [ 5572.891479] NVRM: None of the NVIDIA graphics adapters were initialized!
    [ 5572.891480] nvidia-nvlink: Unregistered the Nvlink Core, major device number 242
    [ 5625.958732] bbswitch: enabling discrete graphics
    [ 5625.973092] pci 0000:01:00.0: Refused to change power state, currently in D3
    

    I tried to downgrade the nvidia driver but nothing changed, I tried to reinstall everything from scratch following the guide but same …

  • Solution:
    I found out the issue is not related to the nvidia driver update but to GMD ( I have switched to it recently ).

    • I have switched back to lightdm and rebooted -> optirun started to work again.
    • then I have switched back to GDM and now optirun works also with GDM

    I am not sure why this happened but it worth to share this strange behavior in case somebody experience the same issue
    Maybe the is a bug in some GMD configuration file/systemd.

  • @postadelmaga said in Nvidia 940mx / Intel 520:

    Solution:

    I am not sure why this happened but it worth to share this strange behavior in case somebody experience the same issue

    It certainly should be mentioned in Wiki. But it’s the first time I hear about this behaviour. It must be studied and analyzed with attention, before going to the Wiki. I do not use GDM. LightDM works nicely here. Having a spare time, will probably do it later.

    I noticed another new thing. Recently, bumblebeed daemon (service) requires some seconds before starting up. If optirun status is checked with

    optirun --status
    

    right after the boot, it returns an error, similar to yours.

    Checked after a short delay, without doing anything else, the command reports that everything is OK:

    $ optirun --status
    Bumblebee status: Ready (3.2.1-2016-05-20-Format:%h$). X inactive. Discrete video card is off.
    
    $ 
    

    Edit

    Nice to hear that you can isolate and solve a problem yourself. It’s the right approach to Linux.

  • Thank you for the feedback.
    Actually I have experienced the problem again so it is not related to GDM/LightDM.

    I will add more details if I get more understanding of the issue, maybe it is just related to what you mention:

    Recently, bumblebeed daemon (service) requires some seconds before starting up.

  • When I read nvidia driver, some bells are ringing here. You need bumblebee for your hybrid graphics, you can’t simply use the normal nvidia driver.
    J.

  • @Jeannie____
    If you read above you will see we are already talking about bumblebee

    Solution
    I again had problem with bumblebee not working.

    sudo modprobe nvidia
    modprobe: ERROR: could not insert 'nvidia': No such device
    

    First I have uninstalled bumblebee bbswitch and nvidia driver and reinstalled again and rebooted, then for a while everything worked but then I experienced problems again. ( after reboot or suspend )

    I think I finally found a solution:
    I changed the PPMethod in /etc/bumblebee/bumblebee.conf:

    [driver-nvidia]
    # Module name to load, defaults to Driver if empty or unset
    KernelDriver=nvidia
    #PMMethod=auto
    PMMethod=bbswitch
    

    and created this service /etc/systemd/system/nvidia-enable.service

    [Unit]
    Description=Enable NVIDIA card
    DefaultDependencies=no
    
    [Service]
    Type=oneshot
    ExecStart=/bin/sh -c 'echo ON > /proc/acpi/bbswitch'
    
    [Install]
    WantedBy=shutdown.target
    

    Then enable the service

    sudo systemctl enable nvidia-enable.service
    
  • @postadelmaga It is great that you’ve found such an elaborated solution for the problem. Must study it with more attention later.

    Apparently a similar problem - optirun cannot access secondary GPU (Nvidia) - was discussed in this thread.

    It was caused by the simultaneous use of tlp and bbswitch. Two are in conflict one with another. @xumarcus has found a very elegant solution to workaround a problem.

    Can it be your case, too? Do you use tlp?

  • @just
    The problem happened again, unfortunately I cannot trace what trigger it so I always not 100% sure if a solution works or not.

    Thank you for sharing the tlp post, I am using tlp too … I tried the solution in the post but after few days I got the problem again :(

intel24 nvidia100 940mx1 5201 Posts 12Views 1662
Log in to reply