• Gnome not locking screen automatically


    I just installed antergos with gnome so all the following is refered to the default settings.
    I running gnome 3.22.2 and I cannot manage to lock the screen automatically after a given time.

    I found quite confusing the configuration as it is spread across many setting/app:

    1. Settings -> Power
    • Blank screen (time)
    1. Settings -> Privacy
    • Screen Lock (yes/no)
    1. Light locker
    • Blank screen after (time)
    • Switch screen off after (time)

    I have configured startup applications:

    • Light Locker
    • xset s 60 dpms 420 0 0

    What is wrong ?
    How I am suppose to configure all above settings ?

    My session manager is lightdm

  • @postadelmaga , hi
    Under lightDM all you have to do is disable all native Gnome power settings and use only the Light Locker ones
    That is, unless you prefer to use GDM instead. In such a case Gnome power settings will be working out of the box, but you ll miss Antergos login screen.
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I set

    • Power: Black screen NEVER

    • Privacy: Screen Lock NO

    then set light locker timers, the screen lock correctly
    … but then if I open again light locker my setting are gone and the screen stop to lock correctly

    anything else I can try ?

  • I have the same problem. Only lock screen if i clos the tape.

  • @postadelmaga said

    if I open again light locker my setting are gone and the screen stop to lock correctly
    anything else I can try ?

    Sorry, I have actually uninstalled Light Locker myself and cannot tell. Isn t there a “save” button somewhere so your settings are stored?

    @alaguna , sorry, I didn t understand what your problem is…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • no lockscreen for me either. im using lightdm. i have lock button but does nothing. i dont like leaving my pc unlocked all the time.

  • So, I guess you press the “apply” button but your settings aren t saved. Sorry, but somebody else who uses lightDM+light locker should take over from there on…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • For me light-locker-settings have no effect / do not work…
    Also some if i put “switch off” timer on, it is reset to “never” after restarting the tool, blank screen save the time i put but do not have any effect…

    There are a lot of buggy stuff around GDM/LIGHTDM gnome-shell, have to do something with wayland/X-org changes… if you are not badly unhappy with this failures wait… or try to find a solution what maybe will helpfull for developpers also ;)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • we have two thread I guess with the same error.
    https://forum.antergos.com/topic/5465/buttons-go-missing-from-the-system-menu-in-gnome-3/16

    temporary solution
    $ dm-tool lock

    i ll make a bash script for this so at least I can lock manually.

  • That topic is not about light locker but about some buttons in the menu diapering. it afflict me too but it is not that important to me.

    Somebody in that thread was speaking about a light locker git version on AUR maybe you mean that ?

  • @postadelmaga: also the git version of light-locker do not make lock-session possible…
    the only working solution is

    dm-tool lock
    

    But this do not lock session automaticly…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • I didnt say that the AUR version locks, just that there is a new version, but I didnt make it clear, sorry for that. I just wanted to point out that on github this bug has been reported and it exist in the 1.7 version since it is still marked unsolved. I haven`t tried it but at least u did. ;)

  • @r1kkHUN: you are welcome ;)

    Seems that this is not a problem with light-locker or Lightdm GDM directly… Caus uninstalling light-locker and try using integrated gnome-shell function also do not work…i do not try with GDM running caus i have to use lightdm to suspend my system…

    EDIT:
    Quick try with GDM result in the same no session-lock…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad The new gnome seems to have plenty issues recently, I think it`s better to wait and report bugs to devs. This is a quite important function to leave it buggy for security and privacy reasons.

  • i try to install “gnome-screensaver” and with it running i can lock-session by
    [SUPER+l] !

    I read that inside gnome "if you disable GDM service, Gnome put the gnome-internal-handling on session-lock e.t.c. automaticly to gnome-screensaver… i do not try yet to use timed lockout e.t.c.
    And it is f***** yesterday to use stuff like a “screensaver”… youtu.be/tubes

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • so is it working for you? Its not clear for me. XD

  • @joekamprad
    With GDM everything works fine for me.
    ( to lock the screen super + l )

    My settings:
    Settings -> Power I have set Blank screen (time)
    Settings -> Privacy Screen Lock (yes)
    Light locker removed from startup application

    P.s.
    it is a pity this doesn’t work out of the box on a clean installation …

  • :facepalm:

    distrohopping is the past. the future is gdm and lightdm hopping.

  • So i changed my mind… If we talk about using Gnome-Shell this problem is caused by lightdm.
    Gnome-Shell do not give a usable info, that make light-locker able to lock session…
    So we need to make light-locker able to get the info to lock, or (like i do for now) use gnome-screensaver to lock the session (What is a bit zombi-a-like) Or as @postadelmaga do using GDM…

    I would like that session locking is not depending on the DM or completly depending on the dm… but it needs to be secure and clean!!!

    https://github.com/the-cavalry/light-locker/issues/54 :

    lots0logs commented on 23 Apr 2015:

    I was able to get it to work by launching it from lightdm's xsession wrapper script just before gnome is launched:
    /etc/lightdm/Xsession
    
    ....
    
    /usr/bin/light-locker &
    echo "X session wrapper complete, running session $@"
    
    exec $@
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

gnome-shell10 lockscreen11 lightlocker4 Posts 26Views 2954
Log in to reply