• changing password settings in mate?


    Hi all,
    I set up Antergos Mate to require my password at boot up as i expected to have several desktop choices. Turns out i am happy with just mate and now want to log in without stopping for the password prompt. Would like to know how to edit a file to do this without reinstalling. Thanks much!

  • It’s a feature that depends on display manager in use. It is called “autologin”, and it doesn’t depend on password.

    What display manager do you use? LightDM and GDM are most frequently used in Antergos.

  • @just Hi and thanks. Currently using LightDM. I did find the file but am not sure what to change so that it will no longer require password when booting up.

  • @billwx As root, edit the file /etc/lightdm/lightdm.conf.

    Find the section [Seat:*] in it.

    There are two lines in this section, commented out by default:

    ...
    #autologin-user=
    #autologin-user-timeout=
    ...
    

    Uncomment them both. Put your username on the autologin-user line. Set autologin-user-timeout to 0, to avoid any pause on login.

    In this example LightDM automatically logs in the user just;

    ...
    #--just modded
    #autologin-user=
    #autologin-user-timeout=
    autologin-user=just
    autologin-user-timeout=0
    #--
    ...
    

    Good luck

  • @just Made those changes but it still makes me put in the password. Is there something else here i need to change? Thanks.
    [Seat:*]
    #type=xlocal
    #pam-service=lightdm
    #pam-autologin-service=lightdm-autologin
    #pam-greeter-service=lightdm-greeter
    #xserver-command=X
    #xmir-command=Xmir
    #xserver-config=
    #xserver-layout=
    #xserver-allow-tcp=false
    #xserver-share=true
    #xserver-hostname=
    #xserver-display-number=
    #xdmcp-manager=
    #xdmcp-port=177
    #xdmcp-key=
    #unity-compositor-command=unity-system-compositor
    #unity-compositor-timeout=60
    greeter-session=lightdm-webkit2-greeter
    #greeter-hide-users=false
    #greeter-allow-guest=true
    #greeter-show-manual-login=false
    #greeter-show-remote-login=true
    user-session=mate
    #allow-user-switching=true
    #allow-guest=true
    #guest-session=
    session-wrapper=/etc/lightdm/Xsession
    #greeter-wrapper=
    #guest-wrapper=
    #display-setup-script=
    #display-stopped-script=
    #greeter-setup-script=
    #session-setup-script=
    #session-cleanup-script=
    #autologin-guest=false
    autologin-user=bill
    autologin-user-timeout=0
    #autologin-in-background=false
    #autologin-session=
    #exit-on-failure=false

  • @billwx said in changing password settings in mate?:

    @just Made those changes but it still makes me put in the password…

    Strange, it works usually. I have no other ideas, for the moment.

  • I got this in addition to Just’s suggestions from the Arch Lightdm wiki. I think you still have to add yourself to the autologin group.

    Enabling autologin

    Edit the LightDM configuration file and ensure these lines are uncommented and correctly configured:
    [Seat:*]
    pam-service=lightdm
    pam-autologin-service=lightdm-autologin
    autologin-user=username
    autologin-user-timeout=0
    session-wrapper=/etc/lightdm/Xsession

    LightDM goes through PAM even when autologin is enabled. You must be part of the autologin group to be able to login automatically without entering your password:

    # groupadd -r autologin
    
    # gpasswd -a username autologin
    

    Never to old to learn.

  • This discussion in the forum gives some more additional information:
    Auto Login for KDE

    Never to old to learn.

  • @billwx

    @axioma said in changing password settings in mate?:
    …I think you still have to add yourself to the autologin group.

    :+1:

    Yes, sure, @axioma is absolutely right! I just forgot about it. You must be a member of autologin group.

  • @axioma Solved! Thanks much guys, adding myself to the autologin group via terminal commands did the trick.

  • @billwx said in changing password settings in mate?:

    @axioma Solved!..

    Marking the topic as such.

password16 mate42 changing10 Posts 11Views 593
Log in to reply