• Prolem w/ Lightdm after fresh install. Won't boot into Wayland.


    After a fresh install of Antergos with GNOME, the desktop environment dropdown menu shows too many “GNOME” options: “GNOME”, “GNOME”, “GNOME Classic”, and “GNOME on Xorg”. Both two top “GNOME” options seem to do the same thing as the “GNOME on Xorg” option, so they seem redundant. I’m assuming that both top GNOME options are to boot into Wayland, but they don’t work – system won’t boot into Wayland. Installing GDM, however, and setting that as primary boots into Wayland just fine.

    So, two problems after install:
    (1) Two redundant “GNOME” options at start-up (I realize I can change this manually, but I think this should be fixed out-of-the-box".
    (2) System won’t boot into Wayland from LightDM. Booting to Wayland from GDM works fine.

    0_1479500637865_20161118_112842.jpg


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • @jesse.dubord

    Hi , Gnome starts Wayland by default from 3.22 version.
    But 2 “GNOME” ¿¿??

    Cheers

  • @Archrysler thanks for the reply, and the info’ about GNOME 3.22 starting Wayland by default. However, if that’s the case, wouldn’t the graphics in the “Details” section of System Settings show Wayland? Here’s a screenshot of my Details section in System settings:

    0_1479502042360_Screenshot from 2016-11-18 12-45-28.png


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • I can confirm that my system is running X when selecting either of the two top “GNOME” options in the Login Manager. I tried running gtk-recordmydesktop, which crashes when running Wayland. It didn’t crash on start, so I take that as I’m not running Wayland.


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • Hi , Open console

    xrandr
    

    I have antergos with Openbox, but Arch with Gnome, I’ll answer from there.

    One moment.

  • Hi

    0_1479502825182_Screenshot from 2016-11-18 21-59-33.png

    Gnome by default

  • To check what Gnome session is in use, run:

    echo $XDG_SESSION_TYPE
    

    If Gnome runs on Wayland, the command returns

    wayland
    

    If Gnome runs on X, the command returns

    X11
    

    When Gnome runs on Wayland, the

    gnome-control-center info
    

    command opens

    0_1479502934422_gnome-3.22.1-on-wayland.png
    When Gnome runs on X, the same command opens

    0_1479502985019_gnome-3.22.1-on-xorg.png
    I uninstalled all Gnome 3 instances when it has arrived to 3.22, so can’t add more info on the matter.

    Regards

  • @Archrysler Gotcha, thanks, here’s a screenshot of my xrander output. I’m definitely running X. I guess the question I’m trying to ask is: can these options be fixed so that, after install, there’s no 2nd redundant “GNOME” menu option, and to have one of them boot into Wayland? Where would I go to report this?

    0_1479503195859_Screenshot from 2016-11-18 13-05-25.png


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • @just Thanks for the reply, the output shows I’m running X11.


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • wayland is not complete… seems that on some hardware it does not start… specially on systems with more than one GPU/card…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @joekamprad I understand. However, when I install gdm and set it as default, Wayland is the default login option, and it boots just fine.

    From terminal:
    yaourt -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    reboot
    So, again, I’m just wondering why these two top GNOME options are here in the Login Manager if they do the same thing as “GNOME on Xorg”, and whether they can be changed to a single entry that boots via Wayland?


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • They do not the same… only if thery are running on fallback modus…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @jesse.dubord

    First try on console

    dbus-run-session -- gnome-session --display-server --wayland
    

    And test

    echo $XDG_SESSION_TYPE
    

    If it works, we can make it permanent

  • @Archrysler , running from Terminal produces this error:

    ** (gnome-session-binary:15428): WARNING **: Unknown option --display-server


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • Ok

    Wayland and/or Xwayland is not installed …or not completely.

    Wait for another user, my solution would be to reinstall

    Sorry

  • [email protected] ~ % pacman -Qs wayland
    local/lib32-wayland 1.12.0-1
        A computer display server protocol
    local/wayland 1.12.0-1
        A computer display server protocol
    local/wayland-protocols 1.7-1
        Specifications of extended Wayland protocols
    local/xorg-server-xwayland 1.18.4-1 (xorg)
        run X clients under wayland
    
    [email protected] ~ % dbus-run-session -- gnome-session --session=wayland
    Activating service name='org.gtk.vfs.Daemon'
    Successfully activated service 'org.gtk.vfs.Daemon'
    [email protected] ~ % echo $XDG_SESSION_TYPE
    
    wayland
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • Thinking more … Is KMS installed? Nvidia Card?

    Reviewing the wiki, I read:

    “Currently Wayland will only work on systems using KMS”

  • The packages are all installed alright. When I set gdm as the default display manager and log into the “GNOME” (wayland) session from gdm, Wayland boots just fine. It’s only on Antergos’s default display manager, lightdm, that I get the multiple GNOME menu options, with neither of them successfully booting into GNOME Wayland.

    The laptop I’m using has Intel graphics, no proprietary graphics are used or needed, I believe. :)


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

  • and everybody having the two same same Gnome Gnome starting options…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    how to add system logs

  • @joekamprad , this has been the case for all of my installs on multilpe machines in the last 48 hours – they all have the Gnome Gnome starting options in Lightdm after fresh install, which is what brought about the OP question(s): 1. Can the redundant entry be fixed/removed? And 2. can the supposed GNOME Wayland entry be looked at, because it doesn’t appear to be starting a GNOME Wayland session, successfully?


    "Always do right. This will gratify some people and astonish the rest." - Mark Twain

    Jesse DuBord
    FILMMAKER

gnome wayland2 ligthdm3 login manager10 gnome 3.22.210 Posts 30Views 2838
Log in to reply