• [Solved] Cannot enter encryption password with some keyboards


    Hi, I installed Antergos on an USB stick (for a portable system) and enabled encryption.
    Now I have to enter my password everytime I want to boot the system.
    The problem is: All keyboards do work in Grub, but when it comes to enter the password to boot the system, only some keyboards work.
    I already tryed USB 2.0 and 3.0, but there is no difference.
    This is very bad, because my built-in laptop keyboard also doesn’t work there. I have to connect an external USB keyboard to enter my password and boot.
    Also I want to boot the system on other pcs, without having a working keyboard with me.

  • I’d try to move keybaord (and maybe keymap) hooks out of autodetection.

    Edit the /etc/mkinitcpio.conf file and make the HOOKS= line look like:

    HOOKS="base udev keyboard keymap autodetect modconf block resume filesystems fsck"
    

    Remember to rebuild the initramfs after that:

    sudo mkinitcpio -p linux
    

    Just a guess. It may or may not work.

  • @just Didn’t work, ended up with this:
    0_1479483794499_20161118_163640-1.jpg

  • @Bleuzen You must boot from the USB with the Antergos installed (your USB), and rebuild the initramfs from inside the working DE,

    On the image you’re inside the Grub 2 recovery shell, not in the working Antergos.

  • @just I booted up Antergos from USB and change the HOOKS line using “nano /etc/mkinitcpio.conf” from the KDE konsole.
    After this, I executed “sudo mkinitcpio -p linux” in the same terminal / konsole and then “reboot”.
    I booted from USB again and got this message.

  • @Bleuzen You’re using UUID= in the /etc/fstab. For some reason, it has been changed for the / partition.

    Instead of UUID, try to use use /dev/sdaN notation. Usually external USBs are recognized as /dev/sda by Linux. So comment out the existing UUID= line in /etc/fstab, duplicate it, and replace UUID= with /dev/sda1 (or another number of .the partition that holds the / on your USB).

    Edit

    Grub 2 kernel boot line uses root= instruction as well. It must be also changed from UUID to /dev/sdaN. I do not use Grub 2, so can’t help with it.

  • @just I tryed to reinstall, because i can’t modify files, because the system is encrypted and i didn’t have another working antergos installation to mount the encrypted volume.
    Now installation fails to install grub, which is strange, because it already worked one time. I will try it again tomorrow.
    After I reinstalled …
    Should I try this with ‘HOOKS’ again? I guess no ;D

  • @Bleuzen said in Cannot enter encryption password with some keyboards:

    …Should I try this with ‘HOOKS’ again? I guess no ;D

    No, you shouldn’t - if you can’t boot from modified USB.

  • I’m late to the discussion, but it seems to me that OP didn’t do what he was meant to do while being chroot in the installed system (/mnt for example).

    crypsetup luksOpen /dev/sda1 root
    mount /dev/mapper/root /mnt
    [etc.]
    arch-chroot /mnt
    vim /etc/mkinitcpio.conf
    mkinitcpio -p linux
    exit
    umount -R /mnt
    reboot 0
    

    The second issue (screenshot) seems GRUB or fstab related but I’m no expert. Clearly the GRUB_CMD_LINUX="" is not set properly or something.

  • – Problem solved –
    … by doing updates.

boot271 password30 encryption14 keyboard issue5 Posts 10Views 1599
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.