• Screen tearing when watching videos


    Hello! I’m using Antergos with KDE and I’m experiencing screen tearing when watching videos on VLC and KPlayer.

    The screen tearing seems to happen when there’s fast paced movement inside the video. I’ve tried changing the render backend between OpenGL 2.0 and OpenGL 3.1 and it doesn’t seem to help.

    Any ideas on what to do?

  • Which Application style are you using? I experienced screen problems when using Qtcurve.
    Also make sure you have set Tearing prevention to automatic. For me OpenGL-2 / accurate seems to work best.
    You could also try to switch between kwin_x11 and kwin_wayland.
    kwin_wayland --enable

    Never to old to learn.

  • @axioma I honestly wouldn’t be able to tell you what Application Style I’m using lol. Just the default KDE setup.

    Yeah, I left it at OpenGL-2 and tearing is set to automatic, also

    [[email protected] ~]$ kwin_wayland --enable
    Unknown option ‘enable’.

  • @dgameman1 Ooops, my wrong: --enable should be - -replace

    Never to old to learn.

  • @axioma Lmao

    [[email protected] ~]$ kwin_wayland -replace
    Unknown options: r, e, p, l, a, c, e.
    [[email protected] ~]$ kwin_wayland --replace
    Unknown option 'replace'.
    [[email protected] ~]$
    
  • @dgameman1 The commant was correct, it did also not work for Kwin_wayland when I just tried. It does though, when you use kwin_x11 instead. You can also just use kwin_x11 in Konsole.

    Do you have an also an other DE installed? Especially Compton can disrupt Kwin. If so, make sure the WM of the other desktop does not autostart when you log into Plasma. In that case you will have to restart kwin_x11 in Konsole and un-check the other WM in Settings.

    Never to old to learn.

  • One more question, which I maybe should have asked first, but do you have Nvidia?
    In that case make sure you have the proper drivers installed. Also this article I found might be of help: link text

    Never to old to learn.

  • Hey @dgameman1
    I found this guide that explain a way to remove tearing with newer nvidia graphics cards
    https://www.cmscritic.com/how-to-fix-nvidia-screen-tearing-in-xfce-mate-kde-lxde-and-others

    If you don’t have the nvidia-settings application, you can install it by enter the following command in terminal

    sudo pacman -S nvidia-settings 
    
  • @dgameman1 Changing to full screen repaints worked for me…

  • @dgameman1 Make sure you have installed your GPU drivers

  • To be honest guys, I just went ahead and reinstalled the Gnome version of Antergos cause I didn’t really like xfce or kde.

    And there’s now no more screen tearing lol

screen tearing1 graphics card7 Posts 11Views 486
Log in to reply