• Want to boot Linux 4.4.31-1-lts kernel instead of latest kerenel


    Hello. How do I make Antergos boot the Linux 4.4.31-1-lts kernel instead of the newest kernel? Basically I want to have the LTS kernel listed first in the Grub menu so it is booted automatically. I picked the LTS kernel at install but it is not listed first. Thank you very much.

  • As you can see, I changed (Grub_Default =saved) and uncommented (GRUB_SAVEDEFAULT=“true”)

    GRUB_DEFAULT=saved
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="Antergos"
    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=0af79f70-089f-461a-b43d-95cc8862830d"
    GRUB_CMDLINE_LINUX=""
    
    # Preload both GPT and MBR modules so that they are not missed
    GRUB_PRELOAD_MODULES="part_gpt part_msdos"
    
    # Uncomment to enable Hidden Menu, and optionally hide the timeout count
    #GRUB_HIDDEN_TIMEOUT=5
    #GRUB_HIDDEN_TIMEOUT_QUIET=true
    
    # Uncomment to use basic console
    GRUB_TERMINAL_INPUT=console
    
    # Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=auto
    
    # Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX=keep
    
    # Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
    # format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    GRUB_DISABLE_RECOVERY=true
    
    # Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
    # modes only.  Entries specified as foreground/background.
    #GRUB_COLOR_NORMAL="light-blue/black"
    #GRUB_COLOR_HIGHLIGHT="light-cyan/blue"
    
    # Uncomment one of them for the gfx desired, a image background or a gfxtheme
    #GRUB_BACKGROUND="/path/to/wallpaper"
    GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"
    
    # Uncomment to get a beep at GRUB start
    #GRUB_INIT_TUNE="480 440 1"
    
    GRUB_SAVEDEFAULT="true"
    

    Saved it then I entered sudo grub-mkconfig -o /boot/grub/grub.cfg into the terminal, and all it does is hight the second entry in the grub menu, then boot the latest kernel. If I change Grub_default= to Grub_Default=1>2 which should be Advanced Options then Lts kernel it does the same thing. I must be not doing something else with the /etc/default/grub file. Thank you very much for your help.

  • Hello everyone. I marked this topic as solved because I decided to install Grub Customizer. After starting Grub Customizer I clicked on the “General Settings” tab, then clicked “predefined” then picked “Advanced options for Antergos Linux>Antergos Linux LTS Kernel”. Then I saved it from the Grub Customizer “File” menu, exited and rebooted the computer and It now boots the LTS Kernel, and it doesn’t change the look of the Grub menu in anyway because I didn’t change anything else. If anyone is successful doing this using another method please let me know so it can be shared with the community. Thank you again for your help.

kerenel1 kernel74 4.4.31-1-lts1 boot159 Posts 4Views 471
Log in to reply