• Steam does not run certain games except with Terminal command


    I’m running Steam on an Arch system installed the Arch Way along with XFCE. I’ve installed Steam-Native and the appropriate runtimes and drivers. For the Half Life and Countet Strike games this seems to work fine. However, for Portal 2, System Shock 2 and Duke Nukem 3D do not run from Steam unless I run

    LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' /usr/bin/steam
    

    via the Terminal. Is there a way to set this up so that selecting Steam from the Whisker Menu will run these games? If you need more output from the terminal be glad to post it

    Thank you!

  • This post is deleted!
  • @DanielPowerNL said i

    If you’re using Arch, you should be asking on the Arch forums rather than here.

    He has. But to no avail We are aware of that, he has (discreetly) asked permission if he could post here.
    Thanks for your help and understanding:+1: .

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Steam does not run certain games except with Terminal command:

    @DanielPowerNL said i

    If you’re using Arch, you should be asking on the Arch forums rather than here.

    He has. But to no avail We are aware of that, he has (discreetly) asked permission if he could post here.
    Thanks for your help and understanding:+1: .

    Thanks Anarch :)

    Daniel, thanks for the response, but I actually have already installed Steam-Native-Runtime and am running Steam exclusively from Steam-Native. For many games (the half life series, original Portal, and Counter Strike Condition Zero) this has solved all problems I was having (initially Steam-Native would not run at all), but for the three games I’ve mentioned, they will not run without that particular terminal command.

    Sorry if my inital post didn’t make that clear

  • It seems the games you mentioned need that particular libraries, so i’m guessing thats why steam-native can’t launch them.
    Is there any way to link those libraries to your games? (i’m newbie but i guess again that it should do the trick), so you won’t need to use the command every time…
    Cheers.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Well I would think there’s someway that I can link the terminal command to the entry on the Whisker Menu, but thus far it has remained elusive. I’ve even tried changing the command on the menu to that terminal entry, but that left me with a nonfunctional steam

    Don’t feel bad about being a newbie, we all gotta start somewhere! Clearly I am!

  • @chasbel2112
    hahaha :+1:
    When you load the libraries you use Steam or Steam-native?

    Another thing: while you don’t find a good solution you can create a script to load the library and launch steam native, then add a shortcut and that’s it.

    #!/bin/bash
    LD_PRELOAD=’/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so’ /usr/bin/steam
    /usr/bin/steam-native

    I didn’t test, but probably work :)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I always run Steam-Native. I’ve found that nothing happens when just running Steam.

    I may just do that, although I would like to find a more elegant solution if you know what i mean

  • Yes of course, it’s just a workaround if youre in a hurry to play. hahaha
    I’m sure someone else will appear and help you.
    Good luck :+1:

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Thanks bud!
    I wouldn’t say i’m in a “hurry” to play haha, obviously the terminal command can run these games as can my (shudder) Windows PC, but I can sometimes be out of the country without internet access, so it pays to have this stuff figured out beforehand.

  • Hey! I’m also having the exact same issue where games won’t run unless I start steam with that command.

  • @dgameman1 nice to know I’m not the only one!
    I would imagine whatever way that tells Steam-Native to launch would be able to be set as how to always launch steam somehow, but I’m not sure how to do it. ArchWiki seems to imply that there is a way, but there seems to be some sort of moral aversion to explaining things over there…

  • @chasbel2112 For real. I’ve posted in their forums and I haven’t gotten a response yet.

    And some of my games don’t work when I run steam-native so it’s nice that at least this works for now :P

  • @dgameman1 Don’t expect one. I tried to get help with this issue only to get berated for supposedly “not reading the wiki.” Wonder if they realize the wiki may not be the most clear document to a newbie.

    And at least you can play, I’m suddenly getting an error that Steamui.so can’t be loaded!

  • @chasbel2112

    I didn’t end up downloading the update I just received for steam.
    I see an update for ‘steam-native-runtime’ version 1.0.0.52-9.

    I’m currently on version 1.0.0.52-8.

    Which version are you on and did you end up getting it fixed?

  • I’m having the same problem as well with Portal 2, even though all my other games work fine. Haven’t tried Duke Nukem: Megaton Edition.

    If it’s only for a few select games, here’s a clean workaround that will only affect the specific games that need the extra libraries loaded. Steam now allows us to set launch options for individual games. I’ll use Portal 2 as an example.

    1 Right click Portal 2 in Steam and click Properties
    2 Click Set Launch Options…
    3 Paste the following into the text box:
    LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' %command%

    %command% will be replaced with the Portal 2 executable. This is very useful for any game that you need to load extra libraries for, or even for running a script before launching a game.

    Edit: To clarify, you actually write %command% in the textbox. Don’t replace it with anything. Steam will automatically replace %command% with the game’s executable.

  • @DanielPowerNL
    Holy. You’re a god.

    And I use this with steam-native or the other steam?

  • You can use it with either, but I’d recommend steam-native, because it will use your native system libraries rather than the outdated Ubuntu Runtime libraries.

    Meaning you’ll get better performance with steam-native.

  • This post is deleted!
  • @DanielPowerNL This is The antergos forums :p
    And it actually doesn’t work on the steam-native for me :P

except2 games10 steam53 certain4 Posts 32Views 2800
Log in to reply