• Pacman won't upgrade/EVE Online installation


    Hello people,
    First of all, I’m kinda new here, so if this post is on the wrong place, please forgive my ignorance 🙂
    So, heading to install Eve Online, I started facing a few problems. Following the directions of this link, I checked to see if I had multilib already, and to see if it was uncommented or not on /etc/pacman.conf
    When asked to type

    sudo pacman -S wine wine_gecko winetricks q4wine wine-mono lib32-gnutls samba lib32-mpg123 lib32-sdl lib32-libldap lib32-libpulse
    

    I received the following:

    error: configuration file /etc/pacman.conf, line 1: all directives must belong to a session
    

    and now I have no idea what to do or how to bring pacman.conf back to normal. Can anyone help me with this?

    oh boy, here we go again

  • Publish your pacman.conf so we can see what’s wrong, please (you can use paste2.org and put the link here)

    Cheers!

  • Here it is!
    http://paste2.org/tzvpYZ5E

    oh boy, here we go again

  • Odd. I see no problems there.

    What do you get if you issue a :
    sudo pacman -Syyuu

  • The exact same error:

    error: configuration file /etc/pacman.conf, line 1: all directives must belong to a session
    

    oh boy, here we go again

  • The only thing I did when trying to install EVE was insert the # in [multilib], then removing right after the error came up. But then, the error continued to appear. I have tried rebooting three times already to no avail.

    oh boy, here we go again

  • Geez, I don’t see what’s wrong with your setup.

    Can you also post your /etc/pacman.d/mirrorlist file?

    There is an error in your pacman setup (or so it seems).

  • Here, take a look
    http://paste2.org/HzVOXAX2

    oh boy, here we go again

  • @karasu comparing my pacman.conf i see a missplaced line(priority), but i’m newbie, not sure if is this.

    [antergos]
    SigLevel = PackageRequired
    Include = /etc/pacman.d/antergos-mirrorlist

    from @olivigora is at the bottom, mine is above #[testing]
    What do you think?

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • I tried doing what @fernandomaroto suggested but nothing changed

    oh boy, here we go again

  • This is really odd.

    OK, please comment the multilib repo in pacman.conf:

    #[multilib]
    #Include = /etc/pacman.d/mirrorlist
    

    and use this http://paste2.org/nVghP7dY as your mirrorlist file (rename the one you already have).

    Remember to uncomment one or two of the mirrors in the mirrorlist file.

    EDIT: Just in case, comment also the Antergos repo in pacman.conf:

    #[antergos]
    #SigLevel = PackageRequired
    #Include = /etc/pacman.d/antergos-mirrorlist
    
  • Did what @karasu said, but nothing changed. Still get the same error.
    I may be saying something stupid, but isn’t there something wrong with line 1? Shouldn’t it be something more than just #?

    oh boy, here we go again

  • Ok, let’s do this.

    Move your pacman.conf and your mirrorlist files to somewhere else, like /tmp.

    Reinstall pacman and pacman-mirrorlist:

    sudo pacman -U /var/cache/pacman/pkg/pacman-5.0.1-4-x86_64.pkg.tar.xz
    sudo pacman -U /var/cache/pacman/pkg/pacman-mirrorlist-20161114-1-any.pkg.tar.xz
    

    See if now you can update your repo databases and system:

    sudo pacman -Syyuu
    

    In line 1, you can put whatever you like as long as it starts with #

    I’m starting to think that there’s something else wrong here.

    EDIT: Could you try this sudo pacman -Syyuu --debug and put the output also in paste2 ?

  • Again, it seems pacman is nothing but unusable. I get the same old error when trying to reinstall it. Will try moving it to another folder.
    Will give the result of the debug in a minute.

    oh boy, here we go again

  • Okay, results from the last tries:

    as long as the command is

    sudo pacman
    

    nothing seems to work. Maybe if I copy someone else’s pacman.conf?

    oh boy, here we go again

  • It seems the problem isn’t with pacman.conf at the same time it seems it is. I copied your file, @karasu , but when I try sudo pacman -Syyuu I get the same error.

    oh boy, here we go again

  • To be honest, I do not know what’s wrong here. It complains about pacman.conf but pacman.conf is ok ¿?

    Let’s hope somebody else knows what’s happening here.

    EDIT: Oh, remember to run pacman with --debug and post it, maybe something else is shown.

  • Thanks for the help, @karasu
    About the --debug, it shows the exact same error, pacman.conf is totally unusable

    oh boy, here we go again

  • UPDATES:
    After updating a few stuff, I got a different error when trying to access pacman.conf. It gives the following

    [[email protected] ~]$ sudo pacman -Syyuu --debug
    [sudo] senha para ---------: 
    debug: pacman v5.0.1 - libalpm v10.0.1
    debug: config: attempting to read file /etc/pacman.conf
    erro: configuration file etc/pacman.conf, line 1: all directives must belong to a session. 
    [[email protected] ~]$ 
    
    

    oh boy, here we go again

pacman104 wine23 eve online1 Posts 31Views 4347
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.