• Installed yesterday on ZFS. Can't boot after a kernel update today.


    Hi,

    I installed Antegros on ZFS yesterday and everything worked great on my Thinkpad X1 Carbon. This morning there was a couple of updates, looked like kernel updates and I thought I was to install them (I came from Ubuntu where I always installed the available updates). The update took very long, more than 5 minutes. I didn’t pay attention to it and thought things went well. Then I reboot, I get the blue welcome screen but then a blank screen with this:

    ERROR: resume: no device specified for hibernation
    ash: 1: unknown operand
    The ZFS modules are not loaded
    Try running '/sbin/modprobe zfs' as root to load them.
    ERROR: failed to mount the real root device
    Bailing out, you are on your own. Good luck
    
    sh: can't access tty: job control turned off
    [rootfs ]#_ 
    

    Even I understand that this is bad. Probably very bad to the extent I have to reinstall? Anyway, ZFS may not be such a good idea if I reinstall? I used btrfs on Ubuntu without problems, but I have read all these horror stories about btrfs lately so I thought I would try the hyped up ZFS file system. Oh well. Let me know how busted I am please! 🙂

    Not a flying start on my second try to transition to Antegros from Ubuntu, but I’ll try again if I have to! 🙂

    //Christian

  • @lots.0.logs said in Installed yesterday on ZFS. Can't boot after a kernel update today.:

    This should help: https://forum.antergos.com/topic/5418/zfs-on-root-and-kernel-upgrade-process

    Thank you! The first post explaining how to solved this by chrooting from the LIVE USB media solved it for me.

    //Christian

zfs40 booting problem18 modules9 Posts 3Views 740
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.