• Screenfetch Prevents Terminal From Running

    In the Gnome environment I have installed screenfetch.

    I have not added screenfetch to or edited the bashrc file.

    When I run screenfetch from the terminal, any terminal program, the Antergos graphic appears but the default Terminal (Gnome terminal I believe) won’t start after closing the terminal.

    Other terminal programs like Terminix and Guake work fine after running screenfetch.

    Is this a bug with Gnome terminal and is it possible to fix this issue?


  • Hello.
    Edit /usr/bin/screenfetch to comment out the following lines:


    After that terminal should work fine.

  • @Makaveli , thanks for sharing👍

  • @Makaveli , would you mind marking it as “SOLVED”, please?
    Click on the “TOPIC TOOLS” on the bottom R-H corner to find the option.

  • @anarch I’m not the OP so I don’t think I can mark it as solved. Or am I wrong?

  • @Makaveli
    Oooops! Sorry!
    @johnyv123 , will you please mark it as “SOLVED”?
    Click on the “TOPIC TOOLS” on the bottom R-H corner to find the option.

  • @Makaveli Thank you, your solution worked.

    So from the the terminal I typed,

    sudo gedit /usr/bin/screenfetch

    to open the screenfetch file in a text editor with root privileges and then added # in front of each of the three lines you mentioned to comment them out and saved the file, I could have deleted the three line also as you mentioned.


    Then to auto start screenfetch, opened the file manager and from the home directory typed the control + h keys to unhide the hidden files and opened the .bashrc file with a text editor and added the command screenfetch -t on the very last line of the .bashrc file.

    Screenfetch with the Antergos logo appears now when the terminal is opened and the terminal now works.

    Thank you for your help and will mark this post as solved.


terminal46 running20 screenfetch4 prevents4 Posts 7Views 1741
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.