• Screenfetch Prevents Terminal From Running


    In the Gnome environment I have installed screenfetch.

    I have not added screenfetch to or edited the bashrc file.

    When I run screenfetch from the terminal, any terminal program, the Antergos graphic appears but the default Terminal (Gnome terminal I believe) won’t start after closing the terminal.

    Other terminal programs like Terminix and Guake work fine after running screenfetch.

    Is this a bug with Gnome terminal and is it possible to fix this issue?

    thanks.

  • Hello.
    Edit /usr/bin/screenfetch to comment out the following lines:

    LANG=C
    LANGUAGE=C
    LC_ALL=C
    

    After that terminal should work fine.

  • @Makaveli , thanks for sharing:+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @Makaveli , would you mind marking it as “SOLVED”, please?
    Click on the “TOPIC TOOLS” on the bottom R-H corner to find the option.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch I’m not the OP so I don’t think I can mark it as solved. Or am I wrong?

  • @Makaveli
    Oooops! Sorry!
    @johnyv123 , will you please mark it as “SOLVED”?
    Click on the “TOPIC TOOLS” on the bottom R-H corner to find the option.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @Makaveli Thank you, your solution worked.

    So from the the terminal I typed,

    sudo gedit /usr/bin/screenfetch

    to open the screenfetch file in a text editor with root privileges and then added # in front of each of the three lines you mentioned to comment them out and saved the file, I could have deleted the three line also as you mentioned.

    #LANG=C
    #LANGUAGE=C
    #LC_ALL=C

    Then to auto start screenfetch, opened the file manager and from the home directory typed the control + h keys to unhide the hidden files and opened the .bashrc file with a text editor and added the command screenfetch -t on the very last line of the .bashrc file.

    Screenfetch with the Antergos logo appears now when the terminal is opened and the terminal now works.

    Thank you for your help and will mark this post as solved.

    Cheers.

running5 terminal27 prevents2 screenfetch1 Posts 7Views 533
Log in to reply