• Enable screen lock / blank screen in Antergos?


    How do you enable screen lock / blank screen in Antergos with Gnome desktop.

    What are the steps required to ensure that the screen locks or blanks after a set time. In other words what do I need to enable or disable in, Light Locker, screensaver, power and privacy settings what are the correct combinations to enable the lock screen and blank the screen?

    I can see on my system that the following are available:

    1. Light Locker Setting is available
    2. Screen Locker in startup applications
    3. Screensaver in startup applications
    4. The default lock screen, I believe it to be Light DM
    5. Power and privacy in the settings menu

    It sounds like a basic request but it is an important one that is easy to enable in other Linux operating systems and it is frustrating not being able to work this out…

  • Have you disabled any settings you may have had in Gnome s native power settings and then enable what you want from light locker?

    To manually lock the screen, there s an extension too that places an icon on the taskbar.
    https://extensions.gnome.org/extension/83/lock-screen/
    (the keyboard shortcuts should be Ctrl+Alt+L or Windowskey+L (haven t used Gnome for some time and not sure which one).

    To manually blank the screen there s also an extension (not working under Wayland)
    https://extensions.gnome.org/extension/897/turn-off-display/

    You may also take a look at this thead:
    https://forum.antergos.com/topic/5430/screen-won-t-turn-off-after-set-time-on-my-lenovo-thinkpad-x1-carbon/2
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch thanks for your response.

    Figured out what works for me.

    With lightdm as the lock screen:

    In the settings menu, under privacy, Screen Lock set to Off

    In the settings menu, under power, Blank Screen set to Never

    In the Light Locker Settings:

    1. Set Blank screen after to desired duration, this will blank the screen after the set time.
    2. Turn on Enable light-locker.
    3. Set Automatically lock the session to - When the screensaver is activated.
    4. Apply these settings.

    In startup applications, which I can see through the Tweek Tool, I have Screensaver and Screen Locker present and therefore set to start when the operating system starts.

    This worked for me this post is marked as solved.

    Cheers.

  • @johnyv123 , You re welcome!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

blank screen10 screenlock1 Posts 4Views 1668
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.