• Screen won't turn off after set time on my Lenovo Thinkpad X1 Carbon


    Hi,

    I just got Antergos on my Lenovo Thinkpad X1 Carbon and all works well except for the screen not turning off after the set amount of time. I have it set to turn off after 1 minute but nothing happens. I am running the GNOME desktop. It works on Ubuntu which I used to have on this laptop. How do I get this to work?

    Update, I am able to get it to work with “xset s 60” for a minute delay so this is a GNOME problem. I would like to be able to set it in GNOME though and not have to script it.

    //Christian

  • @cdysthe said

    I am running the GNOME desktop

    Hi. No, it is not a Gnome issue. In Antergos Gnome, under lightDM, the native Gnome power settings don t take effect. You ll have to use the “light locker settings” instead, which is already installed in your system. Remember to disable what you ve set in Gnome s native power settings, of course…
    Alternatively, you can switch to GDM if you want to avoid the above procedure. In this case, however, you ll have Gnome s default login screen plus an extra 150 MBs added as you ll notice that under GDM there are 2 Gnome shell instances running. One is used to switch users and cannot be disabled.
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Thank you! Got GDM instead and it worked. Thanks! :)

    //Christian

  • You re welcome! Would you mind marking it as “SOLVED”, please?
    Click on the “TOPIC TOOLS” on the bottom R-H corner to find the option.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • This has been a common problem for quite a while. Will this be addressed in future releases of Antergos?

  • This has been a common problem for quite a while. Will this be addressed in future releases of Antergos?

    How can this be addressed?

    If you use lightdm you must use light locker settings, if you use gdm then you must use Gnome power settings. I don’t see anything that needs fixing… ;)

  • The light locker settings do not work out of the box ;). Hence, it needs to be fixed ;). Every thread where this is brought up, it is recommended to run gdm instead ;).

  • In Antergos Gnome, under lightDM, the native Gnome power settings don t take effect. You ll have to use the “light locker settings” instead, which is already installed in your system.

    ;)

  • Because the complaint is about light locker settings not working, there s one more sentence to the above:
    Disable all power settings you may have applied from the Gnome s native System Settings, before:+1: .

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @karasu said

    If you use lightdm you must use light locker settings, if you use gdm then you must use Gnome power settings. I don’t see anything that needs fixing…

    Karasu, despite this, I think we have to admit that this behavior of Gnome under our default DM is a nasty welcoming experience to newcomers and it somehow should be addressed… Maybe some notice? (sorry if such already exists).

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Screen won't turn off after set time on my Lenovo Thinkpad X1 Carbon:

    @karasu said

    If you use lightdm you must use light locker settings, if you use gdm then you must use Gnome power settings. I don’t see anything that needs fixing…

    Karasu, despite this, I think we have to admit that this behavior of Gnome under our default DM is a nasty welcoming experience to newcomers and it somehow should be addressed… Maybe some notice? (sorry if such already exists).

    I use my laptop for work and based on the way I work all the power settings has to work which they do on Ubuntu which I came from. I came to Antegros because of wi-fi problems on the last two versions of Ubuntu. This is the second time I try Antegros. Last time I had the exact same problem but didn’t remember it. I spend an hour trying to find out and was very close to just jump to Mint but decided to wait for an answer here. For someone new to Antegros it doesn’t feel very welcoming having a problem like that immediately after intstall, especially when it should be very simple to fix it, or code in an information bubble saying that the settings doesn’t work with the default DM. Even that doesn’t sound very good, but it’s better than letting newbies fumble around to figure it out :)
    I’m still on Antegros and will stay this time. I have migrated four of our Thinkpads now and have a couple more to go. I had to abandon ZFS because it was buggy, but it was fun to try. So thank you guys for getting back so soon here. I know understand that I can use Lightlocker to get this to work with LightDM, but who would I want LightDM when GDM is the DM that comes with GNOME in the first place? :)

    //Christian

  • @cdysthe said i

    who would I want LightDM when GDM is the DM that comes with GNOME in the first place?

    If the above statement should apply to any and each one of the DMs Antergos supports or will be supporting in the future, then we would have to employ all kinds of native Desktop Managers for each and every Desktop Environment. That would be a total mess!
    We need a unified Antergos DM with its own logo and character. Here, the devs have done an excellent work. It is BEAUTIFUL!
    The problem is eliminated to Gnome, which unfortunately is our default DE. Unfortunately not in terms of my own preferences, but because as default, it is the most widely installed, thus a major drawback to someone unaware of what he/she has got to do to apply power settings.
    So, in my opinion, if nothing better can be done, some info should be given in some form of a notice.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Screen won't turn off after set time on my Lenovo Thinkpad X1 Carbon:

    @cdysthe said i

    who would I want LightDM when GDM is the DM that comes with GNOME in the first place?

    If the above statement should apply to any and each one of the DMs Antergos supports or will be supporting in the future, then we would have to employ all kinds of native Desktop Managers for each and every Desktop Environment. That would be a total mess!
    We need a unified Antergos DM with its own logo and character. Here, the devs have done an excellent work. It is BEAUTIFUL!
    The problem is eliminated to Gnome, which unfortunately is our default DE. Unfortunately not in terms of my own preferences, but because as default, it is the most widely installed, thus a major drawback to someone unaware of what he/she has got to do to apply power settings.
    So, in my opinion, if nothing better can be done, some info should be given in some form of a notice.

    I agree on all counts. However, the DM is not very important to me personally. I see it once in the blue moon since I do not reboot very often, but the Antegros implementation of LightDM is the best I’ve seen. I like the dull old GDM as well though. It feels safe and known. All of this would be resolved with information somewhere strategic to avoid waste of time after Antegros is installed. It’s just such a downer having that kind of problem as your “Welcome to Antegros” experience. I did have problems with ZFS also which I kinda resolved, but I decided to move back to btrfs since that is another known to me (just like GDM) :)

    //Christian

powermanagement11 gnome219 display31 Posts 13Views 1011
Log in to reply