• Problem with pacman and pipelight


    On pacman i have error message:

    [[email protected] ~]$ export LANG=C && sudo pacman -Syyu
    [sudo] password for kate: 
    error: GPGME error: Invalid crypto engine
    :: Synchronizing package databases...
     antergos                           133.5 KiB   563K/s 00:00 [################################] 100%
     core                               120.1 KiB   858K/s 00:00 [################################] 100%
     extra                             1752.8 KiB  1638K/s 00:01 [################################] 100%
     community                            3.7 MiB  1639K/s 00:02 [################################] 100%
     pipelight                          150.5 KiB   697K/s 00:00 [################################] 100%
     pipelight.sig                      543.0   B  0.00B/s 00:00 [################################] 100%
    error: GPGME error: Invalid crypto engine
    error: failed to update pipelight (invalid or corrupted database (PGP signature))
     multilib                           184.1 KiB  1615K/s 00:00 [################################] 100%
    error: database 'pipelight' is not valid (invalid or corrupted database (PGP signature))
    [[email protected] ~]$ 
    

    Then, i deinstall pipelight but i have same errors.

    What can i do?

    ThinkPad x200 with Antergos

  • @Danica_Talos more errors:

    [[email protected] ~]$ export LANG=C && sudo pacman -Syyu
    [sudo] password for kate: 
    :: Synchronizing package databases...
     antergos                           133.5 KiB   456K/s 00:00 [################################] 100%
     core                               120.1 KiB   379K/s 00:00 [################################] 100%
     extra                             1752.8 KiB   526K/s 00:03 [################################] 100%
     community                            3.7 MiB   971K/s 00:04 [################################] 100%
     multilib                           184.1 KiB  1497K/s 00:00 [################################] 100%
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (16) bash-4.4-1  cinnamon-3.2.1-2  cinnamon-desktop-3.2.0-1  cinnamon-menus-3.2.0-1
                  cinnamon-screensaver-3.2.2-1  cinnamon-session-3.2.0-1
                  cinnamon-settings-daemon-3.2.0-1  cinnamon-translations-3.2.1-1  cjs-3.2.0-1.1
                  libpcap-1.8.1-2  libusb-1.0.21-1  muffin-3.2.0-1  nemo-3.2.0-1
                  numix-frost-themes-3.6.6-1  readline-7.0-1  xapps-1.0.2-1
    
    Total Download Size:   10.06 MiB
    Total Installed Size:  66.34 MiB
    Net Upgrade Size:       4.16 MiB
    
    :: Proceed with installation? [Y/n] y
    :: Retrieving packages...
     cjs-3.2.0-1.1-x86_64               160.4 KiB  1022K/s 00:00 [################################] 100%
     cinnamon-desktop-3.2.0-1-x86_64    231.7 KiB  1309K/s 00:00 [################################] 100%
     muffin-3.2.0-1-x86_64              969.5 KiB  1663K/s 00:01 [################################] 100%
     cinnamon-translations-3.2.1-1-any    2.2 MiB  1542K/s 00:01 [################################] 100%
     nemo-3.2.0-1-x86_64                858.8 KiB  1684K/s 00:01 [################################] 100%
     cinnamon-menus-3.2.0-1-x86_64       46.8 KiB  1734K/s 00:00 [################################] 100%
     cinnamon-screensaver-3.2.2-1-...   161.4 KiB  1681K/s 00:00 [################################] 100%
     cinnamon-session-3.2.0-1-x86_64    212.2 KiB  1671K/s 00:00 [################################] 100%
     cinnamon-settings-daemon-3.2....   983.4 KiB  1687K/s 00:01 [################################] 100%
     cinnamon-3.2.1-2-x86_64              2.2 MiB  1563K/s 00:01 [################################] 100%
     numix-frost-themes-3.6.6-1-any     242.4 KiB  1616K/s 00:00 [################################] 100%
     readline-7.0-1-x86_64              294.9 KiB  1027K/s 00:00 [################################] 100%
     bash-4.4-1-x86_64                 1416.9 KiB  1605K/s 00:01 [################################] 100%
     libusb-1.0.21-1-x86_64              54.0 KiB  1637K/s 00:00 [################################] 100%
     libpcap-1.8.1-2-x86_64             216.9 KiB  1631K/s 00:00 [################################] 100%
     xapps-1.0.2-1-x86_64                17.6 KiB  1355K/s 00:00 [################################] 100%
    (16/16) checking keys in keyring                             [################################] 100%
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    (16/16) checking package integrity                           [################################] 100%
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: readline: missing required signature
    :: File /var/cache/pacman/pkg/readline-7.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: bash: missing required signature
    :: File /var/cache/pacman/pkg/bash-4.4-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cjs: missing required signature
    :: File /var/cache/pacman/pkg/cjs-3.2.0-1.1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-desktop: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-desktop-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: muffin: missing required signature
    :: File /var/cache/pacman/pkg/muffin-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-translations: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-translations-3.2.1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: nemo: missing required signature
    :: File /var/cache/pacman/pkg/nemo-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-menus: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-menus-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-screensaver: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-screensaver-3.2.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-session: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-session-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: libusb: missing required signature
    :: File /var/cache/pacman/pkg/libusb-1.0.21-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-settings-daemon: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-settings-daemon-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: xapps: missing required signature
    :: File /var/cache/pacman/pkg/xapps-1.0.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-3.2.1-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: libpcap: missing required signature
    :: File /var/cache/pacman/pkg/libpcap-1.8.1-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: numix-frost-themes: missing required signature
    :: File /var/cache/pacman/pkg/numix-frost-themes-3.6.6-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: failed to commit transaction (invalid or corrupted package (PGP signature))
    Errors occurred, no packages were upgraded.
    [[email protected] ~]$ sudo pacman -Scc
    
    Cache directory: /var/cache/pacman/pkg/
    :: Do you want to remove ALL files from cache? [y/N] y
    removing all files from cache...
    
    Database directory: /var/lib/pacman/
    :: Do you want to remove unused repositories? [Y/n] y
    removing unused sync repositories...
    [[email protected] ~]$ sudo pacman -Syy
    :: Synchronizing package databases...
     antergos                           133.5 KiB   726K/s 00:00 [################################] 100%
     core                               120.1 KiB   822K/s 00:00 [################################] 100%
     extra                             1752.8 KiB  1557K/s 00:01 [################################] 100%
     community                            3.7 MiB  1522K/s 00:02 [################################] 100%
     multilib                           184.1 KiB  1534K/s 00:00 [################################] 100%
    [[email protected] ~]$ sudo pacman -S haveged
    warning: haveged-1.9.1-2 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) haveged-1.9.1-2
    
    Total Download Size:   0.04 MiB
    Total Installed Size:  0.13 MiB
    Net Upgrade Size:      0.00 MiB
    
    :: Proceed with installation? [Y/n] y
    :: Retrieving packages...
     haveged-1.9.1-2-x86_64              37.9 KiB   677K/s 00:00 [################################] 100%
    (1/1) checking keys in keyring                               [################################] 100%
    error: GPGME error: Invalid crypto engine
    (1/1) checking package integrity                             [################################] 100%
    error: GPGME error: Invalid crypto engine
    error: haveged: missing required signature
    :: File /var/cache/pacman/pkg/haveged-1.9.1-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: failed to commit transaction (invalid or corrupted package (PGP signature))
    Errors occurred, no packages were upgraded.
    [[email protected] ~]$ sudo haveged -w 1024
    [[email protected] ~]$ sudo pacman-key --init
    gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory
    gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory
    ==> Updating trust database...
    gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory
    ==> ERROR: Trust database could not be updated.
    [[email protected] ~]$ sudo pacman-key --populate archlinux antergos
    ==> Appending keys from archlinux.gpg...
    gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory
    ==> Appending keys from antergos.gpg...
    gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory
    ==> Locally signing trusted keys in keyring...
      -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
    ==> ERROR: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 could not be locally signed.
      -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
    ==> ERROR: 684148BB25B49E986A4944C55184252D824B18E8 could not be locally signed.
      -> Locally signing key 24B445614FAC071891EDCE49CDBD406AA1AA7A1D...
    ==> ERROR: 24B445614FAC071891EDCE49CDBD406AA1AA7A1D could not be locally signed.
      -> Locally signing key D95436A2E18DA94A72B1A5E2AEA529BF122902E5...
    ==> ERROR: D95436A2E18DA94A72B1A5E2AEA529BF122902E5 could not be locally signed.
      -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
    ==> ERROR: 91FFE0700E80619CEB73235CA88E23E377514E00 could not be locally signed.
      -> Locally signing key EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4...
    ==> ERROR: EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4 could not be locally signed.
      -> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...
    ==> ERROR: 44D4A033AC140143927397D47EFD567D4C7EA887 could not be locally signed.
      -> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
    ==> ERROR: 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 could not be locally signed.
      -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
    ==> ERROR: AB19265E5D7D20687D303246BA1DFB64FFF979E7 could not be locally signed.
    [[email protected] ~]$ sudo pkill haveged
    [[email protected] ~]$ sudo pacman -S archlinux-keyring antergos-keyring
    warning: archlinux-keyring-20161101-1 is up to date -- reinstalling
    warning: antergos-keyring-20150806-1 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (2) antergos-keyring-20150806-1  archlinux-keyring-20161101-1
    
    Total Download Size:   0.60 MiB
    Total Installed Size:  0.84 MiB
    Net Upgrade Size:      0.00 MiB
    
    :: Proceed with installation? [Y/n] y
    :: Retrieving packages...
     antergos-keyring-20150806-1-any     13.8 KiB   417K/s 00:00 [################################] 100%
     archlinux-keyring-20161101-1-any   598.2 KiB  1300K/s 00:00 [################################] 100%
    (2/2) checking keys in keyring                               [################################] 100%
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    (2/2) checking package integrity                             [################################] 100%
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: archlinux-keyring: missing required signature
    :: File /var/cache/pacman/pkg/archlinux-keyring-20161101-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: antergos-keyring: missing required signature
    :: File /var/cache/pacman/pkg/antergos-keyring-20150806-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: failed to commit transaction (invalid or corrupted package (PGP signature))
    Errors occurred, no packages were upgraded.
    [[email protected] ~]$ y
    bash: y: command not found
    [[email protected] ~]$ sudo pacman -Syu
    :: Synchronizing package databases...
     antergos is up to date
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (16) bash-4.4-1  cinnamon-3.2.1-2  cinnamon-desktop-3.2.0-1  cinnamon-menus-3.2.0-1
                  cinnamon-screensaver-3.2.2-1  cinnamon-session-3.2.0-1
                  cinnamon-settings-daemon-3.2.0-1  cinnamon-translations-3.2.1-1  cjs-3.2.0-1.1
                  libpcap-1.8.1-2  libusb-1.0.21-1  muffin-3.2.0-1  nemo-3.2.0-1
                  numix-frost-themes-3.6.6-1  readline-7.0-1  xapps-1.0.2-1
    
    Total Download Size:   10.06 MiB
    Total Installed Size:  66.34 MiB
    Net Upgrade Size:       4.16 MiB
    
    :: Proceed with installation? [Y/n] y
    :: Retrieving packages...
     cjs-3.2.0-1.1-x86_64               160.4 KiB   863K/s 00:00 [################################] 100%
     cinnamon-desktop-3.2.0-1-x86_64    231.7 KiB  1340K/s 00:00 [################################] 100%
     muffin-3.2.0-1-x86_64              969.5 KiB  1323K/s 00:01 [################################] 100%
     cinnamon-translations-3.2.1-1-any    2.2 MiB  1634K/s 00:01 [################################] 100%
     nemo-3.2.0-1-x86_64                858.8 KiB  1694K/s 00:01 [################################] 100%
     cinnamon-menus-3.2.0-1-x86_64       46.8 KiB  1800K/s 00:00 [################################] 100%
     cinnamon-screensaver-3.2.2-1-...   161.4 KiB  1664K/s 00:00 [################################] 100%
     cinnamon-session-3.2.0-1-x86_64    212.2 KiB  1671K/s 00:00 [################################] 100%
     cinnamon-settings-daemon-3.2....   983.4 KiB  1468K/s 00:01 [################################] 100%
     cinnamon-3.2.1-2-x86_64              2.2 MiB  1673K/s 00:01 [################################] 100%
     numix-frost-themes-3.6.6-1-any     242.4 KiB  1616K/s 00:00 [################################] 100%
     readline-7.0-1-x86_64              294.9 KiB  1053K/s 00:00 [################################] 100%
     bash-4.4-1-x86_64                 1416.9 KiB  1636K/s 00:01 [################################] 100%
     libusb-1.0.21-1-x86_64              54.0 KiB  1637K/s 00:00 [################################] 100%
     libpcap-1.8.1-2-x86_64             216.9 KiB  1631K/s 00:00 [################################] 100%
     xapps-1.0.2-1-x86_64                17.6 KiB  1036K/s 00:00 [################################] 100%
    (16/16) checking keys in keyring                             [################################] 100%
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    (16/16) checking package integrity                           [################################] 100%
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: GPGME error: Invalid crypto engine
    error: readline: missing required signature
    :: File /var/cache/pacman/pkg/readline-7.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: bash: missing required signature
    :: File /var/cache/pacman/pkg/bash-4.4-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] yy
    error: cjs: missing required signature
    :: File /var/cache/pacman/pkg/cjs-3.2.0-1.1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-desktop: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-desktop-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: muffin: missing required signature
    :: File /var/cache/pacman/pkg/muffin-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-translations: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-translations-3.2.1-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: nemo: missing required signature
    :: File /var/cache/pacman/pkg/nemo-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-menus: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-menus-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-screensaver: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-screensaver-3.2.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-session: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-session-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: libusb: missing required signature
    :: File /var/cache/pacman/pkg/libusb-1.0.21-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon-settings-daemon: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-settings-daemon-3.2.0-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: xapps: missing required signature
    :: File /var/cache/pacman/pkg/xapps-1.0.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: cinnamon: missing required signature
    :: File /var/cache/pacman/pkg/cinnamon-3.2.1-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: libpcap: missing required signature
    :: File /var/cache/pacman/pkg/libpcap-1.8.1-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: numix-frost-themes: missing required signature
    :: File /var/cache/pacman/pkg/numix-frost-themes-3.6.6-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: failed to commit transaction (invalid or corrupted package (PGP signature))
    Errors occurred, no packages were upgraded.
    [[email protected] ~]$ 
    
    

    ThinkPad x200 with Antergos

  • Hi,

    What’s the output of
    sudo pacman-key --populate archlinux antergos ?

    And what do you get if you try to reinstall archlinux-keyring and antergos-keyring packages?

    sudo pacman -U /var/cache/pacman/pkg/archlinux-keyring-20161101-1-any.pkg.tar.xz
    sudo pacman -U /var/cache/pacman/pkg/antergos-keyring-20150806-1-any.pkg.tar.xz
    
  • @karasu said in Problem with pacman and pipelight:

    Hi,

    What’s the output of
    sudo pacman-key --populate archlinux antergos ?

    And what do you get if you try to reinstall archlinux-keyring and antergos-keyring packages?

    sudo pacman -U /var/cache/pacman/pkg/archlinux-keyring-20161101-1-any.pkg.tar.xz
    sudo pacman -U /var/cache/pacman/pkg/antergos-keyring-20150806-1-any.pkg.tar.xz
    

    [[email protected] ~]$ sudo pacman-key --populate archlinux antergos
    [sudo] Passwort für kate:
    ==> Füge Schlüssel aus archlinux.gpg hinzu…
    gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory
    ==> Füge Schlüssel aus antergos.gpg hinzu…
    gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory
    ==> Signiere die vertrauenswürdigen Schlüssel im Schlüsselbund lokal…
    -> Signiere Schlüssel 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 lokal…
    ==> FEHLER: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 konnte nicht lokal signiert werden.
    -> Signiere Schlüssel 684148BB25B49E986A4944C55184252D824B18E8 lokal…
    ==> FEHLER: 684148BB25B49E986A4944C55184252D824B18E8 konnte nicht lokal signiert werden.
    -> Signiere Schlüssel 24B445614FAC071891EDCE49CDBD406AA1AA7A1D lokal…
    ==> FEHLER: 24B445614FAC071891EDCE49CDBD406AA1AA7A1D konnte nicht lokal signiert werden.
    -> Signiere Schlüssel D95436A2E18DA94A72B1A5E2AEA529BF122902E5 lokal…
    ==> FEHLER: D95436A2E18DA94A72B1A5E2AEA529BF122902E5 konnte nicht lokal signiert werden.
    -> Signiere Schlüssel 91FFE0700E80619CEB73235CA88E23E377514E00 lokal…
    ==> FEHLER: 91FFE0700E80619CEB73235CA88E23E377514E00 konnte nicht lokal signiert werden.
    -> Signiere Schlüssel EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4 lokal…
    ==> FEHLER: EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4 konnte nicht lokal signiert werden.
    -> Signiere Schlüssel 44D4A033AC140143927397D47EFD567D4C7EA887 lokal…
    ==> FEHLER: 44D4A033AC140143927397D47EFD567D4C7EA887 konnte nicht lokal signiert werden.
    -> Signiere Schlüssel 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 lokal…
    ==> FEHLER: 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 konnte nicht lokal signiert werden.
    -> Signiere Schlüssel AB19265E5D7D20687D303246BA1DFB64FFF979E7 lokal…
    ==> FEHLER: AB19265E5D7D20687D303246BA1DFB64FFF979E7 konnte nicht lokal signiert werden.
    [[email protected] ~]$

    [[email protected] ~]$ sudo pacman-key --populate archlinux antergos
    [sudo] Passwort für kate: 
    ==> Füge Schlüssel aus archlinux.gpg hinzu...
    gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory
    ==> Füge Schlüssel aus antergos.gpg hinzu...
    gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory
    ==> Signiere die vertrauenswürdigen Schlüssel im Schlüsselbund lokal...
      -> Signiere Schlüssel 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 lokal...
    ==> FEHLER: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 konnte nicht lokal signiert werden.
      -> Signiere Schlüssel 684148BB25B49E986A4944C55184252D824B18E8 lokal...
    ==> FEHLER: 684148BB25B49E986A4944C55184252D824B18E8 konnte nicht lokal signiert werden.
      -> Signiere Schlüssel 24B445614FAC071891EDCE49CDBD406AA1AA7A1D lokal...
    ==> FEHLER: 24B445614FAC071891EDCE49CDBD406AA1AA7A1D konnte nicht lokal signiert werden.
      -> Signiere Schlüssel D95436A2E18DA94A72B1A5E2AEA529BF122902E5 lokal...
    ==> FEHLER: D95436A2E18DA94A72B1A5E2AEA529BF122902E5 konnte nicht lokal signiert werden.
      -> Signiere Schlüssel 91FFE0700E80619CEB73235CA88E23E377514E00 lokal...
    ==> FEHLER: 91FFE0700E80619CEB73235CA88E23E377514E00 konnte nicht lokal signiert werden.
      -> Signiere Schlüssel EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4 lokal...
    ==> FEHLER: EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4 konnte nicht lokal signiert werden.
      -> Signiere Schlüssel 44D4A033AC140143927397D47EFD567D4C7EA887 lokal...
    ==> FEHLER: 44D4A033AC140143927397D47EFD567D4C7EA887 konnte nicht lokal signiert werden.
      -> Signiere Schlüssel 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 lokal...
    ==> FEHLER: 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 konnte nicht lokal signiert werden.
      -> Signiere Schlüssel AB19265E5D7D20687D303246BA1DFB64FFF979E7 lokal...
    ==> FEHLER: AB19265E5D7D20687D303246BA1DFB64FFF979E7 konnte nicht lokal signiert werden.
    [[email protected] ~]$ 
    
    

    ThinkPad x200 with Antergos

  • @Danica_Talos

    [[email protected] ~]$ sudo pacman -U /var/cache/pacman/pkg/archlinux-keyring-20161101-1-any.pkg.tar.xz
    Lade Pakete...
    Fehler: '/var/cache/pacman/pkg/archlinux-keyring-20161101-1-any.pkg.tar.xz': Konnte Paket nicht finden oder lesen
    [[email protected] ~]$ sudo pacman -U /var/cache/pacman/pkg/antergos-keyring-20150806-1-any.pkg.tar.xz
    Lade Pakete...
    Fehler: '/var/cache/pacman/pkg/antergos-keyring-20150806-1-any.pkg.tar.xz': Konnte Paket nicht finden oder lesen
    [[email protected] ~]$ 
    
    

    ThinkPad x200 with Antergos

  • gpg: error while loading shared libraries: libreadline.so.7: cannot open shared object file: No such file or directory

    This could be the culprit. You should update your readline package.
    http://mirrors.evowise.com/archlinux/core/os/x86_64/readline-7.0-1-x86_64.pkg.tar.xz

    Use sudo pacman -U readline-7.0-1-x86_64.pkg.tar.xz

  • @karasu

    I have solved my problem with re-install my backup (my first clean-install) and install all updates. Now works my antergos without probelms.

    ThinkPad x200 with Antergos

  • Well, sorry to hear that as it is always preferable to know what is wrong.

    Anyway, remember to issue a sudo pacman -Syu from time to time (once a week at least).

    Cheers!

  • @karasu

    THX

    ThinkPad x200 with Antergos

pipelight1 pacman77 Posts 9Views 1201
Log in to reply