• Macbook Pro Install Fails


    Adding modprobe.blacklist-nouveau, I have the exact same error.
    Passing nouveau.modeset=0, I have a blinking _ with no text.
    Adding nouveau.modeset=o nomodeset and systemd.unit=multi-user.target allows me to boot to tty1. When I tried running startx from there, I got

    Fatal server error:
                        (EE) no screens found(EE) 
                                                  (EE)
                                                      Please consult the X.Org Foundation support
    

    along with some other information, after which it wrote

    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    xinit: server error
    

    .

  • @RandomUser33

    Hi, try also nouveau.blacklist=1 in your kernel line.

  • Passing only nouveau.blacklist=1, the computer fails to boot, writing

    [FAILED] Failed to start Light Display Manager.
    See 'systemctl status lightdm.service' for details.
             Starting Pamac...
    [  OK  ] Started Update man-db cache.
    [  OK  ] Started Pamac.
    _
    

    , with _ blinking in regular intervals. Here is the output of journalctl, the xorg log, and the lightdm log.

  • @RandomUser33 The main idea remains the same as already suggested - exclude nouveau from being used.

    Try to instruct the kernel to do so in a slightly different form:

    modprobe.blacklist=nouveau
    

    Sometimes the parameter works in one form, sometimes in another.

  • Adding modprobe.blacklist-nouveau, I have the exact same error.
    Passing nouveau.modeset=0, I have a blinking _ with no text.
    Adding nouveau.modeset=o nomodeset and systemd.unit=multi-user.target allows me to boot to tty1. When I tried running startx from there, I got

    Fatal server error:
                        (EE) no screens found(EE) 
                                                  (EE)
                                                      Please consult the X.Org Foundation support
    

    along with some other information, after which it wrote

    xinit: giving up
    xinit: unable to connect to X server: Connection refused
    xinit: server error
    

    .

  • Do you have managed to install Antergos on yout MBP?
    Check the wiki page that i have put up:
    “Install dual boot MacOS X & Antergos on a MacBookPro 9,1”, Search for that title in the Wiki because Akismet blocks the post with URL.

    In the latest Antergos iso there is no CD/DVD option anymore, choose the first one of the list, that works now!
    I will change the wiki.

fails34 macbook24 pro15 Posts 6Views 1214
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.