have two Dell XPS 13 notebooks: one called darwin3 which is the first generation and has an Intel wifi card and t
he other one called darwin4 which is the 2015 (9343) model. The latter came with a Broadcom wifi card and I replace
d it with an Intel Wireless 7265 card.

The two notebooks run Antergos (Gnome in darwin3 and KDE in darwin4). They both run kernel 4.8.7-1. Wifi signal strength is quite poor in darwin4. For instance, with both notebooks quite close to my wifi router at work (less than two meters distance) iwconfig
returns:

wlp1s0    IEEE 802.11  ESSID:"DE-FC"  
          Mode:Managed  Frequency:2.417 GHz  Access Point: A0:F3:C1:5A:41:EA   
          Bit Rate=28.9 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2832   Missed beacon:0

lo        no wireless extensions.

[email protected] ~ $ iwconfig

Notice the difference in link quality and also in Tx excessive retries. 
0    IEEE 802.11  ESSID:"DE-FC"  
          Mode:Managed  Frequency:2.417 GHz  Access Point: A0:F3:C1:5A:41:EA   
          Bit Rate=86.7 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
         Link Quality=40/70  Signal level=-70 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:84   Missed beacon:0

lo        no wireless extensions.

Notice the difference in link quality. 

dmesg in darwi3: 

[email protected] ~ $ dmesg | grep wifi
[    2.238705] iwlwifi 0000:01:00.0: can't disable ASPM; OS doesn't have ASPM control
[    2.246457] iwlwifi 0000:01:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
[    2.270014] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    2.270016] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[    2.270018] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[    2.270020] iwlwifi 0000:01:00.0: Detected Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0
[    2.272176] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    2.799090] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0
[    3.529558] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    3.536620] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    3.536725] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0
[    3.820217] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    3.827294] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    3.827397] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0
[    3.917202] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    3.924225] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    3.924312] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0
[    4.204923] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    4.211930] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    4.212017] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0
[    8.122311] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    8.129330] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    8.129418] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0
[    8.409474] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    8.416538] iwlwifi 0000:01:00.0: L1 Enabled - LTR Disabled
[    8.416640] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0

dmesg in darwin4:

[email protected] ~ $ dmesg | grep iwlwifi
[    1.831444] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
[    1.832191] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-24.ucode failed with error -2
[    1.832204] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-23.ucode failed with error -2
[    1.837102] iwlwifi 0000:02:00.0: loaded firmware version 22.361476.0 op_mode iwlmvm
[    1.874032] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7265, REV=0x210
[    1.878596] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    1.878799] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    2.039456] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
[    2.804172] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    2.804375] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    2.870294] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    2.870496] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    2.894273] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    2.894476] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    2.960252] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    2.960454] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled

Using options iwlwifi 11n_disable=1 in darwin4 did not help. linux-firmware is installed on both computers.

Suggestions are welcome.