• Cannot Start Gnome on Xorg; Please Help


    Antergos on Dell XPS 13 9360 (2106 Kaby Lake). Using systemd. Dual boot with W10. GDM.

    As of yesterday (there were a few updates, but not sure which exactly), I cannot start Gnome on Xorg, only on Wayland. On Xorg, it goes gray after I enter my password, but that’s all that happens. I can drop into shell, but I can’t get it it to run a Gnome session on Xorg.

    Searched all over online. Four possible solutions, all failed:

    • locale is messed up. It wasn’t, but I regenerated it anyway. No effect.
    • Go back to LightDM, but f I switch back to LightDM, same thing happens (black screen with X cursor, not gray).
    • Gnome user account corrupted, which does’t make sense since it works fine in Wayland, but I completely reinstalled Antergos anyway. Same effect immediately post install. I even installed Antergos Base and then installed Gnome myself. No effect.
    • Press Esc key at frozen gray screen to continue to boot Gnome on Xorg. No effect
    • Change clock back to 24 hour time. It was already on 24 hour time, but I toggled it. No effect.

    There were some other things I’ve tried, but I still can’t boot Gnome on Xorg.

    You may be wondering why I want to boot Xorg instead of Wayland? Well, Wayland has this annoying habit of slow loading Gnome 3.22 apps (Nautilus, Terminal, etc.) They load OK, but leave this annoying spinning circle up on the application’s menu in top bar. Anyone have any ideas about that?

    Anyway, appreciate any help I can get on this inability to load Gnome on Xorg.

    Thanks!
    Benjamin

  • So I just set up a different machine, and same thing. I can only launch a Wayland session, not Xorg. Is no one else seeing this?

  • Any logs available ? For example.

    Keep Your Mind in a Constant State of Openness

  • Thanks for responding. You can download see the logs I can find here:

    https://drive.google.com/drive/folders/0ByCKApHsjRxOSExoYkZCQnFjTTg?usp=sharing

    I could not find any .xsession-errors logs inside my Home folder. Not sure why.

    Thanks in advance for any help you can offer!! :)

  • Hi,

    Try booting with modprobe.blacklist=nouveau in your linux kernel line (press ‘e’ to edit it when the grub menu is shown).

    Then, when your desktop manager appears, go to a terminal (CTRL+ALT+F2) and uninstall nouveau driver:
    sudo pacman -Rns x86-video-nouveau

    Reboot and try to login again.

    Hope this helps, it’s a wild guess.

    Cheers!

  • By switching from using the latest kernel to using the LTS kernel, I am able to boot into Xorg. So it seems something with kernel 4.8 prevents it, but using this one, I am able to boot Xorg:

    Linux xps15 4.4.31-1-lts #1 SMP Thu Nov 10 18:01:16 CET 2016 x86_64 GNU/Linux

    Happy to be back on Xorg. Wayland really doesn’t feel ready. Weird behavior and laggy.

  • @benjaminnyc When you get to your login screen try (CTRL+ALT+F2) Give yourself su privileges. Then type in
    sudo pacman -S gnome
    from there try reinstalling the gnome-shell and other core software to your system
    After that type in
    sudo reboot
    This worked for me hope it helps.

  • Thanks, but this is happening on FRESH installs of Gnome. As in Gnome installed anew 5 minutes before.

  • Last night’s update to mutter fixed this. I can now launch Xorg on testing kernel 4.8.x once again.

xorg22 gnome227 Posts 9Views 1143
Log in to reply