• "No key available with this passphrase" after installation


    I have installed Antergos with full disk encryption on one of my laptops and it works perfectly. However, when installing it on my other laptop with full disk encryption I get a “No key available with this passphrase” error after I enter my passphrase during boot. The weird thing is that eventually it will work but it is most always after I enter it multiple times. It could be after I enter it 10, 20 or 30+ times. If I boot from the live Antergos USB then I can unlock the volume on the first try every time. This is the image that I have used to make the USB for installation antergos-2016.10.23-x86_64.iso. Any ideas on what is going on here?

  • Have you checked your keyboard?
    And your layout?

    (sorry if this is obvious to you).

  • @karasu Yeah I thought the same thing. I tested the keyboard in gedit with my password multiple times and it always worked correctly, so it seems to be functioning properly. I also tried testing the keyboard in the grub command line and it always worked correctly. I assumed the key layout to be correct since it will eventually work and it works in the grub command line. When I first turned the laptop on today it took the passphrase the very first time but since I restarted it wont accept it.

  • @karasu I assume that grub has its own key layout setting when you first boot. How can I verify what this is set to?

  • So more info. I installed Debian on this same laptop and it has the exact same issue when the disk is encrypted. Not really sure what is going on here.

passphrase1 installation194 key8 Posts 5Views 499
Log in to reply