• Cinnamon: nemo and nemo-dropbox conflict


    Hi there,

    Recently community/nemo file manager and antergos/nemo-dropbox Nemo extension packages have entered in conflict one with another.

    community/nemo-3.0.6-2 wants to upgrade to 3.2.0-1.

    But antergos/nemo-dropbox-3.0.0-2 requires nemo < 3.1.

    It doesn’t allow antergos/nemo-dropbox users to perform an upgrade, currently available in Cinnamon:

    $ yaourt -Syyua
    [sudo] password for just: *********
    :: Synchronizing package databases...
     core               120.3 KiB  1647K/s 00:00 [----------] 100%
     extra             1755.7 KiB  3.90M/s 00:00 [----------] 100%
     community            3.7 MiB  2.76M/s 00:01 [----------] 100%
     multilib           184.4 KiB  3.22M/s 00:00 [----------] 100%
     antergos           131.1 KiB  3.20M/s 00:00 [----------] 100%
     netrunner           14.0 KiB   279K/s 00:00 [----------] 100%
     apricity-core       13.9 KiB  0.00B/s 00:00 [----------] 100%
     apricity-core.sig  287.0   B  0.00B/s 00:00 [----------] 100%
     bluestar            39.3 KiB   786K/s 00:00 [----------] 100%
     bluestar-plasma    832.0   B  0.00B/s 00:00 [----------] 100%
    error: failed to prepare transaction (could not satisfy dependencies)
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: nemo-dropbox: installing nemo (3.2.0-1) breaks dependency 'nemo<3.1'
    $
    

    A workaround is to temporarily uninstall antergos/nemo-dropbox package:

    sudo pacman -Rc nemo-dropbox
    

    perform Cinnamon upgrade:

    ...
    :: Starting full system upgrade...
    resolving dependencies...
    looking for conflicting packages...
    
    warning: insufficient columns available for table display
    Packages (33) antergos-mirrorlist-20161107-2  baobab-3.22.1-1  bc-1.06.95-2
                  cinnamon-3.2.0-1  cinnamon-control-center-3.2.0-1
                  cinnamon-desktop-3.2.0-1  cinnamon-session-3.2.0-1
                  cinnamon-settings-daemon-3.2.0-1  cinnamon-translations-3.2.0-1
                  cjs-3.2.0-1  cups-2.2.1-1  cups-filters-1.11.6-1
                  evolution-data-server-3.22.2-1  gnome-desktop-1:3.22.2-1
                  gnome-online-accounts-3.22.2-1  gnome-photos-3.22.2-1
                  gnome-terminal-3.22.1-1  gspell-1.2.1-1
                  gtk-update-icon-cache-3.22.3-1  gtk3-3.22.3-1
                  gtksourceview3-3.22.1-1  gvfs-1.30.2-1  gvfs-mtp-1.30.2-1
                  imagemagick-6.9.6.3-1  liblouis-3.0.0-1  liblqr-0.4.2-1
                  muffin-3.2.0-1  nemo-3.2.0-1  ocl-icd-2.2.9-1  qpdf-6.0.0-2
                  smplayer-16.11.0-1  vte-common-0.46.1-1  vte3-0.46.1-1
    
    Total Download Size:    42.78 MiB
    Total Installed Size:  237.18 MiB
    Net Upgrade Size:       36.92 MiB
    
    :: Proceed with installation? [Y/n] Y
    ...
    

    and try to live without nemo-dropbox for some time. Maybe antergos/nemo-dropbox-3.0.0 will be updated later, to make it compatible with community/nemo-3.2.0.

    Regards

  • @just
    Maybe you could leave nemo from being upgraded? only nemo. I cannot try it, but it’s a possibility, isn’t it ?

    IgnorePkg=nemo
    

    inside pacman.conf until the problem is resolved.

    Thanks

    Keep Your Mind in a Constant State of Openness

  • @NickTh said in Cinnamon: nemo and nemo-dropbox conflict:

    @just
    Maybe you could leave nemo from being upgraded? only nemo. I cannot try it, but it’s a possibility, isn’t it ?..

    Yes, sure, you’re absolutely right!

    It is possible to exclude nemo from upgrades by including it in the IgnorePkg= instruction. As always, the same result may be obtained in Linux in many different ways.

    But personally I prefer to have the most recent nemo version, the core Cinnamon element, and I’m almost sure that Antergos devs will update nemo-dropbox soon :) . They pay much attention to keep [antergos] repo up-to-date.

    Dropbox content is easily managed without nemo-dropbox extension.

  • Hi,

    There is no 3.2 version of nemo-dropbox yet:
    http://packages.linuxmint.com/pool/main/n/nemo-dropbox/

    But it seems that in github they already have a 3.2 (23 hours ago :p)
    https://github.com/linuxmint/nemo-extensions/tree/master/nemo-dropbox

    When I have the time, I’ll change the package PKGBUILD to build from github release instead of mint package sources.

    I’ll keep you posted.

  • @karasu Thanks a lot for your attention.

    I think there’s no hurry with nemo-dropbox update. There’s no need to change PKGBUILD to point to github, probably we can wait nemo-dropbox arrival to the regular Mint’s repo.

    Edit:

    I’ve said a stupid thing. The official repos must be constantly consistent, all the time. No package from official repos should conflict with another.

  • @just I’ve updated nemo-dropbox to get its source from linuxmint github (tag 3.2)

    Have a try when you have the time, please (give it some time for mirrors to update, the build server has just built the package).

    Cheers!

  • I am sorry. I do not want to open a new theme. Really is updating of Cinnamon already accessible in Antergos ?

    Russian fan club of Antergos

  • @tuxnot I’m not quite sure what are you asking about.

    Yes, some core Cinnamon packages got an upgrade from 3.0 to 3.2: cinnamon, cinnamon-desktop, cinnamon-session are among them. If you have no nemo-dropbox installed, then you can upgrade to 3.2 right now.

    If you’re asking about nemo-dropbox, then no. The package, upgraded by @karasu to 3.2 few minutes ago, has not reached (my) mirrors yet. Hence, I can’t upgrade it right now.

    Edit:

    Attention! Upgrading cinnamon package to 3.2 breaks Cinnamon shell themes: all dropdown menus loose the user defined theme and return to the the default Cinnamon theme.

    Place cinnamon-3.0 package on hold via IgnorePkg= before the upgrade, if you don’t want to loose the user theme.

    Please, do not discuss themes problem in this topic. If you’re interested in it, please, open a new topic.

  • @just Only these packages (screenshot) were updated for me. 0_1478627665468_Выделение_001.jpg
    For some reason there is no new version of Cinnamon. How I must change the server of updating on other ? example to yandex mirror.

    Russian fan club of Antergos

  • @tuxnot Run

    sudo reflector --age 8 --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist
    

    This will select the fastest mirrors - for you! - updatest in the last 8 hours. Hopefully, they will already have cinnamon 3.2. Or edit the mirrorlist by hand and place the Yandex server at the top of the list.

    Please, do not go off-topic. This one speaks about the conflict between neno and nemo-dropbox only. Open a new topic, if you wish.

  • @karasu said in Cinnamon: nemo and nemo-dropbox conflict:

    @just I’ve updated nemo-dropbox to get its source from linuxmint github (tag 3.2)

    Have a try when you have the time, please (give it some time for mirrors to update, the build server has just built the package).

    Cheers!

    It’s time to go to bed in my time zone, but pacman still doesn’t see nemo-dropbox-3.2. I found the Denmark server with 3.2 by hand, downloaded the package manually, and installed the local package. Now:

    $ pacman -Q cinnamon nemo nemo-dropbox
    cinnamon 3.2.1-1
    nemo 3.2.0-1
    nemo-dropbox 3.2.0-1
    $ 
    

    Though not a “clean” automatic upgrade, everything works very well. No conflicts arise during installation, nemo-dropbox nicely integrates with Nemo, and works as expected.

    Tomorrow morning (local), if pacman will see nemo-dropbox-3.2, will repeat everything from scratch to test a true, clean upgrade.

    G’night

    0_1478635167711_nemo-dropbox-part.png

  • nemo-dropbox v.3.2 has reached all mirrors now. If you have it installed, and upgrade nemo up to v.3.2, no conflict between nemo and nemo-dropbox arises anymore.

    Thanks to devs. The problem is Solved. The topic is closed.

cinnamon72 nemo-dropbox2 conflict7 nemo5 Posts 12Views 1323
Log in to reply