• [Pamac] Multiple words AUR search not working

    Hi guys,
    am I the only one that is experiencing the title issue?
    The main Github project page the multiple words search is explicitly declared as feature, but some months ago this feature didn’t worked anymore in all the arch-based distros I’ve tried, but I didn’t find any bug report for this bug.
    So is there something that am I doing wrong?

  • @el.Quero You can always fill an issue in their github… ;)

  • Shure @karasu, but I was asking if someone is experiencing the same issue… I’ll make a bug report ;)

  • @el.Quero Oh sorry. I didn’t get that. I do not use pamac myself, sorry. Let’s see what others say.


  • It’s working, but the search bar never was able to find all the proper packages; i guess is because the very short description of the packages.
    For example if you type “free library” you’ll see searching multiple words are working.
    The descriptions could include key-words to improve the search.

  • Well, I tried searching “free library”, but I didn’t get any result 😞.
    I’ve attached some screenshots for better explaining what I’m talking about.
    @fernandomaroto Did you get the same?
    2_1478773066073_Screenshot from 2016-11-10 11-13-53.png
    1_1478773066073_Screenshot from 2016-11-10 11-13-48.png
    0_1478773066072_Screenshot from 2016-11-10 11-13-43.png

  • @el.Quero: the word “bin” is not in the description nor in the name of the package ;) there is only “franz-bin” and “Franz”… but if you are searching for “bin” or “-bin” package will be find…

  • Sorry, I m not in Antergos now, but in the screenshots it is searching the AUR, not the repos. Have you tried both searches (official repos and AUR) and get the same issue?

  • @anarch, while you replied I was writing about that: I think that there is a bug because when I search in the official repos the space is interpreted as a word separator or a wildcard, as you can see in the image.
    0_1478774328896_Screenshot from 2016-11-10 11-38-34.png

  • Same issue also have this
    it do not take space and erase the first space when typing the next letter

  • @el.Quero
    Hi, i just retested searching “free lib” and it’s working

  • @fernandomaroto from the screen you posted seems that you are searching in official repositories, while the problem I’m experiencing is with AUR searches.
    I think I’ll fill up a bug report.

  • @el.Quero ah ok, i just tested and is not working indeed, only searching the package name.
    Go ahead, this fix will improve the pamac usage.

  • This is indeed a bug in Pamac. I’ve been meaning to file a bug report but havent got around to it yet 😬

pamac70 bug11 search9 Posts 14Views 2293
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.