• Cannot set a btrfs formatted bcache device as a mount point in Cnchi


    I have an existing (bcache) partition that I wanted to use as /home, but when attempting to install Antergos through Cnchi, the Add/Delete/Edit Partition buttons are greyed out, and double-clicking does not bring up the Edit Partition Popup, as it does with other partitions, so I am unable to select the partition to use as /home

  • Hi!
    As far as i remember clicking twice doesn’t work. You should click one time and search at left-bottom for something like "Edit partition"
    I’ll run some installation here and get back to you.

    Edit: Worked both double click and the “Edit” botom

    Did you create the new partition table?
    Cheers.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • @fernandomaroto Do I need to set a new partition table for a bcache device? The device already has a formatted partition on it, as I set it up beforehand.

    EDIT: Bcache replaces the block layer, so is it possible that Cnchi is just not recognising the partition table as valid?
    EDIT2: Creating a GPT partition table within the bcache device works, but since bcache itself does not support the use of partitions (/dev/bcache0p1 does not exist, no matter what cnchi thinks), and cnchi does not support Btrfs subvolumes, I will probably have to edit /etc/fstab in order to get it to use the bcache device as home.
    EDIT3: Did have to edit fstab, but it seems to work now.

  • @techno156 I tried just a basic installation on virtualbox, and i never tried to use a bcache.
    I’m glad you managed to find the solution hehehe.
    How exactly did you edit fstab? (if you post here you can help someone in the future with the same problem)
    Cheers.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

device17 btrfs13 bcache2 formatted1 Posts 4Views 758
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.