Well, I don t know if your hardware is that bleeding edge so that it needs the very latest kernel.Keep in mind that it was the latest kernel that caused the issue. Lts kernel doesn t mean obsolete/outdated, but more conservative, thus more stable. FYI the lts kernel got upgraded a day AFTER the current one was upgraded. Anyway, you can always uninstall it if it doesn t work