• Setting Keyboard-layout for lightdm-webkit2-greeter???


    I search and search … how can i change settings for lightdm-webkit-greeter?

    stuff like autologin keyboardlayout e.t.c…

    Only thing i find is this:
    https://doclets.io/Antergos/lightdm-webkit2-greeter/master
    and here:
    http://bazaar.launchpad.net/~lightdm-team/lightdm/trunk/view/head:/data/lightdm.conf

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • The answer is simple. LightDM uses the keyboard map defined in the /etc/vconsole.conf file. The same keyboard map is used in virtual terminals (Ctl+Alt+F1…7).

    For example, this sets English (US) leyboard to be used in LightDM:

    KEYMAP=us
    

    This one sets English (UK) keyabord for LigthDM and virtual terminals:

    KEYMAP=uk
    

    The country code is not an obvious choice. For example, gb is a wrong code for an English (UK) keyboard. uk is the correct one.

  • cat  /etc/vconsole.conf                                   
    
    KEYMAP=de
    

    but lightdm do not have this… (z=y)

    killajoe]# localectl status
       System Locale: LANG=de_DE.UTF-8
           VC Keymap: de
          X11 Layout: de
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • can or can’t someone reproduce this?

    Find this:
    https://bbs.archlinux.org/viewtopic.php?id=165381

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • Did you try the solution proposed in the post you linked?

    OK, it seems that lightdm finds the locale settings in /etc/environment.
    (According to this: http://www.freedesktop.org/wiki/Softwar … DM/Design/ ; look for /etc/environment)
    If I set the locale in that file, lightdm uses the correct locale.

  • @karasu no same as before lightdm does not take the locale…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

  • It should take the same layout as your GNOME system settings. Could you try installing GNOME Web (epiphany) and see if your keyboard layout works with it?

  • @lots.0.logs : when gnome is startet settings are working, also epiphany… it seems to effect only to the password field inside lightdm greeter (also gtk-greeter) … it looks loke lightdm is running by a different “user” ?

    [root@empowered64 lightdm]# ls
    Bilder  Dokumente  Downloads  Musik  Öffentlich  Schreibtisch  Videos  Vorlagen
    
    # id lightdm
    uid=620(lightdm) gid=620(lightdm) Gruppen=620(lightdm)
    
    lslogins lightdm
    Username:                           lightdm                             
    UID:                                620                                 
    Gecos field:                        Light Display Manager               
    Home directory:                     /var/lib/lightdm                    
    Shell:                              /usr/bin/nologin                    
    No login:                           yes                                 
    Password is locked:                 no                                  
    Password not required:              no                                  
    Login by password disabled:         yes                                 
    Primary group:                      lightdm                             
    GID:                                620                                 
    Hushed:                             no                                  
    Password expiration warn interval:  7                                   
    Password changed:                   Oct29/02:00                         
    Maximum change time:                99999                               
    Running processes:                  0                                   
    
    Last logs:
    03:38:39 systemd[380]: Stopped target Paths.
    03:38:39 systemd[380]: Received SIGRTMIN+24 from PID 485 (kill).
    03:38:39 systemd[381]: pam_unix(systemd-user:session): session closed for user lightdm
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3 GNOME

keyboard-layout3 Posts 8Views 892
Log in to reply