• USB keyboard is very unresponsive on boot menu


    Hi,

    I’ve an old laptop connected with an USB keyboard. I have both Antergos and Windows installed side-by-side and I’d like to run Windows when needed i.e. some Photoshop/Skype video etc.

    Whenever, I want to select Windows from the boot menu using down arrow keys, it often doesn’t work and sometimes it select the next option with a delay of 30-40 seconds.

    I’ve tried to edit /etc/mkinitcpio.conf and put keyboard before autodetect and ran the following and I’ve also tried to put autodetect at the end of HOOKS

    # mkinitcpio -p linux
    

    This didn’t help either.

    Here is my /etc/mkinitcpio.conf

    # vim:set ft=sh
    # MODULES
    # The following modules are loaded before any boot hooks are
    # run.  Advanced users may wish to specify all system modules
    # in this array.  For instance:
    #     MODULES="piix ide_disk reiserfs"
    MODULES=""
    
    # BINARIES
    # This setting includes any additional binaries a given user may
    # wish into the CPIO image.  This is run last, so it may be used to
    # override the actual binaries included by a given hook
    # BINARIES are dependency parsed, so you may safely ignore libraries
    BINARIES=""
    
    # FILES
    # This setting is similar to BINARIES above, however, files are added
    # as-is and are not parsed in any way.  This is useful for config files.
    FILES=""
    
    # HOOKS
    # This is the most important setting in this file.  The HOOKS control the
    # modules and scripts added to the image, and what happens at boot time.
    # Order is important, and it is recommended that you do not change the
    # order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
    # help on a given hook.
    # 'base' is _required_ unless you know precisely what you are doing.
    # 'udev' is _required_ in order to automatically load modules
    # 'filesystems' is _required_ unless you specify your fs modules in MODULES
    # Examples:
    ##   This setup specifies all modules in the MODULES setting above.
    ##   No raid, lvm2, or encrypted root is needed.
    #    HOOKS="base"
    #
    ##   This setup will autodetect all modules for your system and should
    ##   work as a sane default
    #    HOOKS="base udev autodetect block filesystems"
    #
    ##   This setup will generate a 'full' image which supports most systems.
    ##   No autodetection is done.
    #    HOOKS="base udev block filesystems"
    #
    ##   This setup assembles a pata mdadm array with an encrypted root FS.
    ##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
    #    HOOKS="base udev block mdadm encrypt filesystems"
    #
    ##   This setup loads an lvm2 volume group on a usb device.
    #    HOOKS="base udev block lvm2 filesystems"
    #
    ##   NOTE: If you have /usr on a separate partition, you MUST include the
    #    usr, fsck and shutdown hooks.
    HOOKS="base udev keyboard modconf block keymap resume filesystems fsck autodetect"
    
    # COMPRESSION
    # Use this to compress the initramfs image. By default, gzip compression
    # is used. Use 'cat' to create an uncompressed image.
    #COMPRESSION="gzip"
    #COMPRESSION="bzip2"
    #COMPRESSION="lzma"
    #COMPRESSION="xz"
    #COMPRESSION="lzop"
    #COMPRESSION="lz4"
    
    # COMPRESSION_OPTIONS
    # Additional options for the compressor
    #COMPRESSION_OPTIONS=""
    
  • It doesn’t seem to be a problem with the /etc/mkinitcpio/conf . Your file looks fine. (Though I’d place the autodetect hook after the keymap and before the resume ones. Otherwise, the autodetect hook is useless.)

    It might be a problem with a slow Grub 2 operation. Especially when it is used in a graphical mode. Especially on a slightly outdated hardware.

    Possible solutions:

    • use Grub 2 in text mode
    • switch to another boot loader. Grub 1 still remains an excellent alternative to bloated Grub 2.
boot282 usb108 keyboard73 unresponsive4 Posts 2Views 749
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.