• I can't install Vmware


    Hi!

    I’m trying to install Vmware but I can’t do it.
    This is the code:

    # sh ./VMware-Player-12.5.0-4352439.x86_64.bundle --console
    Extracting VMware Installer...done.
    User interface initialization failed.  Exiting.  Check the log for details.
    
    
    

    Then I go to see the error log and this is that contains

    2016-11-01T10:35:31.299+01:00| vthread-4| I125: Log for VMware Workstation pid=3969 version=12.5.0 build=build-4298805 option=Release
    2016-11-01T10:35:31.299+01:00| vthread-4| I125: The process is 64-bit.
    2016-11-01T10:35:31.299+01:00| vthread-4| I125: Host codepage=UTF-8 encoding=UTF-8
    2016-11-01T10:35:31.299+01:00| vthread-4| I125: Host is Linux 4.8.6-1-ARCH Arch Linux
    2016-11-01T10:35:31.297+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/etc/vmware/config": No such file or directory.
    2016-11-01T10:35:31.297+01:00| vthread-4| I125: PREF Optional preferences file not found at /etc/vmware/config. Using default values.
    2016-11-01T10:35:31.297+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory.
    2016-11-01T10:35:31.297+01:00| vthread-4| I125: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
    2016-11-01T10:35:31.297+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/usr/lib/vmware/config": No such file or directory.
    2016-11-01T10:35:31.297+01:00| vthread-4| I125: PREF Optional preferences file not found at /usr/lib/vmware/config. Using default values.
    2016-11-01T10:35:31.299+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/config": No such file or directory.
    2016-11-01T10:35:31.299+01:00| vthread-4| I125: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
    2016-11-01T10:35:31.299+01:00| vthread-4| I125: PREF Unable to check permissions for preferences file.
    2016-11-01T10:35:31.299+01:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/preferences": No such file or directory.
    2016-11-01T10:35:31.299+01:00| vthread-4| I125: PREF Failed to load user preferences.
    

    VirtualBox works fine for me but I need to install vmware because we are using it in school.
    I’m newbie using Linux and I don’t know how fix-it. I try to find solution in google and in the official arch web but i can’t solve it.

    Thank you for your time!

  • With Vmware always problems with installation, on Arch. I can offer such variant, must help, but I will not be able to check for itself.
    Installation:
    mkdir -p /etc/rc.d/vmware.d/{rc{0,1,2,3,4,5,6},init}.d
    sudo ./VMware-workstation-full-12.1.1-3770994.x86_64.bundle --custom --console -I --eulas-agreed
    Still necessary to make the reference ln -s /etc/init.d/vmware /etc/rc.d/vmware.d/init.d/vmware 4.8.4-1-ARCH #1 SMP PREEMPT

    Russian fan club of Antergos

  • @tuxnot said in I can't install Vmware:

    With Vmware always problems with installation, on Arch. I can offer such variant, must help, but I will not be able to check for itself.
    Installation:
    mkdir -p /etc/rc.d/vmware.d/{rc{0,1,2,3,4,5,6},init}.d
    sudo ./VMware-workstation-full-12.1.1-3770994.x86_64.bundle --custom --console -I --eulas-agreed
    Still necessary to make the reference ln -s /etc/init.d/vmware /etc/rc.d/vmware.d/init.d/vmware 4.8.4-1-ARCH #1 SMP PREEMPT

    Thank you but doesen’t work for me 😞 I try to use virtualbox and import/export virtualmachines.

vmware16 Posts 3Views 2775
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.