• Still booting straight into Windows


    Hey guys,
    I’m kind of new to Antergos but I thought it looks pretty well, so I tried to install it yesterday. Since I am rather new to GNU/Linux I was using an Tutorial (this one: https://itsfoss.com/dual-boot-antergos-windows-uefi/ ). I was pretty much following this exact steps with some exceptions. I was using my Androidphone with DriveDroid instead of an Live-USB. And of course I used some diefferent sizes for my partitions. Only thing that seemed to be a little different, was the fact, that my efi-patition was not labeld as such (It was the only one formated in fat32 tough, so I am pretty sure it was the right one). Installation seemed to go pretty well, in the end t told me installation completed, please reboot. So that’s what I did. But after reboot it was not Grub showing up, but still Windows. So in Boot Menu I tried to select the SSD as booting device instead of “Windows Boot Manager”… still only Windows that is booting.
    Any suggestions? (Yes I disabled fast boot as well as secure boot).
    By the way: My Laptop is a Thinkpad E460
    Thanks already!

  • @joelo1996 said
    Manager”… still only Windows that is booting.

    Hu. I hanen t been using Windows since the notorious Vista and don t really have much experience on this. But do you remember where was GRUB installed? There was an ortion showing it during partitioning.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I don’t think there was an option (or maybe I missed it) where I could select the location for grub. I could only select the boot partition, which I mounted to /boot/efi.

  • Well, actually there is. If you look at the partitioning screenshots of your link, you can see the option to choose bootloader & its location at the very bottom of the wizzard. Maybe it was set on the live media? Is there another HD/ssd?
    I m just trying to guess.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Okay, sorry you’re right, there indeed is an option. Just to make sure I went through the hole process again and made sure the right drive was selected to install grub.
    But still grub is not showing up during boot :(

  • Sorry to hear that. As I said I m not the one to be asked about Windows. I hope someone else with this experience comes up with a solution .
    I don t know if using a live usb/cd instead of theDrivedroid would make any differevce.
    *Can you see Antergos in your disk?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @joelo1996 said in Still booting straight into Windows:

    Hey guys,
    I’m kind of new to Antergos but I thought it looks pretty well, so I tried to install it yesterday. Since I am rather new to GNU/Linux I was using an Tutorial (this one: https://itsfoss.com/dual-boot-antergos-windows-uefi/ ). I was pretty much following this exact steps with some exceptions. I was using my Androidphone with DriveDroid instead of an Live-USB. And of course I used some diefferent sizes for my partitions. Only thing that seemed to be a little different, was the fact, that my efi-patition was not labeld as such (It was the only one formated in fat32 tough, so I am pretty sure it was the right one). Installation seemed to go pretty well, in the end t told me installation completed, please reboot. So that’s what I did. But after reboot it was not Grub showing up, but still Windows. So in Boot Menu I tried to select the SSD as booting device instead of “Windows Boot Manager”… still only Windows that is booting.
    Any suggestions? (Yes I disabled fast boot as well as secure boot).
    By the way: My Laptop is a Thinkpad E460
    Thanks already!

    You could put a screenshot, entering windows, in part to create and format disks, to know how the disk is partitioned?

    So we could help better!

    Autodidacta en la VIDA …y en Linux, también.

  • I have been doing this for a while now and it works perfectly. It is written for ubuntu, but it works for any linux that windows insists on taking the boot away. just make sure to enter the correct path to the proper efi file for your antergos boot.

    Right click on the start button and choose administrator command prompt

    Type mountvol g: /s (This maps your EFI folder structure to the G drive).

    Type cd g:\EFI

    Type dir g:\EFI.
    There should be options for bootx64.efi

    Run the following command to set /boot/efi/EFI/boot/bootx64.efi as the bootloader:

    bcdedit /set {bootmgr} path /boot/efi/EFI/boot/bootx64.efi this is the important command

    Reboot your computer

    You should now have a GRUB menu appear with options for Ubuntu and Windows.
    If your computer still boots straight to Windows repeat steps 1 through 7 again but this time type:

    bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

    Reboot your computer

    Keep this handy as I have to give this command everytime windows does a major update.

  • @jeb0921 , well done! I think this deserves a place in our wiki, don t you think so?
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @judd
    0_1477853273807_upload-cd7ca0ea-8f06-4d89-948c-142bb5ab707c
    do you mean this scrennshot? Unfortunately it is in german, hope you can get the information you need :)

  • @jeb0921 Hey, thanks a lot, sounds like a good way. Unfortunately I am already failing at the first steps. When I type cd g:\EFI nothing is happening, when I type “dir” cmd is listing all files in the current directory (in my case win32). When I type dir c:\EFI it is showing me a directory “Microsoft” and a directory “Boot”. Neither of them contains any grub-related files :(

  • looks like on arch the location is

    /boot/efi/EFI/boot/bootx64.efi

    I also noticed that just listing the dir of g: gives the regular system list. So do dir g:/boot or g:/EFI intead

    the fix is
    bcdedit /set {bootmgr} path \EFI\path\to\app.efi

    the main thing is to get the path set to the location of the bootx64.efi file and it will work.

  • Hey guys, sorry fot not replying for some time, I have been quite busy…
    so, I tried exactly this, and indeed in g:\EFI\Boot there is a file bootx64.efi.
    So I entered the following bcdedit /set {bootmgr} path g:\EFI\Boot\bootx64.efi and the output told me it was done succesfully, but Windows is still booting after every reboot. :( I would like to install it so bad!

  • Hi,

    I have the exact same problem. After installing with the dual boot guide, the system boots automatically to Windows 10 and I have no GRUB showing. The solution mentioned above didn’t seem to work. Have you found a solution?

  • @joelo1996 : Just for reference, could you post your BIOS boot order?

    @j4miol : Post your BIOS boot order + what your disk partitioning looks like?

  • I ended up deciding I don’t really need Windows on my laptop, and installed Antergos alone. Works like a charm.

    BIOS boot order was just one SSD (laptop). The partitioning was if I recall correctly:
    sda1 [windows made] fat32 SYSTEM ~200MB mounted as /boot/efi
    sda2 [windows made] ? 17MB not mounted (dunno what it was)
    sda3 [windows main partition] NTFS 100GB not mounted
    sda4 ext4 20GB primary mounted as /
    sda5 ext4 100GB mounted as /home
    sda6 swap 4GB

  • @j4miol said

    I ended up deciding I don’t really need Windows on my laptop, and installed Antergos alone

    A very wise decision, indeed!!!:heart:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

windows37 straight2 booting21 Posts 17Views 1351
Log in to reply