• Latest system upgrade broke my system


    Good day,

    I was running Antergos with the Cinnamon desktop on my laptop Acer Aspire E15 A10-8700P Radeon R8-M365DX, and after upgrading to the latest system my laptop won’t boot to the desktop.

    Using the terminal, I ran:
    sudo pacman -Syyu

    Once the update was finished, I rebooted the computer and after showing various scripts running, it finished by displaying a black screen with a dialog box saying "Failed to load session “cinnamon” with a “Log Out” button beneath. The mouse doesn’t work, so I can’t click on “Log Out.”

    I suspect I’ll have to boot up with a Live USB to fix it. I’ve downloaded the latest ISO; will I have to re-install the system, or is there a script I can fix, somewhere? If it’s a problem with the Cinnamon desktop, perhaps I should choose Gnome or XFCE this time?

    I’m not sure this problem only happened to me, which is why I’m posting it.

    Thanks,
    Trevor

  • Boot and use the Fallback kernel. It will take you the command line, I think. Then you can starting the DM (lightdm, sdd, gdm, whatever and troubleshoot from there.

  • @tb67 It could be a kernel problem or something with your drivers. But maybe some of my ideas below might help.

    You probably don’t have to reinstall the system if you want to check out e.g. Xfce.
    When you are at the black screen press: ctl-alt-F2
    This will give you a virtual console. You will be asked to login first. After login give the following command: sudo pacman -S xfce4
    You will be asked if you want to install by default. Just press enter.
    After installation reboot and see if you get to the Display manager login screen. If not try to change your Display manager. Install GDM or SDDM and activate them. Or try to start the xsession by going to the console again and enter: startxfwm4

    You could also try to install the new lightDM display manager.
    sudo pacman -S lightdm-webkit2-greeter-next
    Ultimately you could try to reinstall Cinnamon with the same command as for Xfce; just replace Xfce with cinnamon. (or remove it)

    Never to old to learn.

  • Hi,

    I sincerely appreciate the helpful suggestions. I tried to access the virtual console with ctl-alt-F2, but that didn’t work. I was next going to try to access the fallback kernel, but when I rebooted I got a new error: Unknown filesystem with a grub rescue> prompt.

    I’m just going to re-install the system. Because I’d just installed the Antergos system on my laptop a couple weeks ago, and my laptop isn’t my primary computer, this isn’t too much of a hassle. However, I’d be very unhappy, indeed, if this had happened to my primary system. I liked the looks and functionality of the Cinnamon desktop, but now my confidence in that desktop is shaken (when used by my particular model of Acer laptop) and I think I’ll try another desktop.

    Again, thanks for the help.

    Trevor

  • I apologize for being a bit abrupt, but by re-installing you haven’t learned anything. This is basically an Arch system and occasionally it might break. So you troubleshoot, not re-install.
    You could have done this with the Live DVD
    You can boot using the Live ISO and fix grub like this:[command:2f9vrady]su
    pacman -S arch-install-scripts --noconfirm
    mount /dev/sda2 /mnt
    arch-chroot /mnt
    grub-install --target=i386-pc --recheck --debug /dev/sda

    Heck, you can even install another kernel

    mount /dev/sdaX /mnt/boot # If you chose to have your /boot on separate partition, you must mount it as well
    exit

  • i dont think a reinstall is such a bad idea. sometimes things get so messed up sometimes a fresh install is the best :+1:

    @tb67 if you like Cinnamon try Gnome with a few extensions you can get it looking like a desktop again.

    mate has been looking great of late of also. KDE another good desktop that is a desktop.

  • Thanks for the suggestions, and no need to apologize.

    As it is, the newest version of the Live DVD freezes my laptop once it’s booted up, and I can’t open a terminal. I tried all the other options before the boot starts to try to get to a non-GUI interface, and they all throw /vmlinuz not found errors. I’m not an advanced user, and while I completely understand I need to ‘do’ in order to learn, this is more effort than I want to expend. I simply chose the wrong distribution for my needs–perhaps the Debian/Ubuntu-based Mint is a better fit for me. I just thought Arch was more lean & mean, if that’s the right term, and I liked that idea.

    Again, I appreciate all the help, and I’m sorry if I wasted anyone’s time.

    Regards,
    Trevor

broke11 upgrade39 cinnamon68 system55 Posts 7Views 750
Log in to reply