• "pci : Failed to adjust lnkctl speed" while antergos installation


    Hi there, I have tried to install antergos on dual boot with windows 10 on my MSI gl62 6qf with a GTX960m.
    But I can’t start antergos live and the error was :
    nouveau pci : Failed to adjust lnkctl speed
    I tried the both installs : minimal and normal.
    Someone can help me ?

  • Using the normal ISO, try to boot adding this parameter to the boot line:

    modprobe.blacklist=nouveau
    
  • Thanks for your reply
    where can I add this ?

    1. Start from the Live media

    2. You’re at the Antergos startup screen, with some options to boot Antergos in different modes

    3. Don’t move the selection, leave it on the default option

    4. Press Tab key once

    5. Boot line is displayed at the bottom of the screen. It is possible to edit it as you wish.

    6. Without modifiying the existing, default parameters, simply add modprobe.blacklist=nouveau at the end of the line

    7. Press Enter to boot with the modified boot line

  • Thank you, it’s work fine.
    In order to edit the boot options I hit the e key not tab. But finaly I got the same result.

  • Most probably you’ll face the problem on the installed system.

    Nouveau driver is a total disaster for Optimus cards, like yours.

    To avoid the problem, you should:

    • either add the same parameter to Grub 2 boot line in the permanent way

    • or, much better, uninstall the malefic xf86-video-nouveau driver on the first boot of the installed system

adjust2 lnkctl1 speed4 pci1 Posts 6Views 2412
Log in to reply