• "Unable to start services." vmware installation fails


    So first says “Before you can run VMware, several modules must be compiled and loaded into the running kernel.” I click install there wait for a second or two and see this error message “Unable to start services. See log file /tmp/vmware-root/vmware-8302.log for details.”

    Here is that log file. (I downloaded vmware as .bundle file from vmware’s website.)

    2016-10-24T12:54:36.588+02:00| vthread-4| I125: Log for VMware Workstation pid=8302 version=12.1.1 build=build-3770994 option=Release
    2016-10-24T12:54:36.588+02:00| vthread-4| I125: The process is 64-bit.
    2016-10-24T12:54:36.588+02:00| vthread-4| I125: Host codepage=UTF-8 encoding=UTF-8
    2016-10-24T12:54:36.588+02:00| vthread-4| I125: Host is Linux 4.8.4-1-ARCH Antergos Linux release 16.9 (Minimal-ISO-Rolling)
    2016-10-24T12:54:36.587+02:00| vthread-4| I125: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory.
    2016-10-24T12:54:36.587+02:00| vthread-4| I125: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
    2016-10-24T12:54:36.588+02:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/config": No such file or directory.
    2016-10-24T12:54:36.588+02:00| vthread-4| I125: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
    2016-10-24T12:54:36.588+02:00| vthread-4| I125: PREF Unable to check permissions for preferences file.
    2016-10-24T12:54:36.588+02:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/preferences": No such file or directory.
    2016-10-24T12:54:36.588+02:00| vthread-4| I125: PREF Failed to load user preferences.
    2016-10-24T12:54:36.594+02:00| vthread-4| W115: Logging to /tmp/vmware-root/vmware-8302.log
    2016-10-24T12:54:36.622+02:00| vthread-4| I125: Obtaining info using the running kernel.
    2016-10-24T12:54:36.622+02:00| vthread-4| I125: Created new pathsHash.
    2016-10-24T12:54:36.622+02:00| vthread-4| I125: Setting header path for 4.8.4-1-ARCH to "/lib/modules/4.8.4-1-ARCH/build/include".
    2016-10-24T12:54:36.622+02:00| vthread-4| I125: Validating path "/lib/modules/4.8.4-1-ARCH/build/include" for kernel release "4.8.4-1-ARCH".
    2016-10-24T12:54:36.622+02:00| vthread-4| I125: Failed to find /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h
    2016-10-24T12:54:36.622+02:00| vthread-4| I125: /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h$
    2016-10-24T12:54:36.622+02:00| vthread-4| I125: using /sbin/gcc for preprocess check
    2016-10-24T12:54:36.633+02:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.8.4-1-ARCH".
    2016-10-24T12:54:36.633+02:00| vthread-4| I125: The header path "/lib/modules/4.8.4-1-ARCH/build/include" for the kernel "4.8.4-1-ARCH" is valid.  Whoohoo!
    2016-10-24T12:54:36.697+02:00| vthread-4| I125: found symbol version file /lib/modules/4.8.4-1-ARCH/build/Module.symvers
    2016-10-24T12:54:36.697+02:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.8.4-1-ARCH/build/Module.symvers.
    2016-10-24T12:54:36.719+02:00| vthread-4| I125: Read 19267 symbol versions
    2016-10-24T12:54:36.720+02:00| vthread-4| I125: Reading in info for the vmmon module.
    2016-10-24T12:54:36.720+02:00| vthread-4| I125: Reading in info for the vmnet module.
    2016-10-24T12:54:36.720+02:00| vthread-4| I125: Reading in info for the vmblock module.
    2016-10-24T12:54:36.720+02:00| vthread-4| I125: Reading in info for the vmci module.
    2016-10-24T12:54:36.720+02:00| vthread-4| I125: Reading in info for the vsock module.
    2016-10-24T12:54:36.720+02:00| vthread-4| I125: Setting vsock to depend on vmci.
    2016-10-24T12:54:36.720+02:00| vthread-4| I125: Invoking modinfo on "vmmon".
    2016-10-24T12:54:36.725+02:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-24T12:54:36.725+02:00| vthread-4| I125: Invoking modinfo on "vmnet".
    2016-10-24T12:54:36.729+02:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-24T12:54:36.729+02:00| vthread-4| I125: Invoking modinfo on "vmblock".
    2016-10-24T12:54:36.733+02:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-24T12:54:36.733+02:00| vthread-4| I125: Invoking modinfo on "vmci".
    2016-10-24T12:54:36.737+02:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-24T12:54:36.737+02:00| vthread-4| I125: Invoking modinfo on "vsock".
    2016-10-24T12:54:36.740+02:00| vthread-4| I125: "/sbin/modinfo" exited with status 0.
    2016-10-24T12:54:36.763+02:00| vthread-4| I125: to be installed: vmmon status: 0
    2016-10-24T12:54:36.763+02:00| vthread-4| I125: to be installed: vmnet status: 0
    2016-10-24T12:54:36.772+02:00| vthread-4| I125: Obtaining info using the running kernel.
    2016-10-24T12:54:36.772+02:00| vthread-4| I125: Setting header path for 4.8.4-1-ARCH to "/lib/modules/4.8.4-1-ARCH/build/include".
    2016-10-24T12:54:36.772+02:00| vthread-4| I125: Validating path "/lib/modules/4.8.4-1-ARCH/build/include" for kernel release "4.8.4-1-ARCH".
    2016-10-24T12:54:36.772+02:00| vthread-4| I125: Failed to find /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h
    2016-10-24T12:54:36.772+02:00| vthread-4| I125: /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h$
    2016-10-24T12:54:36.772+02:00| vthread-4| I125: using /sbin/gcc for preprocess check
    2016-10-24T12:54:36.786+02:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.8.4-1-ARCH".
    2016-10-24T12:54:36.786+02:00| vthread-4| I125: The header path "/lib/modules/4.8.4-1-ARCH/build/include" for the kernel "4.8.4-1-ARCH" is valid.  Whoohoo!
    2016-10-24T12:54:36.847+02:00| vthread-4| I125: found symbol version file /lib/modules/4.8.4-1-ARCH/build/Module.symvers
    2016-10-24T12:54:36.847+02:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.8.4-1-ARCH/build/Module.symvers.
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: Read 19267 symbol versions
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: Kernel header path retrieved from FileEntry: /lib/modules/4.8.4-1-ARCH/build/include
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: Update kernel header path to /lib/modules/4.8.4-1-ARCH/build/include
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: Validating path "/lib/modules/4.8.4-1-ARCH/build/include" for kernel release "4.8.4-1-ARCH".
    2016-10-24T12:54:36.772+02:00| vthread-4| I125: Failed to find /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h
    2016-10-24T12:54:36.772+02:00| vthread-4| I125: /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h$
    2016-10-24T12:54:36.772+02:00| vthread-4| I125: using /sbin/gcc for preprocess check
    2016-10-24T12:54:36.786+02:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.8.4-1-ARCH".
    2016-10-24T12:54:36.786+02:00| vthread-4| I125: The header path "/lib/modules/4.8.4-1-ARCH/build/include" for the kernel "4.8.4-1-ARCH" is valid.  Whoohoo!
    2016-10-24T12:54:36.847+02:00| vthread-4| I125: found symbol version file /lib/modules/4.8.4-1-ARCH/build/Module.symvers
    2016-10-24T12:54:36.847+02:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.8.4-1-ARCH/build/Module.symvers.
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: Read 19267 symbol versions
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: Kernel header path retrieved from FileEntry: /lib/modules/4.8.4-1-ARCH/build/include
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: Update kernel header path to /lib/modules/4.8.4-1-ARCH/build/include
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: Validating path "/lib/modules/4.8.4-1-ARCH/build/include" for kernel release "4.8.4-1-ARCH".
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: Failed to find /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h$
    2016-10-24T12:54:36.869+02:00| vthread-4| I125: using /sbin/gcc for preprocess check
    2016-10-24T12:54:36.898+02:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.8.4-1-ARCH".
    2016-10-24T12:54:36.898+02:00| vthread-4| I125: The header path "/lib/modules/4.8.4-1-ARCH/build/include" for the kernel "4.8.4-1-ARCH" is valid.  Whoohoo!
    2016-10-24T12:54:36.901+02:00| vthread-4| I125: Found compiler at "/sbin/gcc"
    2016-10-24T12:54:36.912+02:00| vthread-4| I125: Got gcc version "6.2.1".
    2016-10-24T12:54:36.912+02:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2016-10-24T12:54:36.913+02:00| vthread-4| I125: Using user supplied compiler "/sbin/gcc".
    2016-10-24T12:54:36.921+02:00| vthread-4| I125: Got gcc version "6.2.1".
    2016-10-24T12:54:36.921+02:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2016-10-24T12:54:36.925+02:00| vthread-4| I125: Trying to find a suitable PBM set for kernel "4.8.4-1-ARCH".
    2016-10-24T12:54:36.925+02:00| vthread-4| I125: No matching PBM set was found for kernel "4.8.4-1-ARCH".
    2016-10-24T12:54:36.926+02:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
    2016-10-24T12:54:36.926+02:00| vthread-4| I125: Validating path "/lib/modules/4.8.4-1-ARCH/build/include" for kernel release "4.8.4-1-ARCH".
    2016-10-24T12:54:36.926+02:00| vthread-4| I125: Failed to find /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h
    2016-10-24T12:54:36.926+02:00| vthread-4| I125: /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h$
    2016-10-24T12:54:36.926+02:00| vthread-4| I125: using /sbin/gcc for preprocess check
    2016-10-24T12:54:36.945+02:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.8.4-1-ARCH".
    2016-10-24T12:54:36.964+02:00| vthread-4| I125: The header path "/lib/modules/4.8.4-1-ARCH/build/include" for the kernel "4.8.4-1-ARCH" is valid.  Whoohoo!
    2016-10-24T12:54:36.965+02:00| vthread-4| I125: Using temp dir "/tmp".
    2016-10-24T12:54:36.968+02:00| vthread-4| I125: Obtaining info using the running kernel.
    2016-10-24T12:54:36.968+02:00| vthread-4| I125: Setting header path for 4.8.4-1-ARCH to "/lib/modules/4.8.4-1-ARCH/build/include".
    2016-10-24T12:54:36.968+02:00| vthread-4| I125: Validating path "/lib/modules/4.8.4-1-ARCH/build/include" for kernel release "4.8.4-1-ARCH".
    2016-10-24T12:54:36.968+02:00| vthread-4| I125: Failed to find /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h
    2016-10-24T12:54:36.968+02:00| vthread-4| I125: /lib/modules/4.8.4-1-ARCH/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h$
    2016-10-24T12:54:36.968+02:00| vthread-4| I125: using /sbin/gcc for preprocess check
    2016-10-24T12:54:36.989+02:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.8.4-1-ARCH".
    2016-10-24T12:54:36.989+02:00| vthread-4| I125: The header path "/lib/modules/4.8.4-1-ARCH/build/include" for the kernel "4.8.4-1-ARCH" is valid.  Whoohoo!
    2016-10-24T12:54:37.057+02:00| vthread-4| I125: found symbol version file /lib/modules/4.8.4-1-ARCH/build/Module.symvers
    2016-10-24T12:54:37.057+02:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.8.4-1-ARCH/build/Module.symvers.
    2016-10-24T12:54:37.079+02:00| vthread-4| I125: Read 19267 symbol versions
    2016-10-24T12:54:37.079+02:00| vthread-4| I125: Invoking modinfo on "vmmon".
    2016-10-24T12:54:37.084+02:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-24T12:54:37.084+02:00| vthread-4| I125: Invoking modinfo on "vmnet".
    2016-10-24T12:54:37.089+02:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
    2016-10-24T12:54:37.639+02:00| vthread-4| I125: Setting destination path for vmmon to "/lib/modules/4.8.4-1-ARCH/misc/vmmon.ko".
    2016-10-24T12:54:37.639+02:00| vthread-4| I125: Extracting the vmmon source from "/usr/lib/vmware/modules/source/vmmon.tar".
    2016-10-24T12:54:37.644+02:00| vthread-4| I125: Successfully extracted the vmmon source.
    2016-10-24T12:54:37.645+02:00| vthread-4| I125: Building module with command "/sbin/make -j4 -C /tmp/modconfig-HDWzzf/vmmon-only auto-build HEADER_DIR=/lib/m$
    2016-10-24T12:54:40.216+02:00| vthread-4| W115: Failed to build vmmon.  Failed to execute the build command.
    2016-10-24T12:54:40.220+02:00| vthread-4| I125: Setting destination path for vmnet to "/lib/modules/4.8.4-1-ARCH/misc/vmnet.ko".
    2016-10-24T12:54:40.220+02:00| vthread-4| I125: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
    2016-10-24T12:54:40.231+02:00| vthread-4| I125: Successfully extracted the vmnet source.
    2016-10-24T12:54:40.231+02:00| vthread-4| I125: Building module with command "/sbin/make -j4 -C /tmp/modconfig-HDWzzf/vmnet-only auto-build HEADER_DIR=/lib/m$
    2016-10-24T12:54:42.675+02:00| vthread-4| W115: Failed to build vmnet.  Failed to execute the build command.
    
  • @TheKardinals I once tried running vmware and it was a pain in the ass, to be honest.

    It seems that you system can’t build the vmware modules for your kernel, but I do not know why.

    Check that you have the package linux-headers installed, that is a must.

    More than that I’m unable to help.

    By the way, do you really need vmware? Can’t use another system like virtualbox? (it’s easier to setup).

    Cheers!

  • Maybe it is necessary to install open-vm-tools ?

    Russian fan club of Antergos

  • I already have linux-headers and linux-lts-headers. I also do have open-vm-tools.

    This is why I’m not using virtualbox. Seems like I will have issues no matter what VM I use.
    I used to fix this easily just by installing some packages from archlinux.org but linux44-headers is now missing and that was one of those packages.

    EDIT: actually I made vbox working, just had to restart 😄
    alt text

  • With it never will be problems if to install it under the instruction. It is checked up many times. https://forum.antergos.com/topic/1102/how-to-install-virtualbox-in-antergos-tutorial

    Russian fan club of Antergos

  • @karasu @tuxnot cool. But now I have slow wifi after a new kernel upgrade. The problems never stop it seems. 😞

    Gonna downgrade it to linux-firmware-20150527.3161bfa-1-any.pkg.tar.xz like I saw someone else fix it this way. Do you suggest me using manjaro-settings-manager to do this or put the live usb of antergos and do it like it says here? https://wiki.archlinux.org/index.php/downgrading_packages#Downgrading_the_kernel

  • You can always install the LTS kernel… (linux-lts and linux-lts-headers)

  • In another Arch system it happened to me that logrotate service was unable to start. Giving the same Cannot open file error as yours.

    Looking at boot log with journalctl -xb I found a message about the missing file. Actually, it was not a file but a directory.

    Creating the missing dir by hand has solved the problem. logrotate service starts properly now.

    You could try to create by hand those missing files/dirs.

  • @just I made virtualbox working so it’s cool now. I just wanted a VM doesn’t matter which one. I was used to vmware on windows so it was obvious why I went with it first every time.

    @karasu installing the LTS kernel replaces the current one and sets it as default? I already do have linux-lts-4.4.27-1 installed.

    This guy here said downgrading the kernel helped him so might help me as well but it’s completely off topic here.

  • @TheKardinals said in "Unable to start services." vmware installation fails:


    @karasu installing the LTS kernel replaces the current one and sets it as default? I already do have linux-lts-4.4.27-1 installed.

    No, it does not.

    As @anarch explains here, if you have both current and LTS kernels, then the current one is the default, and the LTS is found in “Advaced options”.

    I don’t use neither LTS nor Grub 2, so @anarch is undoubtly more expert in the question.

  • Hi from me,too. What I said in that occasion applied to a new OS installation only, not in the case of adding the lts kernel after installation. In case of a post-installation, the lts kernel becomes the default kernel.
    But, @TheKardinals you said

    already do have linux-lts-4.4.27-1 installed.

    so no need to install it. That s the one and you should see it in the advanced option. t

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • You re welcome!👍

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

installation264 unable59 vmware16 services2 Posts 13Views 5311
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.